Автор Тема: Ошибка при установке через apt-get  (Прочитано 6219 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Ошибка при установке через apt-get
« : 23 Марта 2014, 10:45:31 »
Всем привет. Проблема возникла после того как я обновил Debian. Перестали коректно устанавливатся пакеты. Требует понизить версию libc6.

The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (< 2.18) but 2.18-4 is to be installed
 libc6-dev : Depends: libc6 (= 2.17-97) but 2.18-4 is to be installed
 libc6-i386 : Depends: libc6 (= 2.17-97) but 2.18-4 is to be installed

Пытаюсь переустановить но вслед тянутся еще тучи зависимостей. Не подскажите как это сделать проще и так что бы не убить систему, сервер находится удаленно.

P.S. Еще вылазит вот это, постоянно.

N: Ignoring file 'install.sh' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #1 : 23 Марта 2014, 10:53:39 »
rotorgames, у Вас установлен и , скорее всего, зафиксирован какой-то пакет, которому нужны текущие версии libc. Запускайте aptitude и просматривайте конфликты.

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #2 : 23 Марта 2014, 10:58:38 »
qupl, Спасибо за быстрый ответ. Да так оно и есть. Только я не знаю как с этим боротся.

1395557818-clip-20kb

Сообщение объединено: [time]23 Март 2014, 13:35:38[/time]
qupl, Вот что выдаёт когда я пытаюсь обновить (u).

1395560097-clip-16kb

*Руководство по добавлению изображений на форум, qupl
« Последнее редактирование: 23 Марта 2014, 11:44:21 от qupl »
 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #3 : 23 Марта 2014, 11:42:13 »
От root или sudo
gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553
gpg -a --export 8B48AD6246925553 | apt-key add -

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #4 : 23 Марта 2014, 11:45:17 »
qupl,

gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553

gpg: requesting key 46925553 from hkp server pgpkeys.mit.edu
gpg: key 46925553: public key "Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmaster@debian.org>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

gpg -a --export 8B48AD6246925553 | apt-key add -
OK
 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #5 : 23 Марта 2014, 11:47:14 »
Пробуйте обновляться.

Если проблема не решится покажите
cat /etc/apt/sources.list
aptitude search "~ahold"
lsb_release -a
uname -a

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #6 : 23 Марта 2014, 11:50:38 »
P.S.
Попробовал нажать (g). И вот что получилось.

1395560837-clip-25kb

Теперь нету того что на первом скрине. Но все по прежнему не работает.

cat /etc/apt/sources.list
#deb http://ftp.de.debian.org/debian-archive/debian lenny main contrib non-free
#deb http://ftp.de.debian.org/debian-archive/debian-volatile lenny/volatile main contrib non-free
#deb http://ftp.de.debian.org/debian-archive/debian-security lenny/updates main contrib non-free
deb http://ftp.de.debian.org/debian/ jessie main contrib non-free

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux unstable (sid)
Release:        unstable
Codename:       sid

uname -a
Linux user204 2.6.32-bpo.5-vserver-amd64 #1 SMP Thu Oct 21 12:40:47 UTC 2010 x86_64 GNU/Linux

aptitude search "~ahold" ничего не вывел.


 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #7 : 23 Марта 2014, 12:06:26 »
rotorgames, ничего непонятно. Вы с lenny до какой версии начали обновляться?  Текущее ядро из backports lenny, в источниках jessie, а релиз unstable(sid).

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #8 : 23 Марта 2014, 12:12:56 »
qupl, Я уже сам запутался. Обновлял где то год назад может больше. jessie это я недавно прописал. Обнавлялся скорей всего с
#deb http://ftp.de.debian.org/debian-archive/debian lenny main contrib non-free
 

Оффлайн ferum

Re: Ошибка при установке через apt-get
« Ответ #9 : 23 Марта 2014, 12:22:43 »
rotorgames, Задавая подобные вопросы я бы начал с пред истории типа стояла debian lenni с ядром из бэкпортов решил обновиться сразу до jessie вот что получилось.
Во первых обновлять систему следует не ай бы как http://4debian.info/hdbk/ch-wheezy/
Во вторых от релиза к релизу некоторые библиотеки могут удаляться и добавляться, соответственно и зависимости. Например в jessie уже нет ia32-libs  а есть multiarch-support
Русские дебианщики против цифрового слабоумия !
 

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #10 : 23 Марта 2014, 12:27:03 »
ferum, Спасибо что поправил, я первый день на форуме. Когда обновлял debian я вообще не понимал что делаю. Главное для меня было установить npm и nodejs. Видимо тогда и наломал дров.

Сообщение объединено: 23 Марта 2014, 12:28:04
P.S. Если есть возможность как то поправить apt-get буду очень признателен за помощь.
 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #11 : 23 Марта 2014, 12:41:49 »
Во первых обновлять систему следует не ай бы как http://4debian.info/hdbk/ch-wheezy/
Или из первоисточника на примере 6=>7 wiki.
Я бы поэтапно обновлял lenny - squeeze - wheezy - jessie.

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #12 : 23 Марта 2014, 12:46:29 »
qupl, ferum, Так что мне лучше сейчас предпринять. Откатится до lenny или просто попробывать откатить этот libc6?
 

Оффлайн qupl

Re: Ошибка при установке через apt-get
« Ответ #13 : 23 Марта 2014, 12:48:45 »
5=>6 - но он Вам наверное не пригодится. Ваша система где-то между 6 и 7 версией, как мне кажется.

Требуемые Вам пакеты есть только в jessie, так что обновление необходимо.

Оффлайн rotorgames

  • Пользователь
  • *
  • Сообщений: 12
Re: Ошибка при установке через apt-get
« Ответ #14 : 23 Марта 2014, 13:01:33 »
qupl, Это можно как то сделать с учетом что у меня не работает apt-get?
 

Теги:
     

    Ошибка при компиляции в Lazarus

    Автор flyer

    Ответов: 3
    Просмотров: 2706
    Последний ответ 22 Сентября 2014, 13:15:00
    от flyer
    Ошибка при обновлении Debian 8 до Debian 9

    Автор Ferox2017

    Ответов: 4
    Просмотров: 1771
    Последний ответ 21 Июня 2017, 10:54:52
    от qupl
    [РЕШЕНО] Ошибка в kwrite или нет?

    Автор Metrix

    Ответов: 3
    Просмотров: 2660
    Последний ответ 08 Марта 2011, 00:38:52
    от Ghostdmn
    При выполнении команды update-grub ошибка not foundrub-mkconfig: 5

    Автор Bojokot

    Ответов: 1
    Просмотров: 1635
    Последний ответ 24 Сентября 2017, 14:47:07
    от Juriy
    Ошибка с locale

    Автор diefair

    Ответов: 0
    Просмотров: 1564
    Последний ответ 28 Октября 2014, 15:43:21
    от diefair