Автор Тема: Не запускается установка (с флешки/диска)  (Прочитано 23048 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CROSP

  • Новичок форума
  • Сообщений: 3
Здравствуйте, вот захотел установить Debian. Но к сожалению даже не смог запустить установку. Компьютер не в какую не видит ни диск ни флешку.... Записывал несколько раз. 
Ноутбук Fujitsu AH552SL. С EFI загрузчиком.
Все другие дистры UNIX определяются нормально.
Изначально записал на диск. Перезагружаю(Secure Boot отключен) выбираю загрузку с привода - даже меню загрузчика не появилось. Далее пробую записать на флешку через Unix систему использованием команд cat / zcat . Все прошло успешно. Перезагружаюсь.  тоже самое даже нету меню загрузчика , никаких ошибок просто переходит к следующему по списку. Попробовал сделать через Unetbootin . Оно создала само свое загрузочное меню. Там пункт Default . При выборе - ноль реакции.
Вообще никак не хочет грузить.... Пробовал разные дистрибутивы Дебиана.
Подскажите что делать ? Как установить.
 

Оффлайн Olej

Re: Не запускается установка (с флешки/диска)
« Ответ #1 : 02 Апреля 2014, 21:30:12 »
Здравствуйте, вот захотел установить Debian. Но к сожалению даже не смог запустить установку. Компьютер не в какую не видит ни диск ни флешку.... Записывал несколько раз. 
Ноутбук Fujitsu AH552SL. С EFI загрузчиком.

Тут многое зависит от того чем и как писать.
Ну, вот есть у вас файл xxx.iso, и что мы и как пишем дальше?  :D
 

Оффлайн ferum

Re: Не запускается установка (с флешки/диска)
« Ответ #2 : 02 Апреля 2014, 22:34:43 »
Кажется всё таки проблема из за efi загрузчикапо крайней мере при загрузке с оптического привода (можно ещё грешить на неисправность оного). Надо тщательно разбираться с вашим  Secure Boot.
Про флешку многое зависит от  размера образа дистрибутива а стало быть и размера флешки.
Если вы записываете флешку из под линукс и размер дистрибутива не превышает 2 гигов пользуйтесь командой dd
http://wiki.rosalab.ru/ru/index.php/Методы_записи_загрузочных_образов_ISO_на_USB_flash
Если пишете из под windows вариант с файловой системой fat 32 и  Unetbootin только для cd образов.
Если вы используете образ DVD наверное лучше писать на флешку 4 гига и более отформатированную в NTFS из под windows http://remontka.pro/windows-8-1-boot-usb-ultraiso/  по крайней мере такая флешка точно прекрасно грузится.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн CROSP

  • Новичок форума
  • Сообщений: 3
Re: Не запускается установка (с флешки/диска)
« Ответ #3 : 02 Апреля 2014, 22:48:10 »
Писал программой Ultra ISO образ. Сейчас еще попробую на микросд через переходник загнать с помощью команды dd.
 

Оффлайн ferum

Re: Не запускается установка (с флешки/диска)
« Ответ #4 : 02 Апреля 2014, 22:51:58 »
Там надо записать образ жёсткого диска....хз канает ли всё это для efi.
Русские дебианщики против цифрового слабоумия !
 

Yrii

  • Гость
Re: Не запускается установка (с флешки/диска)
« Ответ #5 : 03 Апреля 2014, 13:33:30 »
Если efi и др. новомодные штуки не нужны, то в "BIOS":
Secure Boot Option - Disabled
Fast Boot - Disabled
CSM - Enabled

Я на этот ноут без проблем ставил Debian 7. Всё работало.
Кстати, ноутбуки от Fujitsu очень понравились.
« Последнее редактирование: 03 Апреля 2014, 13:37:50 от Yrii »
 

Оффлайн Olej

Re: Не запускается установка (с флешки/диска)
« Ответ #6 : 03 Апреля 2014, 16:18:07 »
Писал программой Ultra ISO образ. Сейчас еще попробую на микросд через переходник загнать с помощью команды dd.
Не всякий образ разными способами записанный будет годиться:
загрузочный Linux на USB флешке
По моему ощущению, лучше всего LiveUSB (или вообще загрузочные USB) готовит LiveUSB-Creator из комплекта Fedora ... он, кроме всех прочих достоинств, отлично распознаёт внешний USB HDD и на него ставит образ.
 

Yrii

  • Гость
Re: Не запускается установка (с флешки/диска)
« Ответ #7 : 03 Апреля 2014, 16:21:30 »
https://www.debian.org/releases/stable/amd64/ch04s03.html.ru
не когда не подводило...
 

Оффлайн CROSP

  • Новичок форума
  • Сообщений: 3
Re: Не запускается установка (с флешки/диска)
« Ответ #8 : 03 Апреля 2014, 21:48:31 »
Всем спасибо все таки запустил установку. Записав на флешку микросд через кардридер с помощью # cp debian.iso /dev/sdX
# sync .
Запустил установку и сразу возникло много проблем.
1. Не всегда стартовал меню загрузчика с флешки, писало symbol not found "grub_machine" Перезагрузка или смена порта в итоге решала проблему.
2. При установке не могло найти драйвера для iwlwifi 2030.05 и iwlwifi 2030.06 и для чего-то еще. Как не танцевал не смогу установить. Использовал и образы non-free и на флешку дрова пихал ничего не помогало. Скачал в итоге образ debian-live-7.4-amd64-lxde-desktop+nonfree.iso , но тоже при установке не нашло драйвера. Но тут установка пошла дальше (так как не нет инстал).
3. При разбивке дисков, автоматом предложило. Я выбрал мануал. Там выбрал автоматически разбить свободное место. Оно создало из 103 гб 8 гб своп и остальное основной раздел. Я правильно сделал ? 
4. Но вот тут возникла самая основная проблема. Оно написало что-то про то что не может найти EFI я нажал случайно и потом назад уже не смог вернутся - началась установка, затем в конце установки началась установка граб загрузчика . В итоге все завершилось , но загрзчик все таки не создался , или создался не там .
Все осталось как раньше было.

Когда ставил другие Юниксы оно само создавало загрузчик и ставила его первым в приоритете записывало туда загрузку линукса и винды.
Я с восьмерки редактировал через VisualBcd если надо было.
Подскажите пожалуйста на счет проблем и как сделать загрузчик .
Спасибо

Сообщение объединено: 03 Апреля 2014, 22:51:18
Вообщем переустановил заново создав раздел для EFI . Все стало отлично , только не подхватило автоматически винду.
Подскажите как прописать правильно в загрузчике винду ? На федоре смотрел как прописано но уже не помню как.
Еще хотел задать пару вопросов по самой системе.
1. При запуске можно выбрать Default Xsession , LXDE , Openbox . В чем разница ?
2. Как установить правильно все дрова(нету вафли) .
3. Через что производить основные настройки ?
4. Нету индикации батарейки. Это проблема была и на других Юниксах. Нужно было либо вставить зарядку , либо высунуть или чтобы при подключенной зарядке полностью зарядилась , то есть чтобы изменила как-то состояние . только тогда появлялся значок . Подскажите пожалуйста в чем может быть проблема и как решить.
Спасибо
« Последнее редактирование: 03 Апреля 2014, 22:51:18 от CROSP »
 

Оффлайн endru

Re: Не запускается установка (с флешки/диска)
« Ответ #9 : 04 Апреля 2014, 06:25:20 »
CROSP, учитесь пользоваться поиском по форуму и гуглом.

Установка запустилась! Тема закрыта.

Теги:
     

    Не запускается система после установки

    Автор Eyer

    Ответов: 48
    Просмотров: 1132
    Последний ответ 16 Сентября 2021, 12:33:23
    от Eyer
    Debian LiveCD запускается и работает, после установки - нет

    Автор Agris

    Ответов: 40
    Просмотров: 10953
    Последний ответ 12 Февраля 2015, 16:07:12
    от Agris
    Перенесено: Не запускается Debian 10

    Автор endru

    Ответов: 0
    Просмотров: 1149
    Последний ответ 18 Октября 2019, 12:05:44
    от endru
    Debian устанавливается но не запускается.

    Автор Anty666

    Ответов: 8
    Просмотров: 1981
    Последний ответ 10 Февраля 2021, 18:09:43
    от Дима Скоков
    Debian не запускается после установки!

    Автор sk12

    Ответов: 3
    Просмотров: 11265
    Последний ответ 11 Мая 2014, 22:39:01
    от sk12