Автор Тема: Debian Jessie установк Software-center  (Прочитано 12505 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Deileson

Debian Jessie установк Software-center
« : 01 Июня 2014, 14:28:07 »
Система Debian Jessie хочу с репозитория sid установить центр приложения,  появился конфликт пакетов

через apt-get вообще не устанавливается

Spoiler: ShowHide
apt-get install software-center
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 software-center : Зависит: python-gobject (>= 3.0) но он не будет установлен
                   Зависит: python-gobject-cairo
                   Зависит: python-aptdaemon (>= 0.40) но он не будет установлен
                   Зависит: python-aptdaemon.gtk3widgets но он не будет установлен
                   Рекомендует: gir1.2-launchpad-integration-3.0 но он не может быть установлен
                   Рекомендует: sessioninstaller но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Через Aptitude

Spoiler: ShowHide
aptitude install software-center
Следующие НОВЫЕ пакеты будут установлены:       
  app-install-data{a} apt-xapian-index{a} aptdaemon{a} aptdaemon-data{a}
  autopoint{a} diffstat{a} gettext{a} gir1.2-gmenu-3.0{a}
  gir1.2-vte-2.90{a} gnome-packagekit{a} gnome-packagekit-data{a}
  gnome-packagekit-session{a} hardening-includes{a} intltool-debian{a}
  javascript-common{a} libapt-pkg-perl{a} libarchive-zip-perl{a}
  libasprintf-dev{a} libautodie-perl{a} libclass-accessor-perl{a}
  libclone-perl{a} libdee-1.0-4{a} libdigest-hmac-perl{a}
  libemail-valid-perl{a} libgettextpo-dev{a} libgettextpo0{a}
  libgnome-menu-3-0{a} libhtml-template-perl{a} libio-pty-perl{a}
  libio-socket-inet6-perl{a} libio-string-perl{a} libipc-run-perl{a}
  libipc-system-simple-perl{a} libjs-jquery{a} liblist-moreutils-perl{a}
  libnet-dns-perl{a} libnet-domain-tld-perl{a} libnet-ip-perl{a}
  libparse-debianchangelog-perl{a} libperlio-gzip-perl{a}
  libsocket6-perl{a} libsub-identify-perl{a} libsub-name-perl{a}
  libtext-levenshtein-perl{a} libxml-simple-perl{a} libzeitgeist-2.0-0{a}
  lintian{a} patchutils{a} python-aptdaemon{a} python-aptdaemon-gtk{a}
  python-aptdaemon.gtk3widgets{a} python-aptdaemon.gtkwidgets{a}
  python-defer{a} python-gst0.10{a} python-httplib2{a}
  python-lazr.restfulclient{a} python-lazr.uri{a} python-oauth{a}
  python-simplejson{a} python-vte{a} python-wadllib{a} python-xapian{a}
  python-xdg{a} python-zope.interface{a} python3-aptdaemon{a}
  python3-aptdaemon.gtk3widgets{a} python3-defer{a}
  python3-software-properties{a} sessioninstaller{a} software-center
  software-properties-common{a} software-properties-gtk{a} t1utils{a}
  unattended-upgrades{a} update-notifier{a} zeitgeist-core{a}
0 пакетов обновлено, 76 установлено новых, 0 пакетов отмечено для удаления, и 196 пакетов не обновлено.
Необходимо получить 24,1 MB архивов. После распаковки 70,1 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 python-gi : Ломает: software-center (<= 5.6.0-0ubuntu2) но устанавливается 5.1.2debian3.1.
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     software-center [Не установлен]                 



Принять данное решение? [Y/n/q/?]       



Если принять данное решение система несломается?
« Последнее редактирование: 01 Июня 2014, 14:33:44 от Deileson »
Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Оффлайн sandaksatru

Re: Debian Jessie установк Software-center
« Ответ #1 : 01 Июня 2014, 14:43:07 »
Deileson, То есть вы просто в sources.list вместо jessie написали sid и ввели в терминале "apt-get install software-center"?
 

Оффлайн Deileson

Re: Debian Jessie установк Software-center
« Ответ #2 : 01 Июня 2014, 14:46:01 »
Добавил репозиторий
deb http://ftp.ru.debian.org/debian sid main
после сделал
apt-get update
aptitude install software-center
Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Оффлайн sandaksatru

Re: Debian Jessie установк Software-center
« Ответ #3 : 01 Июня 2014, 15:09:06 »
Deileson, ну поскольку инсталлятор удалять ничего не предлагает, обновлять тоже, значит система у вас всего лишь вырастит дополнительно на несколько пакетов. Можете смело ставить.
 

Оффлайн Deileson

Re: Debian Jessie установк Software-center
« Ответ #4 : 01 Июня 2014, 15:13:37 »
Тут написано что какой то пакет сломает
Следующие пакеты имеют неудовлетворённые зависимости:
 python-gi : Ломает: software-center (<= 5.6.0-0ubuntu2) но устанавливается 5.1.2debian3.1.

Установил, а центр приложений так и не появился в меня приложений
« Последнее редактирование: 01 Июня 2014, 15:17:00 от Deileson »
Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Оффлайн endru

Re: Debian Jessie установк Software-center
« Ответ #5 : 01 Июня 2014, 21:01:35 »
Цитата: Deileson
python-gi : Ломает: software-center (<= 5.6.0-0ubuntu2)
Deileson, а чего у вас пакеты из убунту делают в системе? sources.list целиком показывайте.
и dpkg --audit

Оффлайн Deileson

Re: Debian Jessie установк Software-center
« Ответ #6 : 01 Июня 2014, 21:42:40 »
Скорее всего software-center использует пакеты из ubuntu
Sources.list
Spoiler: ShowHide


# deb cdrom:[Debian GNU/Linux jessie-DI-a1 _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140318-12:38]/ jessie main

# deb cdrom:[Debian GNU/Linux jessie-DI-a1 _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140318-12:38]/ jessie main

deb http://ftp.ru.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ jessie non-free contrib main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ jessie-updates main
deb-src http://ftp.ru.debian.org/debian/ jessie-updates main

# jessie-backports, previously on backports.debian.org
deb http://ftp.ru.debian.org/debian/ jessie-backports main
deb-src http://ftp.ru.debian.org/debian/ jessie-backports main

deb http://ftp.ru.debian.org/debian sid main


dpkg --audit перескакивает на следущую строчку

deileson@debian:~$ dpkg --audit
deileson@debian:~$
« Последнее редактирование: 01 Июня 2014, 21:55:04 от Deileson »
Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Оффлайн qupl

Re: Debian Jessie установк Software-center
« Ответ #7 : 02 Июня 2014, 06:19:07 »
Скорее всего software-center использует кто-то ставил пакеты из ubuntu
*fixed

Оффлайн Deileson

Re: Debian Jessie установк Software-center
« Ответ #8 : 02 Июня 2014, 13:11:28 »
Такого быть не может, с ubuntu нечего не устанавливал, sources.list тоже чисто с Debian репозиториями

В стиме нашел в скрытых файлах 2 папки Ubuntu, не он случаем использует библиотеки ubuntu?



Все программы устанавливал через терминал или synaptic

« Последнее редактирование: 02 Июня 2014, 13:30:33 от Deileson »
Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Оффлайн Angus123

Re: Debian Jessie установк Software-center
« Ответ #9 : 03 Июня 2014, 11:04:28 »
Скорее всего software-center использует кто-то ставил пакеты из ubuntu
*fixed

А почему нельзя использовать пакеты из Ubuntu? Я к примеру добавил репозиторий из лаунчпада для бета версии firefox, и всё работает, и не ломается.
 

Оффлайн ogost

Re: Debian Jessie установк Software-center
« Ответ #10 : 03 Июня 2014, 12:06:34 »
Angus123, установка пакетов из сторонних репов не рекомендуется. убунту хоть и дочерний, но всё же имеет свои отличия (как минимум в убунту пакеты новее, чем в стейбле дебиана). за взаимной совместимостью естественно никто не следит и не будет следить (и правильно). посему так часто получаются битые зависимости, нестабильная работа и прочие траблы, вплоть до полной неработоспособности такой "смешанной" системы.
ежели вы понимете что делаете (гуру разруливания зависимостей 80лвл), доверяете поставщику стороннего пакета (т.е. точно знаете, что не мальварь), принимаете возможные риски угробить систему - то никто вам не запрещает использовать убунтовские или другие пакеты. только не забудьте - бекап наше фсё!
лично мне на заре дебианства это вышло боком при обновлении дистра (dist-upgrade).

кстати Deileson, я сейчас тоже попробовал apt-get -s install software-center:
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 software-center : Depends: python-gobject (>= 3.0) but it is not going to be installed
                   Depends: python-gobject-cairo
                   Depends: python-aptdaemon (>= 0.40) but it is not going to be installed
                   Depends: python-aptdaemon.gtk3widgets but it is not going to be installed
                   Recommends: gir1.2-launchpad-integration-3.0 but it is not installable
                   Recommends: sessioninstaller but it is not going to be installed
Вывод: это тестинг, детка! Жди когда исправят.

ПЫСЫ: без ключа -s то же самое.

Оффлайн Angus123

Re: Debian Jessie установк Software-center
« Ответ #11 : 03 Июня 2014, 19:07:34 »
Angus123, установка пакетов из сторонних репов не рекомендуется. убунту хоть и дочерний, но всё же имеет свои отличия (как минимум в убунту пакеты новее, чем в стейбле дебиана). за взаимной совместимостью естественно никто не следит и не будет следить (и правильно). посему так часто получаются битые зависимости, нестабильная работа и прочие траблы, вплоть до полной неработоспособности такой "смешанной" системы.
ежели вы понимете что делаете (гуру разруливания зависимостей 80лвл), доверяете поставщику стороннего пакета (т.е. точно знаете, что не мальварь), принимаете возможные риски угробить систему - то никто вам не запрещает использовать убунтовские или другие пакеты. только не забудьте - бекап наше фсё!
лично мне на заре дебианства это вышло боком при обновлении дистра (dist-upgrade).


Тогда вопрос, почему такие важные программы как например Хром и ФиреФокс не добавят в оф. репозиторий? Есть какой-то iceweasel, но это не то( И вот к примеру DE MATE, почему не добавили? Даже в тестинг ветке. Вот и получается, чтобы иметь в системе всё что надо, надо устраивать винегрет... Или я чего-то не понимаю?
 


Оффлайн ogost

Re: Debian Jessie установк Software-center
« Ответ #13 : 03 Июня 2014, 20:27:00 »
Angus123, установка пакетов из сторонних репов не рекомендуется. убунту хоть и дочерний, но всё же имеет свои отличия (как минимум в убунту пакеты новее, чем в стейбле дебиана). за взаимной совместимостью естественно никто не следит и не будет следить (и правильно). посему так часто получаются битые зависимости, нестабильная работа и прочие траблы, вплоть до полной неработоспособности такой "смешанной" системы.
ежели вы понимете что делаете (гуру разруливания зависимостей 80лвл), доверяете поставщику стороннего пакета (т.е. точно знаете, что не мальварь), принимаете возможные риски угробить систему - то никто вам не запрещает использовать убунтовские или другие пакеты. только не забудьте - бекап наше фсё!
лично мне на заре дебианства это вышло боком при обновлении дистра (dist-upgrade).


Тогда вопрос, почему такие важные программы как например Хром и ФиреФокс не добавят в оф. репозиторий? Есть какой-то iceweasel, но это не то( И вот к примеру DE MATE, почему не добавили? Даже в тестинг ветке. Вот и получается, чтобы иметь в системе всё что надо, надо устраивать винегрет... Или я чего-то не понимаю?
Хром - проприетарный. но есть пакет от гугла, допиленный под стейбл - хотите ставьте. в репах же дебиана есть его опенсорсный аналог хромиум. фирефохе не разрешает использовать его иконки/названия, посему есть его "форк" исевизле. ДЕ МАТЕ недопилен, дублирует пакеты гнома (хотя давно не интересовался, может ошибаюсь).
кроме того если бы вы знали о политике добавления пакетов в репы, о заморозках репов и прочее debian rock solid stable штучках, то эти вопросы бы отпали сами собой.

Оффлайн Deileson

Re: Debian Jessie установк Software-center
« Ответ #14 : 03 Июня 2014, 23:18:03 »
Есть какой-то iceweasel, но это не то

По мне iceweasel  тоже самое что и FireFox, просто его настроить надо.

Тему можно закрывать буду ждать пока центр приложений  в jessie добавят, а пока и без него обойдусь.



Ubuntu 14.04 LTS (Unity); Debian Sid (Gnome 3)
Ничего плохого нет в том что умный человек иногда тупит. Гораздо хуже когда тупой постоянно умничает.

 

Теги:
     

    Debian mini.iso netboot

    Автор usershelpme

    Ответов: 5
    Просмотров: 3807
    Последний ответ 27 Января 2014, 06:23:35
    от qupl
    Настройка FTP для Debian (VDS server)

    Автор Riko_s

    Ответов: 3
    Просмотров: 3538
    Последний ответ 27 Января 2015, 07:45:50
    от endru
    Как убрать колонку с информацией о системе на рабочем столе в Debian 8?

    Автор greenwolf10

    Ответов: 9
    Просмотров: 1897
    Последний ответ 13 Декабря 2016, 19:25:00
    от Александр Кряжев
    Debian 8.2.0 и пляски НОВИЧКА с БУБНОМ!!!

    Автор Psyside

    Ответов: 19
    Просмотров: 4382
    Последний ответ 22 Декабря 2015, 10:50:18
    от ferum
    Пароль Для Debian 9.2 KDE Live

    Автор ЦарьПушка

    Ответов: 4
    Просмотров: 2663
    Последний ответ 13 Ноября 2017, 09:16:01
    от Walter_322