Автор Тема: [РЕШЕНО] Черный экран при установке Debian  (Прочитано 17060 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн speed_vm

Доброго времени суток всем!
Не раз я ставил Debian. И себе, и людям, и с графикой, и без, но сегодня наткнулся на непонятный для меня глюк при установке, а точнее еще до установки.
Имеется железяка с процессором AMD Athlon 64 3000 и БИОСом AMI. Пытаюсь установить Debian 7.5.0 netinstall для amd64, скачанный с официального сайта, конечно же. После загрузки с диска появляется меню выбора установки. Я выбираю "Expert install", пробегают две надписи о чтении initrd (или что-то похожее) и комп уходит в "черный экран". Диск не вращается (чтение не происходит), комп виснет наглухо. В место этого должна появиться менюшка на синем фоне.
Проверял по md5 скачанные и записанные образы, менял болванки, пытался выбирать другие типы установки. Скачал даже dvd образ. С ним такая же беда. Пытался выключить в БИОС ACPI - не помогло.
Уже не знаю куда копать. Подскажите, в чем может быть проблема.
« Последнее редактирование: 21 Июня 2014, 12:04:16 от speed_vm »
 

Оффлайн ferum

Re: Черный экран при установке Debian
« Ответ #1 : 20 Июня 2014, 19:07:49 »
Дело точно не в процессоре так как не далее чем в понедельник ставил debian 7.2 c DVD на компьютер с таким же процессором и биосом американ мегатренд, естественно экспертная установка. Единственный нюанс приходится ставить ядро i486 иначе загрузчик ставиться не хочет. Во время установки интернет соответственно присутствовал и на выходе всё равно 7.5.
Попробуйте проверить целостность установочного диска и DVD привода соответственно.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн speed_vm

Re: Черный экран при установке Debian
« Ответ #2 : 20 Июня 2014, 19:43:53 »
Попробуйте проверить целостность установочного диска и DVD привода соответственно.
Болванки резал разными приводами, целостность проверена. Пытался поставить с usb-привода - аналогичная беда.
 

Оффлайн ogost

Re: Черный экран при установке Debian
« Ответ #3 : 20 Июня 2014, 20:47:22 »
просто предположение, может дело в видюхе? посмотрите в сторону nomodeset grub

Оффлайн speed_vm

Re: Черный экран при установке Debian
« Ответ #4 : 21 Июня 2014, 08:19:46 »
просто предположение, может дело в видюхе? посмотрите в сторону nomodeset grub
Не помогает.
Также не помогают опции noapic и acpi=off.

Если взять дистрибутив netinstall i386, то таких проблем не возникает.

Если загружаться с i386-го live, то в dmesg падают сообщения:
powernow-k8: failing targ, change pending bit set
« Последнее редактирование: 21 Июня 2014, 10:53:23 от speed_vm »
 

Оффлайн qupl

Re: Черный экран при установке Debian
« Ответ #5 : 21 Июня 2014, 11:20:33 »
speed_vm,
 
Единственный нюанс приходится ставить ядро i486 иначе загрузчик ставиться не хочет.

Оффлайн speed_vm

Re: Черный экран при установке Debian
« Ответ #6 : 21 Июня 2014, 11:30:03 »
speed_vm,
 
Единственный нюанс приходится ставить ядро i486 иначе загрузчик ставиться не хочет.

Я понимаю, что это выход, но стоит разобраться, по крайней мере, почему на 64-х разрядный процессор AMD не устанавливается система для этого процессора. Я не прав?

Еще один нюанс. Если загружаться с live standard amd64, то сообщение, "powernow-k8: failing targ, change pending bit set" вываливается в консоль каждые полсекунды и не дает ничего сделать (ввести что-нибудь). Может дело в этом powernow?
« Последнее редактирование: 21 Июня 2014, 11:32:09 от speed_vm »
 

Оффлайн qupl

Re: Черный экран при установке Debian
« Ответ #7 : 21 Июня 2014, 11:34:16 »
speed_vm, может быть, попробуйте заblacklist-ить его при загрузке.

Оффлайн speed_vm

Re: Черный экран при установке Debian
« Ответ #8 : 21 Июня 2014, 11:58:57 »
speed_vm, может быть, попробуйте заblacklist-ить его при загрузке.
В общем-то мне не нужно с live системы загружаться. Я просто попробовал и описал то, что произошло.
Если добавить при загрузке с live в параметры ядра  acpi=off, сообщения не появляются.
 

Оффлайн speed_vm

Re: Черный экран при установке Debian
« Ответ #9 : 21 Июня 2014, 12:03:58 »
Разобрался!
Проблема исчезает, если из при загрузке с netinstall убрать из параметров ядра vga=788.
Тема закрыта.
 

Оффлайн m90125

Re: [РЕШЕНО] Черный экран при установке Debian
« Ответ #10 : 19 Марта 2015, 15:45:26 »
Всем привет!

Добавлю свои "5 копеек". У меня было нечто подобное. Ставил Wheezy 7.8 i386 c netinstall на
ноутбук Asus z99H, на данный момент (19.03.2015) уже весьма старый, ему лет 7, не меньше.
Проблема была в том, что после установки при перезагрузке возникал чёрный экран. На нём не
было вообще ничего. Причём при попытке загрузиться в режиме восстановления было то же
самое.

 Погуглил, выяснил, что это связано с настройками видеодрайвера. В качестве зацепки для решения вопроса стало упоминание о vga в предыдущем посте.
 Загрузился с флешки (Debian 6). Открыл grub.cfg, посмотрел на основе значений из каких файлов он генерируется. Проблема решилась редактированием /etc/default/grub, где параметр grub_gfxmode был закомментирован и имел значение 640x480. Я раскомментировал и выставил grub_gfxmode=auto. Команда update-grub по причине, что загрузился с флешки, не актуальна. После перезагрузился и всё стало нормально.
--------------------------------------------------------------------------------------------------------
...вот, прошло больше месяца. Недавно я снова переустановил Debian на этом ноуте, снова было всё то же самое, но мой предыдущий рецепт не помог.
Нагуглил другой:
Изменил настройки в /etc/default/grub

1) GRUB_CMDLINE_LINUX_DEFAULT="quiet"
2) Закомментировал строку GRUB_GFXMODE=640x480 
3) Сразу после строки, указанной в предыдущем пункте, добавил строку
GRUB_GFXPAYLOAD_LINUX=auto

После этого даём команду update-grub и перезагружаемся.

И всё полностью вернулось в своему нормальному виду.

И вот ещё - я не знаю, как сделать update-grub, загрузившись с флешки. В основную же
систему не удавалось попасть даже при загрузке в режиме восстановления. НО (!) если при
загрузке зайти в биос, изменить там какое-нибудь значение, связанное в питанием, то при
перезагрузке после этого оказалось можно (не всегда) загрузиться. Уже не помню в обычном
режиме или режиме восстановления. Тогда всё и проделал. Не знаю насколько одно связано в
другим, но у меня сработало.

« Последнее редактирование: 27 Апреля 2015, 02:06:19 от m90125 »
 

Оффлайн Dragon1654

Re: [РЕШЕНО] Черный экран при установке Debian
« Ответ #11 : 21 Марта 2015, 16:34:16 »
Ребятки, помогите.

Черный экран в любом режиме. При запуске меню установки появляется Error 'prefix' is not set. Затем открывается меню установки. Там пытался отключить VGA=788 как было сказано выше, но не помогло. Может конечно я отключал как то неправильно...
Spoiler: ShowHide
В меню на пункте install нажал "E" и там удалил "vga=788" из строчки "linux    /install.amd/vmlinuz vga=788  --


Но в общем то ничего не изменилось. Самое обидное, что до конца даже не знаю какая начинка у ноута, на который ставлю. Дело в том, что ноут DNS и собирался походу на каких то китайских частях. Видимо компания DNS не хочет разглашать об этом железе инфу. Короче найти точно начинку нереально. Разбирал ноут там на материнке даже маркировки нет. Знаю ток что проц интеловский i3 и все. ЖД тошиба. Больше ничего об этой машине сказать не могу. Но видюха ингрированная, эт точно.

Собственно продолжение вопроса.. как убрать этот черный экран? Возможно он связан с ошибкой 'prefix' is not set, тогда как исправить эту ошибку?
 

Оффлайн ihammers

Re: [РЕШЕНО] Черный экран при установке Debian
« Ответ #12 : 21 Марта 2015, 18:03:01 »
Если есть возможность загрузиться в режиме LiveCD, то в нем можно будет запустить команды типа lspci, lsusb и другие для получения информации о железе.

Какой образ операционной системы использовали Wheezy, Jessie?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн Dragon1654

Re: [РЕШЕНО] Черный экран при установке Debian
« Ответ #13 : 22 Марта 2015, 00:03:06 »
Версия  7.8 Wheezy. Debian netinstall. Лайв режима там помоему нет. но я пробовал другой дистр, с лайв режимом, он тоже не запускался


Сообщение объединено: 22 Марта 2015, 00:30:29
Не знаю, будет ли это полезно, но pointlinux на базе дебы 7 без проблем запустила лайв режим и установилась на тот же ноут
« Последнее редактирование: 22 Марта 2015, 00:30:29 от Dragon1654 »
 

Оффлайн Leo

Re: [РЕШЕНО] Черный экран при установке Debian
« Ответ #14 : 22 Марта 2015, 08:14:02 »
[ot]Между делом: у Debian тоже имеются свои live-образы, даже целый проект под это дело со своим сборщиком образов.[/ot]
« Последнее редактирование: 22 Марта 2015, 08:17:58 от Leo »
 

Теги:
     

    [РЕШЕНО] Установка expert mode в графическом режиме, ошибка rc.local

    Автор VKH

    Ответов: 7
    Просмотров: 2981
    Последний ответ 31 Октября 2015, 22:48:04
    от VKH
    [Решено] Не устанавливает зависимости

    Автор gunb1rd

    Ответов: 2
    Просмотров: 13038
    Последний ответ 23 Марта 2013, 09:39:51
    от gunb1rd
    Проблема после установки Debin (BusyBox v1.30.1) [РЕШЕНО]

    Автор StrahL

    Ответов: 8
    Просмотров: 2584
    Последний ответ 02 Февраля 2020, 00:34:10
    от Gamliel
    [Решено] Не могу попасть в консоль

    Автор Сергей

    Ответов: 9
    Просмотров: 2873
    Последний ответ 07 Августа 2013, 20:31:09
    от Сергей
    Обновление до 6.01 [РЕШЕНО]

    Автор alastor

    Ответов: 7
    Просмотров: 3194
    Последний ответ 29 Апреля 2011, 23:47:06
    от alastor