Обновление установленных пакетов

Автор qwe.kill, 23 июля 2014, 10:35:12

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

qwe.kill

Здраствуйте. У меня такой вопрос.Установил Debian 7.6 установил необходимую библиотеку для работы libboots-thread.so.1.49
пытаюсь обновить ее из репозитория до 1.55, а он не видит новую версию. Объясните почему так происходит. репозиторий http://ftp.us.debian.org/ .
sources.list стандартный :

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 kde-CD Binary-1 20140712-14:09]/ wheezy main

deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 kde-CD Binary-1 20140712-14:09]/ wheezy main

deb http://ftp.us.debian.org/debian/ wheezy main
deb-src http://ftp.us.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ wheezy-updates main
deb-src http://ftp.us.debian.org/debian/ wheezy-updates main
  •  

ogost

закоментируйте вторую строчку. потом apt-get update и дальше по вашему сценарию.

qwe.kill

ни чего не дало, пакеты не обновились.
  •  

qupl

qwe.kill, libboost-thread1.55.0 есть только в jessie и sid, в стабильном debian версии меньше.

qwe.kill

То есть возможности поставить на эту версию нет? только sid и jessie
  •  

qupl


qwe.kill

  •  

Galchinskii

Так если репозиторий от СИД прописать, то версия обновится?
  •  

qupl

Цитата: Galchinskii от 23 июля 2014, 21:01:05
Так если репозиторий от СИД прописать, то версия обновится?
Обновить можно, но что оно потянет по зависимостям надо смотреть на практике.

Galchinskii

Как установил debian, не поднялся wi-fi, по привычке начал решать установкой firmware_realtek и подключением через wpa_supplicant. Драйверы, супликант и зависимости к нему типа более новой версии(!!!) libc6 и прочее качал deb пакетами и носителем перекидывал на minipc где стоит debian и ставил руками через dpkg(насколько это правильно?). Так вот, после установки вайфай соответственно завёлся, но слетела локаль, потому что с дуру согласился удалить проблемные пакеты после aptitude update. Вы такие проблемы имеете в виду? Как избежать подобное, если, к примеру, супликант только последней версии корректно работает с WPA2/AES домашнего роутера, и требует пакеты libc6, gc и другие более новых версий, чем представлена в стейбл, а их установка сопрежена с предупреждениями о некорректной работе десятка других пакетов? Как выявить возможность этой некорректной работы, что бы определиться рисковать и ставить пакеты или искать альтернативные пути? Заранее спасибо!
  •  

ogost

1. не смешивать ветки.
2. использовать backports
3. если всё же приходиться смешивать ветки - использовать apt pinning
4. или полностью обновляться до последней ветки.
5. или делать свой бэкпорт для конкретного пакета.

Galchinskii

Спасибо большое за ответ!

Но получается что стейбл невероятно не гибок, уже не с одним костылём столкнулся, где пришлось ставить более поздние версии пакетов(из Джесси), которые конфликтовали с половиной системы, как обойтись без "смешивания" - не совсем понятно.
  •  

Malaheenee

Жить на нестабильное ветке. Не так уж часто там что-то капитально ломают.
Все мы где-то, когда-то и в чем-то были новичками.
  •