Автор Тема: [multiarch] можно ли использовать пакеты с DVD?  (Прочитано 1356 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Привет.

Подскажите, если у меня amd64 битная ОСь с поддержкой мультиарча i386, могу ли я использовать i386 DVD в качестве локального репозитория?

почему спрашиваю:
имею локальную репу из 3x i386 DVD, ставлю оттуда пакет, как обычно
apt-get install package_name:i386
и apt для его установки предлагает снести пол-системы...
теперь отключаю DVD, качаю тот же пакет из сети - ставится легко и без дополнительных зависимостей...
- непонятка.  ???
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Онлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3160
  • Linux Registered User #547151
самый quick&dirty способ - смонтировать образ в /media/cdrom, потом
apt-cdrom add
apt-get install package_name

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
я не о монтировании, а о зависимостях:
почему-то они по-разному разрешаются при установке с ДВД и из сетевой репы.

Spoiler: ShowHide
PS если я плохо сформулировал вопрос, спросите что не понятно.
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 5020
  • memento mori
  • Jabber: qupl@jabber.ru
su16, а версии пакетов на диске и в репах одни и те же?

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: [multiarch] можно ли использовать пакеты с DVD?
« Ответ #4 : 01 Август 2014, 00:56:36 »
да, разные в миноре.
щас скачал свежие ДВД, в ближайшее время попробую ещё раз и отпишусь.

но по идее это не должно влиять... ну подумаешь пакет чуть постарей на DVD, неужто разница в миноре может привести к полной несовместимости с 64битными пакетами основной системы? к тому же это другая архитектура, полагаю, архитектуры друг к другу версионно не привязаны, и если всё для 386 ставилось с одного и того же DVD, то проблем быть не должно.

у меня мнение, что пакеты на ДВД просто не совместимы с мультиарчем... то есть возможно они заточены быть частью основной системы, а не дополнительной...
что любопытно, некоторые пакеты с 386 ДВД нормально встают, а некоторые просят удалить 64bit пакеты.
второй любопытный момент - gdebi воспринимает 386 пакеты, как 64 битные и говорит, что они уже установлены в системе))
« Последнее редактирование: 01 Август 2014, 01:08:09 от su16 »
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Теги:
 

Пакеты пытаются установиться с неправильной архитектурой

Автор gab

Ответов: 7
Просмотров: 1765
Последний ответ 20 Май 2015, 14:21:25
от ferum
Где можно скачать debian 5(lenny)

Автор Роман846

Ответов: 20
Просмотров: 7037
Последний ответ 03 Август 2011, 17:19:51
от Ghostdmn
сломаные пакеты

Автор gennadi

Ответов: 1
Просмотров: 1630
Последний ответ 07 Июнь 2016, 10:46:41
от endru
Можно ли установить Debian на смартфон?

Автор Ethanol

Ответов: 10
Просмотров: 4123
Последний ответ 06 Март 2017, 15:05:54
от pashkanin
Сломались пакеты при обновлении.

Автор APL

Ответов: 6
Просмотров: 2196
Последний ответ 20 Апрель 2012, 22:09:22
от vladimir_ar