Автор Тема: Debian Wheezy требует диск для установки программ...  (Прочитано 5243 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Baron Rojo

Вот такая чушь произошла. был в Германии, купил там книгу, к ней прилагался Дебиан визи. Установил его. Теперь пытаюсь устанавливать программы стандартным apt-get или  aptitude  а он мне выдает:

_______________________________________________________________________________________________________________________________________________________
root@debian:/home/alexis# aptitude install gnome-tweak-tool
Следующие НОВЫЕ пакеты будут установлены:       
  gnome-tweak-tool
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B/103 kB архивов. После распаковки 676 kB будет занято.
Смена носителя: вставьте диск, помеченный как «Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture i386/amd64/source DVD #1 20130615-23:45» в привод «/media/cdrom/» и нажмите [Enter].
Смена носителя: вставьте диск, помеченный как «Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture i386/amd64/source DVD #1 20130615-23:45» в привод «/media/cdrom/» и нажмите [Enter].
______________________________________________________________________________________________________________________________________________________
Когда вставил диск, с которого устанавливал, все установилосбь нормальною. Вытащил, опять двадцатиь пять...
Что это такое?
 

Оффлайн ferum

Re: Debian Wheezy требует диск для установки программ...
« Ответ #1 : 09 Сентября 2014, 19:45:03 »
Отредактируйте /etc/apt/sources.list
в частности закоментируйте строки с упоминанием CD/DVD
Русские дебианщики против цифрового слабоумия !
 

Оффлайн BULATUS

Re: Debian Wheezy требует диск для установки программ...
« Ответ #2 : 10 Сентября 2014, 10:04:07 »
И не забудьте после сохранения отредактированного файла дать команду aptitude update.

Оффлайн Baron Rojo

Re: Debian Wheezy требует диск для установки программ...
« Ответ #3 : 12 Сентября 2014, 09:45:52 »
Вроде бы сделал все, как вы сказали, за что большое спасибо. Но вот мой файл sources.list

# deb-src cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-archite$
# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architectur$
#

#deb-src cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architec$
#deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture$


# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
deb http://ftp.debian.org/debian/ wheezy-updates main
deb-src http://ftp.debian.org/debian/ wheezy-updates main

Какеой-то он... маленький... И проблема очередная втом, что я пытаюсь установить трансмишн

#apt-get intsall transmission

Он мне пишет что-то такое про неудовлетворенные зависимости.ю Я пытаюсь их удовлетворить и все заканчивается не ннеаденным кандидатом на установку:
_____________________________________________________________________________________________________________________________________________________
root@debian:/home/alexis# [u][i][b]apt-get install transmission[/b][/i][/u]
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 google-chrome-stable : Зависит: libxss1 но он не может быть установлен
                        Зависит: libappindicator1 но он не может быть установлен
[u][i][b] transmission : Зависит: transmission-gtk (>= 2.52-3+nmu2) но он не будет установлен или
                                transmission-qt (>= 2.52-3+nmu2) но он не будет установлен или
                                transmission-cli (>= 2.52-3+nmu2) но он не будет установлен
                Зависит: transmission-common (>= 2.52-3+nmu2) но он не будет установлен[/b][/i][/u]
W: Duplicate sources.list entry http://security.debian.org/ wheezy/updates/main i386 Packages (/var/lib/apt/lists/security.debian.org_dists_wheezy_updates_main_binary-i386_Packages)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ testing/contrib Translation-en (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_testing_contrib_i18n_Translation-en)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ testing/main Translation-en (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_testing_main_i18n_Translation-en)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ testing/main Translation-ru (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_testing_main_i18n_Translation-ru)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ testing/non-free Translation-en (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_testing_non-free_i18n_Translation-en)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ unstable/contrib Translation-en (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_unstable_contrib_i18n_Translation-en)
W: Duplicate sources.list entry http://ftp.ru.debian.org/debian/ unstable/main Translation-ru (/var/lib/apt/lists/ftp.ru.debian.org_debian_dists_unstable_main_i18n_Translation-ru)
W: Вы можете запустить «apt-get update» для исправления этих ошибок
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
root@debian:/home/alexis# transmission-qt
bash: transmission-qt: команда не найдена
root@debian:/home/alexis# apt-get install transmission-qt
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 google-chrome-stable : Зависит: libxss1 но он не может быть установлен
                        Зависит: libappindicator1 но он не может быть установлен
 transmission-qt : Зависит: libminiupnpc5 но он не может быть установлен
                   Зависит: libnatpmp1 но он не может быть установлен
                   Зависит: libqt4-dbus (>= 4:4.5.3) но он не может быть установлен
                   Зависит: libqt4-network (>= 4:4.5.3) но он не может быть установлен
                   Зависит: libqtcore4 (>= 4:4.8.0) но он не может быть установлен
                   Зависит: libqtgui4 (>= 4:4.8.0) но он не может быть установлен
                   Зависит: transmission-common (= 2.52-3+nmu2) но он не будет установлен
[u][i][b]E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).[/b][/i][/u]
root@debian:/home/alexis# apt-get install libminiupnpc5
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libminiupnpc5 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

[u][i][b]E: Для пакета «libminiupnpc5» не найден кандидат на установку[/b][/i][/u]

Кстати, почему-то во времся устнаовки трансмишн он мне ще про гугл хром напоминает... ???


« Последнее редактирование: 12 Сентября 2014, 10:20:16 от qupl »
 

Оффлайн qupl

Re: Debian Wheezy требует диск для установки программ...
« Ответ #4 : 12 Сентября 2014, 10:17:29 »
Поиском по форуму или в вики найдите стандартный список репозиториев. Рядом есть тема.
Конкретно у Вас не хватает веток contrib и non-free, и подключены только репозитории с обновлениями, но не основные.

Оффлайн ogost

Re: Debian Wheezy требует диск для установки программ...
« Ответ #5 : 12 Сентября 2014, 10:18:53 »

используйте тэг код или спойлер для больших выхлопов!

Оффлайн Baron Rojo

Re: Debian Wheezy требует диск для установки программ...
« Ответ #6 : 12 Сентября 2014, 13:16:15 »
Благодарю, пошел искать :)
 

Vacka

  • Гость
 

Теги:
     

    Существует ли пакет KMSCON для Debian?

    Автор Sferg

    Ответов: 6
    Просмотров: 1538
    Последний ответ 23 Августа 2013, 21:53:11
    от Sferg
    Debian зависает при выключении.

    Автор eric

    Ответов: 3
    Просмотров: 1798
    Последний ответ 15 Июля 2015, 05:14:22
    от ihammers
    virtualbox и гость Debian с MYSQL

    Автор mraksoll

    Ответов: 1
    Просмотров: 1130
    Последний ответ 11 Июля 2017, 13:00:18
    от ihammers
    Обновление Debian 8 -> 9. Артефакты.

    Автор Grey_rnd

    Ответов: 14
    Просмотров: 2077
    Последний ответ 12 Июля 2018, 17:35:04
    от ZEN
    Как обновить Unetbootin в Debian 6.0.4 sgueeze

    Автор fox

    Ответов: 2
    Просмотров: 1861
    Последний ответ 14 Мая 2012, 13:36:27
    от fox