Автор Тема: [Решено] При обновлении программ возникает ошибка  (Прочитано 15043 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн phantasm

Доброго времени суток!

Debian 7 x64 (от vmware 10).

phantasm@debian:~$ sudo aptitude upgrade
Следующие пакеты будут обновлены:               
  acpi-support-base apt apt-utils bind9-host dbus dbus-x11 dnsutils file
  gnupg gpgv host libapt-inst1.5 libapt-pkg4.12 libavcodec53 libavformat53
  libavutil51 libbind9-80 libcurl3-gnutls libdbus-1-3 libdns88 libisc84
  libisccc80 libisccfg82 liblwres80 libmagic1 libpostproc52 libswscale2
Следующие частично установленные пакеты будут настроены:
  install-info
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  gnupg-curl
27 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B/10,8 MB архивов. После распаковки 20,5 kB будет занято.
Хотите продолжить? [Y/n/?] Y
Чтение журнала изменений... Выполнено                 
Настраивается пакет install-info (4.13a.dfsg.1-10) …
/usr/sbin/update-info-dir: line 51: rm: команда не найдена
dpkg: ошибка при обработке параметра install-info (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
Настраивается пакет install-info (4.13a.dfsg.1-10) …
/usr/sbin/update-info-dir: line 51: rm: команда не найдена
dpkg: ошибка при обработке параметра install-info (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
 install-info

В чём может быть причина и как можно отлаживать подобные ошибки в Debian?

phantasm@debian:~$ cat /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

deb http://ftp.ru.debian.org/debian/ wheezy main
deb-src http://ftp.ru.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ wheezy-updates main
deb-src http://ftp.ru.debian.org/debian/ wheezy-updates main

# Debian 7 "Wheezy"
deb http://http.debian.net/debian/ wheezy main contrib

phantasm@debian:~$ ls -R /etc/apt/sources.list.d/
/etc/apt/sources.list.d/:
pgdg.list  pgdg.list.save

« Последнее редактирование: 21 Сентября 2014, 19:08:00 от qupl »
 

Оффлайн qupl

Re: При обновлении программ возникает ошибка
« Ответ #1 : 17 Сентября 2014, 18:55:53 »
Выполнять обновление в консоли и смотреть весь вывод ошибок. Универсальных способов нет.

Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #2 : 17 Сентября 2014, 21:00:04 »
Выполнять обновление в консоли и смотреть весь вывод ошибок. Универсальных способов нет.

Ага. Посмотрел тут.

phantasm@debian:~$ aptitude update
E: Не удалось открыть файл блокировки /var/lib/apt/lists/lock - open (13: Отказано в доступе)
E: Невозможно заблокировать каталог /var/lib/apt/lists/
phantasm@debian:~$ sudo !!
sudo aptitude update
[sudo] password for phantasm:
Из кэша http://ftp.ru.debian.org wheezy Release.gpg
Игнор   http://ppa.launchpad.net wheezy Release.gpg                             
Получить: 1 http://ftp.ru.debian.org wheezy-updates Release.gpg [836 B]         
Из кэша http://ftp.ru.debian.org wheezy Release                                 
Игнор   http://ppa.launchpad.net wheezy Release                                 
Получить: 2 http://ftp.ru.debian.org wheezy-updates Release [124 kB]           
Получить: 3 http://security.debian.org wheezy/updates Release.gpg [836 B]       
Получить: 4 http://security.debian.org wheezy/updates Release [102 kB]         
Из кэша http://apt.postgresql.org wheezy-pgdg Release.gpg                       
Из кэша http://http.debian.net wheezy Release.gpg                               
Из кэша http://ftp.ru.debian.org wheezy/main Sources
Из кэша http://ftp.ru.debian.org wheezy/main amd64 Packages                     
Из кэша http://ftp.ru.debian.org wheezy/main Translation-ru                     
Из кэша http://ftp.ru.debian.org wheezy/main Translation-en                     
Получить: 5 http://ftp.ru.debian.org wheezy-updates/main Sources [4 478 B]     
Из кэша http://apt.postgresql.org wheezy-pgdg Release
Из кэша http://http.debian.net wheezy Release                                   
Из кэша http://ftp.ru.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Из кэша http://ftp.ru.debian.org wheezy-updates/main Translation-en/DiffIndex
Получить: 6 http://security.debian.org wheezy/updates/main Sources [127 kB]     
Из кэша http://apt.postgresql.org wheezy-pgdg/main amd64 Packages               
Из кэша http://http.debian.net wheezy/main amd64 Packages                       
Из кэша http://http.debian.net wheezy/contrib amd64 Packages                   
Получить: 7 http://security.debian.org wheezy/updates/main amd64 Packages [215 kB]
Из кэша http://http.debian.net wheezy/contrib Translation-en                   
Из кэша http://http.debian.net wheezy/main Translation-ru                       
Из кэша http://http.debian.net wheezy/main Translation-en                       
Получить: 8 http://security.debian.org wheezy/updates/main Translation-en [121 kB]
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-ru_RU           
Ошибка  http://ppa.launchpad.net wheezy/main Sources
  404  Not Found
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-ru
Ошибка  http://ppa.launchpad.net wheezy/main amd64 Packages
  404  Not Found
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-en
Игнор   http://ppa.launchpad.net wheezy/main Translation-ru_RU
Игнор   http://ppa.launchpad.net wheezy/main Translation-ru
Игнор   http://ppa.launchpad.net wheezy/main Translation-en
Получено 695 kБ в 2с (285 kБ/с)
W: Не удалось получить http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/wheezy/main/source/Sources: 404  Not Found
W: Не удалось получить http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/wheezy/main/binary-amd64/Packages: 404  Not Found
E: Не удалось скачать некоторые индексные файлы. Они были проигнорированы, или вместо них использовались старые.
E: Не удалось перестроить кэш пакетов

Текущее состояние: 22 обновлено [+18].

Т.е. подобную ошибку вызывает недействующий репозиторий?

Вроде бы репозитории в /etc/apt/sources.list хранятся. Но его там нет.

phantasm@debian:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

deb http://ftp.ru.debian.org/debian/ wheezy main
deb-src http://ftp.ru.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ wheezy-updates main
deb-src http://ftp.ru.debian.org/debian/ wheezy-updates main

# Debian 7 "Wheezy"
deb http://http.debian.net/debian/ wheezy main contrib

Этот репозиторий как-то можно найти и удалить?

[ot]P.S. В Chrome 36 #message_resizer не работает.[/ot]
« Последнее редактирование: 17 Сентября 2014, 21:03:47 от phantasm »
 

Оффлайн qupl

Re: При обновлении программ возникает ошибка
« Ответ #3 : 17 Сентября 2014, 21:05:11 »
ls -R /etc/apt/sources.list.d

Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #4 : 17 Сентября 2014, 21:32:17 »
ls -R /etc/apt/sources.list.d

И вправду.
phantasm@debian:~$ ls -R /etc/apt/sources.list.d
/etc/apt/sources.list.d:
pgdg.list  pgdg.list.save  webupd8team-java-wheezy.list
Удалил файл webupd8team-java-wheezy.list.

Далее, повторно проверяю:
phantasm@debian:~$ sudo aptitude update
[sudo] password for phantasm:
Из кэша http://ftp.ru.debian.org wheezy Release.gpg
Из кэша http://ftp.ru.debian.org wheezy-updates Release.gpg           
Из кэша http://ftp.ru.debian.org wheezy Release                       
Из кэша http://security.debian.org wheezy/updates Release.gpg         
Из кэша http://ftp.ru.debian.org wheezy-updates Release               
Из кэша http://ftp.ru.debian.org wheezy/main Sources                   
Из кэша http://security.debian.org wheezy/updates Release             
Из кэша http://ftp.ru.debian.org wheezy/main amd64 Packages           
Из кэша http://ftp.ru.debian.org wheezy/main Translation-ru           
Из кэша http://http.debian.net wheezy Release.gpg                     
Из кэша http://security.debian.org wheezy/updates/main Sources         
Из кэша http://ftp.ru.debian.org wheezy/main Translation-en           
Из кэша http://ftp.ru.debian.org wheezy-updates/main Sources           
Из кэша http://ftp.ru.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Из кэша http://ftp.ru.debian.org wheezy-updates/main Translation-en/DiffIndex
Из кэша http://security.debian.org wheezy/updates/main amd64 Packages
Из кэша http://http.debian.net wheezy Release                       
Из кэша http://apt.postgresql.org wheezy-pgdg Release.gpg
Из кэша http://security.debian.org wheezy/updates/main Translation-en 
Из кэша http://http.debian.net wheezy/main amd64 Packages             
Из кэша http://apt.postgresql.org wheezy-pgdg Release
Из кэша http://http.debian.net wheezy/contrib amd64 Packages           
Из кэша http://apt.postgresql.org wheezy-pgdg/main amd64 Packages     
Из кэша http://http.debian.net wheezy/contrib Translation-en           
Из кэша http://http.debian.net wheezy/main Translation-ru             
Из кэша http://http.debian.net wheezy/main Translation-en             
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-ru_RU
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-ru
Игнор   http://apt.postgresql.org wheezy-pgdg/main Translation-en
Ошибок не наблюдается.

Далее запускаю соответствующее приложение и вновь код 127.
Оказывается, моя догадка про репозиторий была неверна.  :(
- Вложения и другие параметры
 


Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #6 : 18 Сентября 2014, 18:26:27 »
apt-get upgradeпривыкайте уже к консоли.

А, так Я же оказывается в консоли то не вызывал процедуру обновления.
Почитал тут про update и upgrade. Теперь понятнее с этим стало, и почему ошибки не возникало, спасибо Вам.

phantasm@debian:~$ sudo apt-get update
В кэше http://ftp.ru.debian.org wheezy Release.gpg
В кэше http://ftp.ru.debian.org wheezy-updates Release.gpg                     
В кэше http://ftp.ru.debian.org wheezy Release                                 
В кэше http://ftp.ru.debian.org wheezy-updates Release                         
В кэше http://apt.postgresql.org wheezy-pgdg Release.gpg                       
В кэше http://ftp.ru.debian.org wheezy/main Sources                           
В кэше http://security.debian.org wheezy/updates Release.gpg                   
В кэше http://ftp.ru.debian.org wheezy/main amd64 Packages                     
В кэше http://ftp.ru.debian.org wheezy/main Translation-ru                     
В кэше http://ftp.ru.debian.org wheezy/main Translation-en                     
В кэше http://ftp.ru.debian.org wheezy-updates/main Sources                   
В кэше http://security.debian.org wheezy/updates Release                       
В кэше http://ftp.ru.debian.org wheezy-updates/main amd64 Packages/DiffIndex   
В кэше http://apt.postgresql.org wheezy-pgdg Release                           
В кэше http://http.debian.net wheezy Release.gpg                               
В кэше http://ftp.ru.debian.org wheezy-updates/main Translation-en/DiffIndex   
В кэше http://security.debian.org wheezy/updates/main Sources                 
В кэше http://apt.postgresql.org wheezy-pgdg/main amd64 Packages               
В кэше http://security.debian.org wheezy/updates/main amd64 Packages           
В кэше http://http.debian.net wheezy Release                                   
В кэше http://security.debian.org wheezy/updates/main Translation-en           
В кэше http://http.debian.net wheezy/main amd64 Packages                       
В кэше http://http.debian.net wheezy/contrib amd64 Packages                   
В кэше http://http.debian.net wheezy/contrib Translation-en                   
В кэше http://http.debian.net wheezy/main Translation-ru                       
В кэше http://http.debian.net wheezy/main Translation-en                       
Игн http://apt.postgresql.org wheezy-pgdg/main Translation-ru_RU
Игн http://apt.postgresql.org wheezy-pgdg/main Translation-ru
Игн http://apt.postgresql.org wheezy-pgdg/main Translation-en
Чтение списков пакетов… Готово             
phantasm@debian:~$ sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут обновлены:
  acpi-support-base apt apt-utils bind9-host dbus dbus-x11 dnsutils file gnupg
  gpgv host libapt-inst1.5 libapt-pkg4.12 libavcodec53 libavformat53
  libavutil51 libbind9-80 libcurl3-gnutls libdbus-1-3 libdns88 libisc84
  libisccc80 libisccfg82 liblwres80 libmagic1 libpostproc52 libswscale2
обновлено 27, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 3 332 kB/10,8 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 20,5 kB.
Хотите продолжить [Д/н]? Д
Получено:1 http://security.debian.org/ wheezy/updates/main libavutil51 amd64 6:0.8.16-1 [103 kB]
Получено:2 http://security.debian.org/ wheezy/updates/main libavcodec53 amd64 6:0.8.16-1 [2 520 kB]
Получено:3 http://security.debian.org/ wheezy/updates/main libavformat53 amd64 6:0.8.16-1 [477 kB]
Получено:4 http://security.debian.org/ wheezy/updates/main libpostproc52 amd64 6:0.8.16-1 [99,5 kB]
Получено:5 http://security.debian.org/ wheezy/updates/main libswscale2 amd64 6:0.8.16-1 [132 kB]
Получено 3 332 kБ за 6с (553 kБ/c)                                             
Чтение журнала изменений... Выполнено                 
Настраивается пакет install-info (4.13a.dfsg.1-10) …
/usr/sbin/update-info-dir: line 51: rm: команда не найдена
dpkg: ошибка при обработке параметра install-info (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Хотя сама команда rm в консоли выполняется корректно.

При таком вот обновлении есть разница какой командой (aptitude или apt-get) выполнять подобное обновление? Здесь говорят, что алгоритм у них несколько разный, но по сути одно и тоже.
 

Оффлайн ferum

Re: При обновлении программ возникает ошибка
« Ответ #7 : 18 Сентября 2014, 19:44:45 »
[ot]Уважаемые новички! Возможно в правилах форума этого нет но задавая побные вопросы возьмите за правило выкладывать для потенциальных помощников содержимое /etc/apt/sources.list  и /etc/apt/sources.list.d[/ot]
Все подобные беды от левых источников, у вас в системе установлены пакеты которые конфликтуют с пакетами обновлений.
Решение - убираем левые источники ( к ним относятся backports и в меньшей степени deb-multimedia), идём в synaptic и смотрим на пакеты без значка дебиан а особенно на пакеты отмеченые звёздочкой. Если для такого пакета нет возможности для повторной установки значит он установлен из сомнительного источника  и их можно удалять а потом ставить родные. Если получится большой список решайте сами что делать. Был у меня случай в практике когда я наобновлялся из репозитория e-tobi.net и не мог поставить vlc. Пришлось в ручную скачивать один из родных пакетов и ставить его через  dpkg -i  а потом разруливать зависимости через apt-get -f install.
У вас же возможно просто проблемы в sources.list давайте его в студию.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #8 : 18 Сентября 2014, 20:47:34 »
[ot]Уважаемые новички! Возможно в правилах форума этого нет но задавая побные вопросы возьмите за правило выкладывать для потенциальных помощников содержимое /etc/apt/sources.list  и /etc/apt/sources.list.d[/ot]
Содержимое /etc/apt/sources.list здесь, /etc/apt/sources.list.d - тут. На то и обратился новичок за помощью, что пока не знает как подобные проблемы отлаживать и устранять. Теперь вот этот пробел заполнен. :)
Или Вы имеете в виду, что нужно было в шапку данную информацию закинуть?

Все подобные беды от левых источников, у вас в системе установлены пакеты которые конфликтуют с пакетами обновлений.
Решение - убираем левые источники ( к ним относятся backports и в меньшей степени deb-multimedia),
А backports же официальный источник, хоть и из тестируемой версии. Или его именно поэтому можно "левым" отнести? В общем, репозиторев лишних вроде как нет, только "упаковочные" + pgdg (для БД postgre) [или его удалить?].

идём в synaptic и смотрим на пакеты без значка дебиан а особенно на пакеты отмеченые звёздочкой.
Да, пакеты без значка Debian имеются (со звёздочкой нет ни одного). Что интересное, среди них имеются python*, postgresql*, phppgadmin, sublime-text (которые в принципе и нужны для конечной цели - разработки), а также пакеты от nvidia, vmware. Вообще был кластер БД установлен по ману.

Если для такого пакета нет возможности для повторной установки значит он установлен из сомнительного источника  и их можно удалять а потом ставить родные. Если получится большой список решайте сами что делать.
В принципе всё это готов удалить. Только бы понять как правильно всё это дело устанавливать.
[ot]
Для разработки нужны:
python 2.* (vitrualenv, virtualenvwrapper)
django
java se свежая
кластер postgre
[/ot]

Был у меня случай в практике когда я наобновлялся из репозитория e-tobi.net и не мог поставить vlc. Пришлось в ручную скачивать один из родных пакетов и ставить его через  dpkg -i  а потом разруливать зависимости через apt-get -f install.
Такие страсти про обновления рассказываете :o. Может, подскажете ресурс, где можно подчерпнуть информацию какой ресурс можно использовать, а какой нет.

У вас же возможно просто проблемы в sources.list давайте его в студию.
Содержимое /etc/apt/sources.list
Закинул в шапку.
« Последнее редактирование: 18 Сентября 2014, 20:56:31 от phantasm »
 

Оффлайн ogost

Re: При обновлении программ возникает ошибка
« Ответ #9 : 18 Сентября 2014, 21:32:38 »
у вас видимо софт был надерган с ppa и прочих сторонних репов, таких как postgre.
кроме того, у вас вроде бы дублирется основной репозиторий:
Цитировать
http://ftp.ru.debian.org/debian wheezy main
http://http.debian.net/debian wheezy main contrib
вторая строчка - редиректор на лучшее возможное зеркало для вас. уберите его.

а ошибка видимо у вас именно из-за софта, надерганного из убунтушной ppa. попробуйте apt-get install -f.

Оффлайн ferum

Re: При обновлении программ возникает ошибка
« Ответ #10 : 19 Сентября 2014, 09:08:13 »
phantasm, nvidia и virtualbox проприаретарщина соответственно поставляется как есть. Установка пакетов из бэкпортов частенько рушат зависимости, это не секрет так же как и то что маны подобные приведённому вами пишут умельцы вроде нас с вами. И я грешен под настроение занимаюсь разработкой леплю горбатого, в том числе делаю бекпорты с бунтовских ppa ( обычно просто беру за шаблон дебианизацию ) иногда просто выкидываю патчи и обязательно отслеживаю зависимости. Случается что в нашем дистрибутиве в принципе нет тех сборочных и установочных зависимостей для некого приложения или плагина тогда пакеты с этими зависимостями так же приходится бекпортировать либо из сорцов убунту либо из тестируемого дистрибутива или SID. Иногда эти зависимости неразрешимо конфликтут с частью дебиановских пакетов. Тем не менее для решения отдельно взятой задачи на локальной машине для меня это выход. Была практика когда я предоставлял возможность опробовать мои поделия и другим интересующимся юзерам но всегда предупреждал о возможных последствиях. В большинстве случаев такие поделия вполне сносно работают во всяком случае не хуже чем работала вся ubuntu 8.10 - 9.10 но естественно риск загубить систему из за неучтёных ошибок присутствует. Однако иногда хочется шампанского....
Что бы не загаживать основную систему тем что необходимо для разработки я использую cowbuilder - очень удобная штука, мне нравится.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #11 : 20 Сентября 2014, 16:02:07 »
у вас видимо софт был надерган с ppa и прочих сторонних репов, таких как postgre.
Вообще считал что pgdg (во втором абзаце новости локаль на репу) официальный репозиторий.
Да, был один PPA (в теме выше). Сейчас удалён. Теперь знаю, что PPA - зло, если добавлять без понимания.

кроме того, у вас вроде бы дублирется основной репозиторий:
Цитировать (выделенное)
http://ftp.ru.debian.org/debian wheezy main
http://http.debian.net/debian wheezy main contrib
Не знал об этом, убрал, спасибо.

Результат выполнения:
apt-get install -fприложен в файле screen1.png

Может, что-то яснее станет по этой проблемке, при входе в консольный режим ругается bash (см. приложение в файле screen0.png).

phantasm, nvidia и virtualbox проприаретарщина соответственно поставляется как есть.
Проприетарные - в смысле не free? Пакеты nvidia, видимо, vmware сам устанавливал, их из сети точно не дёргал.

Установка пакетов из бэкпортов частенько рушат зависимости, это не секрет так же как и то что маны подобные приведённому вами пишут умельцы вроде нас с вами. И я грешен под настроение занимаюсь разработкой леплю горбатого, в том числе делаю бекпорты с бунтовских ppa ( обычно просто беру за шаблон дебианизацию ) иногда просто выкидываю патчи и обязательно отслеживаю зависимости. Случается что в нашем дистрибутиве в принципе нет тех сборочных и установочных зависимостей для некого приложения или плагина тогда пакеты с этими зависимостями так же приходится бекпортировать либо из сорцов убунту либо из тестируемого дистрибутива или SID. Иногда эти зависимости неразрешимо конфликтут с частью дебиановских пакетов. Тем не менее для решения отдельно взятой задачи на локальной машине для меня это выход. Была практика когда я предоставлял возможность опробовать мои поделия и другим интересующимся юзерам но всегда предупреждал о возможных последствиях. В большинстве случаев такие поделия вполне сносно работают во всяком случае не хуже чем работала вся ubuntu 8.10 - 9.10 но естественно риск загубить систему из за неучтёных ошибок присутствует. Однако иногда хочется шампанского....
Что бы не загаживать основную систему тем что необходимо для разработки я использую cowbuilder - очень удобная штука, мне нравится.
Хм, про зависимости пока толком не знаю, сейчас начну изучать эту темы для понимания.
О cowbuilder до сего момента не слышал, почитаю, попробую. Видимо, в моём случае он пригодится, спасибо.

В Debian имеются какие-либо средства отката/восстановления до определённой точки? Может, образ какой-то создаётся? Другими словами, интересует экспериментирование с установкой/заменой пакетов с возможностью отката в случае проблем (например, как в данной теме)?

Так понимаю, что моя проблема довольно-таки нетривиальная и проще (чтобы людей не дёргать ::)) переустановить систему и просто внимательнее устанавливать и настраивать софт. Если предложений больше нет, можем закрывать тему?
 

Оффлайн qupl

Re: При обновлении программ возникает ошибка
« Ответ #12 : 21 Сентября 2014, 09:30:21 »
Что выдаст на
apt-get -s purge install-info ?

Оффлайн phantasm

Re: При обновлении программ возникает ошибка
« Ответ #13 : 21 Сентября 2014, 11:13:33 »
Что выдаст на
Код: [Выделить]
apt-get -s purge install-info
?

Выдал следующее:
phantasm@debian:~$ sudo apt-get -s purge install-info
[sudo] password for phantasm:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут УДАЛЕНЫ:
  info* install-info*
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 27 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Purg info [4.13a.dfsg.1-10]
Purg install-info [4.13a.dfsg.1-10]
 

Оффлайн qupl

Re: При обновлении программ возникает ошибка
« Ответ #14 : 21 Сентября 2014, 11:18:38 »
apt-get purge install-info
apt-get install -f

Теги:
     

    [Решено] Ошибки после выполнения aptitude update

    Автор koljan8115

    Ответов: 1
    Просмотров: 3190
    Последний ответ 04 Сентября 2014, 07:19:56
    от ihammers
    [Решено]Слишком длинное имя файла,не копирует некоторые файлы веб страниц из Win

    Автор Pacman

    Ответов: 1
    Просмотров: 2962
    Последний ответ 27 Апреля 2016, 07:37:46
    от endru
    [РЕШЕНО] Перезагрузка из KDE ведёт себя странно

    Автор malkavian

    Ответов: 4
    Просмотров: 2134
    Последний ответ 11 Октября 2011, 18:41:31
    от malkavian
    [РЕШЕНО] Не работают видео в Яндекс браузере.

    Автор marksergeeff1

    Ответов: 11
    Просмотров: 3851
    Последний ответ 07 Августа 2018, 20:02:08
    от vovan--vovan
    backup-manager - не работает инкремент [решено]

    Автор Metus_Violarium

    Ответов: 0
    Просмотров: 2935
    Последний ответ 22 Июня 2012, 10:11:59
    от Metus_Violarium