Автор Тема: [Решено] Настройка подключения через TP-Link  (Прочитано 9015 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн smile94

Всем привет!
Времени оч мало, поэтому особо поиском не пользовался.
Прошу помочь в настройке подключения к интернету через wifi адаптер.
Адаптер TP-LINK TL-WN823N.

При подключении к компу лампочка на адаптере не загорается, комп wifi не видит.
lsusb выдает:
Bus 001 Device 002: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter

iwconfig ничего не показывает.

Собсно на этом я и залип, т.к. опыта мало.
« Последнее редактирование: 24 Сентября 2014, 21:14:55 от smile94 »
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #1 : 24 Сентября 2014, 12:30:46 »
драйвера нужно поставить на карточку:
apt-get install firmware-realtekи подгрузить модуль ядра:
modprobe rtl8192cu

Оффлайн smile94

Re: Настройка подключения через TP-Link
« Ответ #2 : 24 Сентября 2014, 12:41:09 »
Спасибо большое за быстрый ответ!

Как все оказывается просто! =)
Хватило и этого...
Еще раз большое спасибо!


И все же на будущее: Как подсунуть драйвер, если нет сети?
« Последнее редактирование: 24 Сентября 2014, 12:45:26 от smile94 »
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #3 : 24 Сентября 2014, 12:47:42 »
скачиваем с сайта: https://packages.debian.org/ru/wheezy/all/firmware-realtek/download

далее зависит от вас как перенесете пакет (флэшка, SSH и тд)

устанавливаете пакет:

dpkg -i /путь/до/файла.deb

Оффлайн smile94

Re: Настройка подключения через TP-Link
« Ответ #4 : 24 Сентября 2014, 12:52:21 »
Понял, спасибо!

Возник еще вопрос: как сделать, чтобы после перезагрузки не требовалось вводить modprobe для подключения к сети? =)
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #5 : 24 Сентября 2014, 13:04:52 »
После перезагрузки не потребуется вводить modprobe

Оффлайн smile94

Re: Настройка подключения через TP-Link
« Ответ #6 : 24 Сентября 2014, 13:08:59 »
Проблема в том, что я перезагрузил комп и индикатор на wifi-адаптере не загорелся, сети нет.
После
sudo modprobe rtl8192cu
диод загорелся, сеть поднялась.
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #7 : 24 Сентября 2014, 13:42:44 »
вообще должно было
можете подгружать через файл /etc/modules
на новой строке название модуля нужно написать и сохранить.

Оффлайн smile94

Re: Настройка подключения через TP-Link
« Ответ #8 : 24 Сентября 2014, 14:01:54 »
Разобрался, работает.
Еще раз спасибо!

Новая проблема - скорость соединения.
Она в разы меньше скорости на ноуте, через который я, собственно, пишу...

Что нужно смотреть в этом случае?
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #9 : 24 Сентября 2014, 14:51:53 »
смотрите на какой скорости работает карточка:
iwconfigвозможно плохой сигнал до точки доступа.
так же стоит проверить usb порт.

Оффлайн smile94

Re: Настройка подключения через TP-Link
« Ответ #10 : 24 Сентября 2014, 15:51:32 »
Большое спасибо за ответы!

Заново установил драйвера для адаптера, только не кривыми руками, а используя скрипт install.sh, предлагаемый производителем.
Скорость стала как должна быть, диод начал мигать (до переустановки горел постоянно).

Проблему с автозагрузкой модуля сама не решилась, поэтому воспользовался советом Endru и добавил строчку в /etc/modules.

Тему можно закрыть.
 

Оффлайн endru

Re: Настройка подключения через TP-Link
« Ответ #11 : 24 Сентября 2014, 17:17:45 »
А еще надо тему пометить решенной. для этого нужно дописать в тему первого сообщения [Решено]

Оффлайн smile94

Re: [Решено] Настройка подключения через TP-Link
« Ответ #12 : 24 Сентября 2014, 21:16:05 »
Спасибо, буду знать =)
 

Оффлайн karymovv

Re: [Решено] Настройка подключения через TP-Link
« Ответ #13 : 27 Апреля 2019, 15:27:43 »
У меня сеть видит, но не подключает.
« Последнее редактирование: 27 Апреля 2019, 21:03:52 от karymovv »
 

Оффлайн qupl

Re: [Решено] Настройка подключения через TP-Link
« Ответ #14 : 28 Апреля 2019, 15:44:54 »
У меня сеть видит, но не подключает.
Создайте отдельную тему и опишите железо и ОС.

Теги:
     

    [Решено]USB-модем МТС, не могу получить /dev/ttyUSB0

    Автор gardarea51

    Ответов: 8
    Просмотров: 24202
    Последний ответ 07 Декабря 2012, 09:06:14
    от gardarea51
    Не подключается Skype (Не удается подключиться к серверу) [РЕШЕНО]

    Автор sx88

    Ответов: 7
    Просмотров: 16461
    Последний ответ 07 Августа 2016, 08:58:11
    от sx88
    [Решено]пропал сетевой интерфейс

    Автор TheBigSnake

    Ответов: 1
    Просмотров: 657
    Последний ответ 12 Мая 2020, 13:40:54
    от TheBigSnake
    [РЕШЕНО] ipv6

    Автор polzovatel

    Ответов: 5
    Просмотров: 2180
    Последний ответ 06 Апреля 2011, 10:50:50
    от kstati
    [Решено]Configuring network interfaces при загрузке

    Автор Aliko

    Ответов: 7
    Просмотров: 2890
    Последний ответ 22 Сентября 2013, 17:42:08
    от Aliko