Пропадает сеть

Автор kolts, 30 сентября 2014, 17:46:12

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

kolts

Пропадает сеть после минуты работы. Вытаскиваю кабель, ставлю на место появляется опять на минуту. В виндосе сеть работает нормально. Вай фай работает нормально. До этого была Убунту в ней такие же приколы. Подумал дай установлю Дебиан может это глюки Убунты но история таже. Что может быть?

gardarea51

Как настраивали сеть?

kolts

Просто кабель втыкнул и по dhcp получил ip. Но пробовал я вручную настроить, история таже. Еще показывало много ошибок ifconfig в этой строке RX packets:0 errors:0 dropped:0 overruns:0 frame:0. Сейчас поставил xubuntu и тоже самое.

yura_n

Вы бы конфиги показали? Вывод ifconfig? Что в логах? Не предоставив никакой информации, какого вы ответа ждете?

ChubaDuba

Как один из вариантов попробуйте с каналами Wi-Fi на роутере поиграться...
Бλог   @chuba_duba

kolts

Сейчас постараюсь поподробнее.
ifconfig
eth0      Link encap:Ethernet  HWaddr dc:0e:a1:df:6d:31 
          inet addr:192.168.1.167  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::de0e:a1ff:fedf:6d31/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16

lo        Link encap:Локальная петля (Loopback) 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1614 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1614 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:210796 (210.7 KB)  TX bytes:210796 (210.7 KB)

wlan0     Link encap:Ethernet  HWaddr 44:6d:57:5a:37:01 
          inet6 addr: fe80::466d:57ff:fe5a:3701/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:8398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4801 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10608558 (10.6 MB)  TX bytes:525851 (525.8 KB)


lspci

02:00.0 Ethernet controller: Qualcomm Atheros AR8162 Fast Ethernet (rev 08)
   Subsystem: Lenovo Device 3979
   Flags: bus master, fast devsel, latency 0, IRQ 46
   Memory at d3900000 (64-bit, non-prefetchable) [size=256K]
   I/O ports at 2000 [size=128]
   Capabilities: [40] Power Management version 3
   Capabilities: [58] Express Endpoint, MSI 00
   Capabilities: [c0] MSI: Enable+ Count=1/16 Maskable+ 64bit+
   Capabilities: [d8] MSI-X: Enable- Count=16 Masked-
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [180] Device Serial Number ff-df-6d-31-dc-0e-a1-ff
   Kernel driver in use: alx
Ноутбук Lenovog580. До этого сидел с только с вайфаем и даже не знал что есть эта проблема.
/etc/network/interfaces Вообще не трогал:

auto lo
iface lo inet loopback


ChubaDuba


Цитата: kolts от 30 сентября 2014, 21:17:32До этого сидел с только с вайфаем и даже не знал что есть эта проблема.
На винде сидели? Тут может быть всё просто - тупо проблема в корявых дровах на Wi-Fi.
Бλог   @chuba_duba

kolts

Да не в вайфае проблема. Проблема только с проводной сетью и только в линуксе. В винде все ок. И с вайфаем в линуксе тоже все нормально. Сидел я с вайфаем под линуксом и даже не знал что проблема с проводной сетью, потому что не пользовался. Сегодня только это узнал.

ChubaDuba

Хм...Обычно с вафлей проблемы...Не понял ваш вопрос с самого начала.
Бλог   @chuba_duba

ChubaDuba

С разными провайдерами такой глюк?
Бλог   @chuba_duba

yura_n

Судя по адресу, компьютер во внутренней сети. Попробуйте подключиться напрямую, до роутера. Появится глюк или нет?

kolts

#11
Ноутбук подключен напрямую к роутеру. Я уверен на 99 процентов что проблема с драйвером для линукса сети ноутбука. В винде то не пропадает ничего. В каких логах можно посмотреть кроме dmesg? В трех дисрибутивах такая же проблема. В кабеле тоже нет проблемы в винде то не пропадает. Более того  я сейчас к тому кабелю подсоединил еще один роутер и уже через его вайфай сижу. Так ничего не пропадает.
В дебиане показывало много ошибок RX в ifconfig. Сейчас ксубунта не показывает почему то ошибки

ChubaDuba

#12
Я бы всё же сделал следующее:

1. Попробовать с другим провайдером.
2. Как советует yura_n выкинуть роутер и подключиться напрямую.
3. Ради интереса поставить дистрибутив не на основе Debian.
4. Всё остальное: настройки, логи и т.д.
Бλог   @chuba_duba

endru

Ноутбук? Попробуйте заменить кабель или обжать заново!

ogost

в вики сказано, использовать ядро из бэкпортов.
давайте вывод cat /var/log/syslog в момент пропадания сети