Автор Тема: Отключаются звук и сеть  (Прочитано 2594 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн smokie

Отключаются звук и сеть
« : 20 Октября 2014, 14:45:20 »
Всем доброго времени суток!

Мне не удалось найти ничего похожего на просторах гугла и форума, потому решил попробывать задать вопрос здесь, может кто подскажет куда капать и как бороться.
Сталкнулся с необчным явлением. Время от времени у меня отключается звук и сеть, просто пропадает. Сеть возвращается довольно благополучно после обычного рестарта сервиса networking, а вот звук не возвращается до полного рестарта. Причем звуковые программы говорят что аудио устройства просто нет. перезапуск alsa-utils ничего не даёт, попытка переинициализирвать устройство, тоже не даёт результатов (alsactl init) - устройство находится, но звука всё равно нет. Проблема появилась довольно довно, стоял LMDE (Linux Mint Debian Edition), сейчас Wheezy 7,6, а немного раньше стоял Linux Mint 17 MATE - тут всё работало, по крайней мере я такого не замечал...

Ядро 3.2.0-4-amd64

Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
 

Оффлайн ioann.sys

Re: Отключаются звук и сеть
« Ответ #1 : 20 Октября 2014, 15:09:19 »
Довольно интересное явление... А вы пробовали обновить пакеты? sudo apt-get update && apt-get upgrade
Debian GNU/Linux jessie/sid on notebook ASUS N750JK
 

Оффлайн smokie

Re: Отключаются звук и сеть
« Ответ #2 : 20 Октября 2014, 15:28:58 »
Да, я не так давно переустановил ОС потому, апдейты делал почти каждый день в течении последней недели. Но ризультат - никаких изменений.
Примечательно что иногда всё работает по много часов, без каких либо проблем, а иногда такое может случиться через 5-10 мин после старта... Пока не смог придумать никакой связи с возможным перегревом или ещё что-то аппаратное, грешу на драйвер чип сета или шины (что там всё объединяет?). Но может я просто не туда смотрю...
 

Yrii

  • Гость
Re: Отключаются звук и сеть
« Ответ #3 : 20 Октября 2014, 15:52:54 »
как только снова всё пропадёт - скидывай логи из /var/log
 

Оффлайн ferum

Re: Отключаются звук и сеть
« Ответ #4 : 20 Октября 2014, 20:35:10 »
Попробуйте просто переустановить ядро через synaptic  и наверное не будет хуже предварительно  почистить кэш пакетов ( на случай если пакет ядра повреждён).
Русские дебианщики против цифрового слабоумия !
 

Оффлайн smokie

Re: Отключаются звук и сеть
« Ответ #5 : 20 Октября 2014, 22:04:10 »
Несколько часов всё работало как часы, и вот опять всё отвалилось... но в логах обсалютно про это ничего?! как такое может быть?

Вот логи перед самым отключением:
Код: (syslog) [Выделить]
ct 20 19:17:01 gigabyte /USR/SBIN/CRON[24533]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Oct 20 19:35:00 gigabyte kernel: [26184.600034] nfs: server nas not responding, still trying
Код: (kern.log) [Выделить]
Oct 20 18:14:02 gigabyte kernel: [21326.660642] input: HID 04f3:0103 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.1/input/input8
Oct 20 18:14:02 gigabyte kernel: [21326.661165] generic-usb 0003:04F3:0103.0006: input,hidraw1: USB HID v1.10 Device [HID 04f3:0103] on usb-0000:00:1d.2-1/input1
Oct 20 19:35:00 gigabyte kernel: [26184.600034] nfs: server nas not responding, still trying
Код: (dmesg) [Выделить]
[   13.663451] r8169 0000:03:00.0: firmware: agent aborted loading rtl_nic/rtl8168e-2.fw (not found?)
[   13.663589] r8169 0000:03:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168e-2.fw (-2)
[   13.679539] r8169 0000:03:00.0: eth0: link down
[   13.679551] r8169 0000:03:00.0: eth0: link down
[   13.680625] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.799101] r8169 0000:03:00.0: eth0: link up
[   15.800144] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   20.478687] RPC: Registered named UNIX socket transport module.
[   20.478693] RPC: Registered udp transport module.
[   20.478696] RPC: Registered tcp transport module.
[   20.478699] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   20.511890] FS-Cache: Loaded
[   20.567084] FS-Cache: Netfs 'nfs' registered for caching
[   20.598192] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Судя по всему инициализация сетевого интерфейса при старте
Код: (messages) [Выделить]
Oct 20 18:14:02 gigabyte kernel: [21326.168076] usb 4-1: USB disconnect, device number 2
Oct 20 18:14:02 gigabyte kernel: [21326.464056] usb 4-1: new low-speed USB device number 4 using uhci_hcd
Oct 20 18:14:02 gigabyte kernel: [21326.621343] usb 4-1: New USB device found, idVendor=04f3, idProduct=0103
Oct 20 18:14:02 gigabyte kernel: [21326.621349] usb 4-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Oct 20 18:14:02 gigabyte kernel: [21326.637934] input: HID 04f3:0103 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/input/input7
Oct 20 18:14:02 gigabyte kernel: [21326.638416] generic-usb 0003:04F3:0103.0005: input,hidraw0: USB HID v1.10 Keyboard [HID 04f3:0103] on usb-0000:00:1d.2-1/input0
Oct 20 18:14:02 gigabyte kernel: [21326.660642] input: HID 04f3:0103 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.1/input/input8
Oct 20 18:14:02 gigabyte kernel: [21326.661165] generic-usb 0003:04F3:0103.0006: input,hidraw1: USB HID v1.10 Device [HID 04f3:0103] on usb-0000:00:1d.2-1/input1
Oct 20 18:14:02 gigabyte mtp-probe: checking bus 4, device 4: "/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-1"
Oct 20 18:14:02 gigabyte mtp-probe: bus: 4, device: 4 was not an MTP device
Oct 20 19:35:00 gigabyte kernel: [26184.600034] nfs: server nas not responding, still trying
Код: (daemon.log) [Выделить]
Oct 20 18:14:02 gigabyte acpid: input device has been disconnected, fd 7
Oct 20 18:14:02 gigabyte acpid: input device has been disconnected, fd 8
Oct 20 19:03:28 gigabyte dhclient: DHCPREQUEST on eth0 to 192.168.11.250 port 67
Oct 20 19:03:28 gigabyte dhclient: DHCPACK from 192.168.11.250
Oct 20 19:03:29 gigabyte dhclient: bound to 192.168.11.12 -- renewal in 2775 seconds.
Код: (user.log) [Выделить]
ct 20 18:14:02 gigabyte mtp-probe: checking bus 4, device 4: "/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-1"
Oct 20 18:14:02 gigabyte mtp-probe: bus: 4, device: 4 was not an MTP device

Может я конечно чего-то не понимаю, но неужели это как-то не должно отображаться в логах? или это можно как-то регулировать чтобы было больше инфы?

Цитата: ferum
Попробуйте просто переустановить ядро через synaptic  и наверное не будет хуже предварительно  почистить кэш пакетов ( на случай если пакет ядра повреждён).
2ferum Мне кажется невероятным что в 3-ех случаях ядро было поврежденно. Я недавно переустановил, до этого стоял LMDE (там тоже ядро дебиана), и было тоже самое. во время переустановки в качестве эксперемента ставил дебиан с готовой оболочкой, с другого диска - было тоже самое. А последний вариант с которого я сижу и сейчас был установлен из сети (netinstall или как-то так). А какое ядро посоветуете дебиановское или виниловое? Синаптика нет потому только вариант через apt или собрать из исходников... если уж переустанавливать кажется лучше взять из исходников или нет?
« Последнее редактирование: 20 Октября 2014, 22:11:44 от smokie »
 

Yrii

  • Гость
Re: Отключаются звук и сеть
« Ответ #6 : 20 Октября 2014, 22:13:37 »
из  bpo поставь, там посвежее - linux-image-3.16
и firmware-linux-free, firmware-linux-nonfree оттуда же
 

Оффлайн smokie

Re: Отключаются звук и сеть
« Ответ #7 : 21 Октября 2014, 02:19:03 »
из  bpo поставь, там посвежее - linux-image-3.16
и firmware-linux-free, firmware-linux-nonfree оттуда же
Я не совсем понимаю, у меня судя по выводу uname -r
Код: ('uname -r') [Выделить]
3.2.0-4-amd64такое же ядро как в BackPorts
linux-image-3.2.0-2-rt-amd64 3.2.19-1
linux-image-3.2.0-2-amd64 3.2.19-1
linux-image-3.2.0-4-rt-amd64 3.2.63-2
linux-image-3.2.0-4-amd64 3.2.63-2
Нашёл так же версию linux-image-3.14-0.bpo.1-amd64 правда не совсем понятно как это ядро более свежее судя по версии, оно немного старее или я просто не в теме? Разъясните пожалсто?
Ядро поставил на установку, буду наблюдать...
 

Оффлайн qupl

Re: Отключаются звук и сеть
« Ответ #8 : 21 Октября 2014, 06:41:24 »
smokie, 3.14  не может быть старее 3.2.   И на 3.2 ваша карта должна работать, но обновить стОит для эксперимента. Под другими ОС такие проблемы (одновременное пропадание сети и звука) не встречаются?

Yrii

  • Гость
Re: Отключаются звук и сеть
« Ответ #9 : 21 Октября 2014, 10:55:11 »
Нашёл так же версию linux-image-3.14-0.bpo.1-amd64 правда не совсем понятно как это ядро более свежее судя по версии, оно немного старее или я просто не в теме? Разъясните пожалсто?
https://packages.debian.org/wheezy-backports/linux-image-3.16-0.bpo.2-amd64
https://www.debian.org/doc/debian-policy/ch-controlfields.html#s-f-Version
linux-image-3.16-0.bpo.2-amd64. Расшифровка:
Имя пакета-<версия программы>-<версия пакета>.реп_bpo.<номер пересборки>-архитектура
 

Оффлайн ogost

Re: Отключаются звук и сеть
« Ответ #10 : 21 Октября 2014, 11:20:07 »
судя по этому у вас нет правильных дров к сетевой плате.
[   13.663451] r8169 0000:03:00.0: firmware: agent aborted loading rtl_nic/rtl8168e-2.fw (not found?)
[   13.663589] r8169 0000:03:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168e-2.fw (-2)
это при старте системы.
если мне не изменяет память со склерозом, с этой карточкой были неполадки с именно с драйверами, так что как посоветовали коллеги, установите ядро по-новее, установите пакеты firmware-linux-nonfree, firmware-linux-free, firmware-realtek из ветки backports non-free.
в логах ничего связанного со звуком не увидел, может пульса чудит?

Оффлайн smokie

Re: Отключаются звук и сеть
« Ответ #11 : 21 Октября 2014, 13:22:54 »
Драва постави, ядро тоже... правда у меня упали иксы... :( пока разбераюсь... посмотрим, как будет работать
А звук стоит alsa, pulse нет совсем, но в последние время звук не пропадал... посмотрим может с ним и нет больше затруднений.

Про 3.16 и 3.2 - извените за гон, я почемуто посчитал запись 3.16 как 3.1.6 ...  ::)

UPD:
Поставил 3.14 и firmware-linux - пока сеть падает... :( сейчас обновляю до 3.16 (странно почему я сразу этого не сделал?! ???)

UPD2:
Прошло около двух часов и опять отрубилась сеть и звук вот что мне выдал аудио плеер
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ERROR: Cannot open device alsa.
В логах опять ничего, чуть попозже выложу логи

Немного попытался разобраться с альсой, правда не особо понимаю почему она занята
# alsa force-reload
Код: ('alsa force-reload') [Выделить]
alias: snd-card-0 not found
alias: snd-hda-intel not found
# lsmod | grep snd
Код: ('lsmod | grep snd') [Выделить]
snd_hda_codec_realtek    62994  1
snd_hda_codec_generic    63154  1 snd_hda_codec_realtek
snd_hda_intel          26327  3
snd_hda_controller     26631  1 snd_hda_intel
snd_hda_codec         108219  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              17205  1 snd_hda_codec
snd_pcm                88538  4 snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq                57061  0
snd_seq_device         13132  1 snd_seq
snd_timer              26768  2 snd_pcm,snd_seq
snd                    69285  14 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              13026  2 snd,snd_hda_codec
и почему он не может найти модули которые вроде как загруженны? ??? Или оно ищет что-то другое?
« Последнее редактирование: 22 Октября 2014, 14:39:45 от smokie »
 

Оффлайн smokie

Re: Отключаются звук и сеть
« Ответ #12 : 22 Октября 2014, 14:55:00 »
Логи.... на самом деле в логах почти ничего нет, вот только syslog:
Код: (syslog) [Выделить]
Oct 21 23:17:01 gigabyte /USR/SBIN/CRON[7562]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Oct 21 23:49:08 gigabyte dhclient: Internet Systems Consortium DHCP Client 4.2.2
Oct 21 23:49:08 gigabyte dhclient: Copyright 2004-2011 Internet Systems Consortium.
Oct 21 23:49:08 gigabyte dhclient: All rights reserved.
Oct 21 23:49:08 gigabyte dhclient: For info, please visit https://www.isc.org/software/dhcp/
Oct 21 23:49:08 gigabyte dhclient:
Oct 21 23:49:08 gigabyte dhclient: Listening on LPF/eth0/1c:6f:65:71:f7:2b
Oct 21 23:49:08 gigabyte dhclient: Sending on   LPF/eth0/1c:6f:65:71:f7:2b
Oct 21 23:49:08 gigabyte dhclient: Sending on   Socket/fallback
Oct 21 23:49:09 gigabyte dhclient: DHCPRELEASE on eth0 to 192.168.11.250 port 67
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Withdrawing address record for 192.168.11.12 on eth0.
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.11.12.
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Interface eth0.IPv4 no longer relevant for mDNS.
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Interface eth0.IPv6 no longer relevant for mDNS.
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::1e6f:65ff:fe71:f72b.
Oct 21 23:49:09 gigabyte avahi-daemon[2847]: Withdrawing address record for fe80::1e6f:65ff:fe71:f72b on eth0.
Oct 21 23:49:09 gigabyte dhclient: Internet Systems Consortium DHCP Client 4.2.2
Oct 21 23:49:09 gigabyte dhclient: Copyright 2004-2011 Internet Systems Consortium.
Oct 21 23:49:09 gigabyte dhclient: All rights reserved.
Oct 21 23:49:09 gigabyte dhclient: For info, please visit https://www.isc.org/software/dhcp/
Oct 21 23:49:09 gigabyte dhclient:
Oct 21 23:49:09 gigabyte kernel: [ 6379.107665] r8169 0000:03:00.0 eth0: link down
Oct 21 23:49:09 gigabyte kernel: [ 6379.107706] r8169 0000:03:00.0 eth0: link down
Oct 21 23:49:09 gigabyte kernel: [ 6379.107763] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Oct 21 23:49:09 gigabyte dhclient: Listening on LPF/eth0/1c:6f:65:71:f7:2b
Oct 21 23:49:09 gigabyte dhclient: Sending on   LPF/eth0/1c:6f:65:71:f7:2b
Oct 21 23:49:09 gigabyte dhclient: Sending on   Socket/fallback
Oct 21 23:49:09 gigabyte dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
Oct 21 23:49:11 gigabyte kernel: [ 6381.739858] r8169 0000:03:00.0 eth0: link up
Oct 21 23:49:11 gigabyte kernel: [ 6381.739874] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Oct 21 23:49:13 gigabyte avahi-daemon[2847]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::1e6f:65ff:fe71:f72b.
Oct 21 23:49:13 gigabyte avahi-daemon[2847]: New relevant interface eth0.IPv6 for mDNS.
Oct 21 23:49:13 gigabyte avahi-daemon[2847]: Registering new address record for fe80::1e6f:65ff:fe71:f72b on eth0.*.
Oct 21 23:49:16 gigabyte dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
Oct 21 23:49:16 gigabyte dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Oct 21 23:49:16 gigabyte dhclient: DHCPOFFER from 192.168.11.250
Oct 21 23:49:16 gigabyte dhclient: DHCPACK from 192.168.11.250
Oct 21 23:49:16 gigabyte avahi-daemon[2847]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.11.12.
Oct 21 23:49:16 gigabyte avahi-daemon[2847]: New relevant interface eth0.IPv4 for mDNS.
Oct 21 23:49:16 gigabyte avahi-daemon[2847]: Registering new address record for 192.168.11.12 on eth0.IPv4.
Oct 21 23:49:16 gigabyte dhclient: bound to 192.168.11.12 -- renewal in 2935 seconds.
Oct 22 00:04:21 gigabyte kernel: [ 7291.036033] nfs: server nas not responding, still trying
Это часть между пропаданием сети, как я и говорил в самом начале если перезапустить сервис networking, то сеть возвращается
... и kern.log
Код: (kern.log) [Выделить]
Oct 21 23:49:09 gigabyte kernel: [ 6379.107665] r8169 0000:03:00.0 eth0: link down
Oct 21 23:49:09 gigabyte kernel: [ 6379.107706] r8169 0000:03:00.0 eth0: link down
Oct 21 23:49:09 gigabyte kernel: [ 6379.107763] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Oct 21 23:49:11 gigabyte kernel: [ 6381.739858] r8169 0000:03:00.0 eth0: link up
Oct 21 23:49:11 gigabyte kernel: [ 6381.739874] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Oct 22 00:04:21 gigabyte kernel: [ 7291.036033] nfs: server nas not responding, still trying
Как я понимаю, вероятнее всего что всё это упирается в драйвер сетевой карты, и возможно в 64 битную систему, соответственно вопрос? Возможно ли что в 32 бита драйвер будет работать нормально?

И немного другой вопрос, где-то прочитал что ядро 686-pae способно поддерживать работу до 64 GB оперативной памяти. Поскольку у меня только 4 гига и обчное 32 битное ядро часть этой памяти не видит, я использую 64 битную версию (от чего, как мне кажется сильно теряю в производительности). Может кто подскажет на сколько это правда, и может действительно стоит попробывать ядро pae? или оно тоже 64 бита и драйвера там будут вести себя так же?
 

Теги: