Автор Тема: проблема с multisystem  (Прочитано 7515 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн saharov96

  • Новичок форума
  • Topic Author
  • Сообщений: 3
проблема с multisystem
« : 03 Декабрь 2014, 00:33:12 »
Всем привет.
Захотел создать мультизагрузочную флешку из-под debian. Сначала вот по этой http://ubuntism.ru/2011/02/multiboot-liveusb/ статье, потом по этой https://debianforum.ru/index.php?topic=2729.0 теме. Проблема такая-multisystem устанавливается, но при попытке запуска выдает вот это:
 
Цитировать
This application requires at least gtkdialog-0.8.3,
Please updrade your version.
Website: http://code.google.com/p/gtkdialog/


Ни на форуме, ни в интернете решения не нашел, прошу помочь. При попытке установить gtkdialog выдает вот это:
Цитировать
~$ sudo apt-get install gtkdialog
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия gtkdialog.
Следующий пакет устанавливался автоматически и больше не требуется:
  libgadu3
Для его удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
 


Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: проблема с multisystem
« Ответ #1 : 03 Декабрь 2014, 04:36:32 »
Вывод
apt-cache policy gtkdialog
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн toZen

  • Активный пользователь
  • **
  • Сообщений: 64
Re: проблема с multisystem
« Ответ #2 : 03 Декабрь 2014, 05:52:15 »
saharov96, понимаю, что мой совет не решит проблему описанную ТС, но может есть смысл не использовать сторонний софт и прикрутить все ручками? Сам использую сей чудный манускрипт. Удачи.
| Arch Linux Openbox | Crunchbang ++ |
 

Оффлайн saharov96

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: проблема с multisystem
« Ответ #3 : 03 Декабрь 2014, 14:53:33 »
Вывод
apt-cache policy gtkdialog

вот результат:
Цитировать
gtkdialog:
  Установлен: 2:0.8.3-2
  Кандидат:   2:0.8.3-2
  Таблица версий:
 *** 2:0.8.3-2 0
        500 http://liveusb.info/multisystem/depot/ all/main amd64 Packages
        100 /var/lib/dpkg/status

соответственно, установлена версия 0.8.3, я так понимаю. Тем не менее, ошибка никуда не делась.

saharov96, понимаю, что мой совет не решит проблему описанную ТС, но может есть смысл не использовать сторонний софт и прикрутить все ручками? Сам использую сей чудный манускрипт. Удачи.

Видел уже подобную статью, и не совсем понял, винда оттуда будет устанавливаться или нет. А винда нужна, флешка рабочая.
 

kefimow

  • Гость
Re: проблема с multisystem
« Ответ #4 : 03 Декабрь 2014, 15:34:48 »
Устанавливал как то Multisystem на свой компьютер, насколько помню пользоваться под Debian нормально этим приложением можно было только от root-пользователя. Т.е. войди в систему c правами root-пользователя и сделать флешку..
 

Оффлайн toZen

  • Активный пользователь
  • **
  • Сообщений: 64
Re: проблема с multisystem
« Ответ #5 : 03 Декабрь 2014, 20:15:36 »
saharov96, о винде как речи не было в первом посте. Как прикрутить - не знаю, не использую.
| Arch Linux Openbox | Crunchbang ++ |
 

Оффлайн I-Jurij

  • Местный житель
  • ***
  • Сообщений: 441
  • Slitaz
Re: проблема с multisystem
« Ответ #6 : 03 Декабрь 2014, 23:29:32 »
Тоже раньше делал это в мультисистем, но потом один раз сделал вручную - все работает.
Рецепт такой же ка по ссылке toZen. Линуксовые исошки просто копировать на флешку, семерку распаковать из образа в корень флешки.
Добавить в конфиг груба строки:
menuentry 'Windows 7'{
    set root='hd0,msdos1'
    insmod ntldr
    ntldr /bootmgr
}
menuentry "debian-7.4.0-amd64-netinst" {
    loopback loop /debian-7.4.0-amd64-netinst.iso
    linux (loop)/install.amd/vmlinuz boot=casper iso-scan/filename=/debian-7.4.0-amd64-netinst.iso noeject noprompt --
    initrd (loop)/install.amd/initrd.gz
}
А мультисистем ненадежный - после каждого обновления ломается.
И да: дебиан лучше грузить c помощью hd-media (initrd+vmlinuz), грубом запускать их, а они уже сами найдут образ дебиана.

А еще есть YUMI.
 

Оффлайн saharov96

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: проблема с multisystem
« Ответ #7 : 04 Декабрь 2014, 04:23:13 »
I-Jurij,
Spoiler: ShowHide
Тоже раньше делал это в мультисистем, но потом один раз сделал вручную - все работает.
Рецепт такой же ка по ссылке toZen. Линуксовые исошки просто копировать на флешку, семерку распаковать из образа в корень флешки.
Добавить в конфиг груба строки:
menuentry 'Windows 7'{
    set root='hd0,msdos1'
    insmod ntldr
    ntldr /bootmgr
}
menuentry "debian-7.4.0-amd64-netinst" {
    loopback loop /debian-7.4.0-amd64-netinst.iso
    linux (loop)/install.amd/vmlinuz boot=casper iso-scan/filename=/debian-7.4.0-amd64-netinst.iso noeject noprompt --
    initrd (loop)/install.amd/initrd.gz
}
А мультисистем ненадежный - после каждого обновления ломается.
И да: дебиан лучше грузить c помощью hd-media (initrd+vmlinuz), грубом запускать их, а они уже сами найдут образ дебиана.

А еще есть YUMI.


grub заработал. И, собственно, все. debian грузится, но потом сообщает о том, что что-то не так с cd-диском. Привод у меня вообще отключен от материнки.
Винда тоже сообщает о какой-то ошибке, но тут думаю я с именами накосячил, буду пробовать. Что не устроило debian я не понял.

upd

Устанавливал как то Multisystem на свой компьютер, насколько помню пользоваться под Debian нормально этим приложением можно было только от root-пользователя. Т.е. войди в систему c правами root-пользователя и сделать флешку..

попробовал из-под терминала суперпользователя запустить. У меня оказывается недостаточно прав.
« Последнее редактирование: 04 Декабрь 2014, 04:26:56 от saharov96 »
 

kefimow

  • Гость
Re: проблема с multisystem
« Ответ #8 : 04 Декабрь 2014, 07:24:21 »
Цитировать
попробовал из-под терминала суперпользователя запустить. У меня оказывается недостаточно прав.
Вы знаете, возможно приложение надо как то настроить, я в этом ничего не понимаю.. но у меня тоже из-под терминала multisystem отказывался работать. Надо было именно войти в систему суперпользователем, вот тогда приложение запускалось и можно было сделать флешку.
 

Оффлайн paulo737

  • Новичок форума
  • Сообщений: 1
Re: проблема с multisystem
« Ответ #9 : 23 Сентябрь 2015, 17:41:53 »
Всем привет.
Захотел создать мультизагрузочную флешку из-под debian. Сначала вот по этой http://ubuntism.ru/2011/02/multiboot-liveusb/ статье, потом по этой https://debianforum.ru/index.php?topic=2729.0 теме. Проблема такая-multisystem устанавливается, но при попытке запуска выдает вот это:
 
Цитировать (выделенное)
This application requires at least gtkdialog-0.8.3,
Please updrade your version.
Website: http://code.google.com/p/gtkdialog/

У меня тоже были проблемы с запуском multisystem в Debian wheezy. Выскакивало окошко с предупреждением, как у Вас, о версии gtkdialog. Решил это установкой более ранней версии gtkdialog-0.8.3-1, на момент первого запуска была версия 0.8.3-2. Скачать нужный пакет можно по адресу http://liveusb.info/multisystem/depot/dists/all/main. После этого программа multisystem стала запускаться с сообщением "user is not admin", но это решилось добавлением пользователя user в группу adm:
 usermod -a -G adm user
Надеюсь, что это поможет кому-то в запуске этой программки.
 

Оффлайн vacka

  • Местный житель
  • ***
  • Сообщений: 118
Re: проблема с multisystem
« Ответ #10 : 24 Сентябрь 2015, 10:38:01 »
обычно каких то проблем с multisystem не возникает, достаточно добавить в свой sources.list
## MultiSystem
deb http://liveusb.info/multisystem/depot all main
затем в терминале
sudo -iДобавить ключ
wget -q -O - http://liveusb.info/multisystem/depot/multisystem.asc |  apt-key add -
обновить репозитории
apt updateвозможно так
apt-get updateили
aptitude updateзатем устанавливайте приложение
apt install multisystemили
apt-get install multisystemопять же или
aptitude install multisystemи обязательно сделать
sudo usermod -a -G adm "$SUDO_USER"усё, после этого всё работает как надо.
источник
http://liveusb.info/dotclear/index.php?pages/install
 

Оффлайн EndryLoveson

  • Новичок форума
  • Сообщений: 1
Re: проблема с multisystem
« Ответ #11 : 01 Май 2020, 10:54:44 »
"А ларчик просто открывался". Я создал ярлык на рабочий стол, залез в свойства, вкладка "права" и группу поменял на "sudo", ВСЁ, работает.  ;)
 

Теги:
 

Проблема после обновления ядра в Wheezy

Автор dduh

Ответов: 5
Просмотров: 1828
Последний ответ 06 Ноябрь 2012, 21:36:11
от qupl
проблема с teamviewer 11

Автор k0matoznik

Ответов: 1
Просмотров: 1136
Последний ответ 14 Июнь 2016, 05:31:45
от endru
Проблема с 2 видеокартами ATI

Автор daun85

Ответов: 13
Просмотров: 1857
Последний ответ 21 Ноябрь 2014, 06:43:50
от qupl
Проблема с пакетом Rainlendar2

Автор Alexey2494

Ответов: 0
Просмотров: 1386
Последний ответ 28 Январь 2019, 00:04:13
от Alexey2494
Перенесено: Проблема установки libpq-dev

Автор qupl

Ответов: 0
Просмотров: 443
Последний ответ 16 Июнь 2019, 20:45:56
от qupl