Автор Тема: Ошибки при установке Samba.Решено.  (Прочитано 16290 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Александр_ru

Ошибки при установке Samba.Решено.
« : 30 Января 2015, 14:08:06 »
Доброе время суток Уважаемые! Прокомментируйте пожалуйста , как "это" победить :)
« Последнее редактирование: 02 Февраля 2015, 15:40:06 от Александр_ru »
 

Оффлайн flyer

Re: Ошибки при установке Samba
« Ответ #1 : 30 Января 2015, 14:30:13 »
sudo apt-get -f install
 

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #2 : 30 Января 2015, 15:13:35 »
Спасибо, но не помогло  :( тоже самое пишет в ответ...
 

Оффлайн qupl

Re: Ошибки при установке Samba
« Ответ #3 : 30 Января 2015, 15:14:27 »
cat /etc/apt/sources.list
uname -a

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #4 : 30 Января 2015, 15:22:08 »
 

Оффлайн qupl

Re: Ошибки при установке Samba
« Ответ #5 : 30 Января 2015, 15:32:53 »
Александр_ru, [ot]зачем текст картинками постить?[/ot]
Добавьте ветки contrib non-free , потом обновляйтесь и ставьте.
 
Пользователи, которые поблагодарили этот пост: Александр_ru

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #6 : 30 Января 2015, 15:38:25 »
я не знаю, как иначе "показать" ответ  ::)
понял, сейчас попробую :)

Сообщение объединено: [time]30 Январь 2015, 15:47:28[/time]
qupl, всё тоже самое  :(

Сообщение объединено: [time]30 Январь 2015, 15:52:52[/time]
и главное Linux "говорит", что установлена самая последняя Samba, хотя директория с Samba(ой) нет и соответственно, cfg тоже нет..., а также, что не установлено или удалено 4 пакета, очевидно те, которые и "озвучены" в картинке выше....
« Последнее редактирование: 30 Января 2015, 15:57:15 от Александр_ru »
 

Оффлайн ogost

Re: Ошибки при установке Samba
« Ответ #7 : 31 Января 2015, 08:19:31 »
беспорядок в sources.list
у вас я насчитал 2 зеркала для ветки main и 2 для обновлений безопасности. приведите в порядок, и всё установится.

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #8 : 02 Февраля 2015, 08:00:03 »
ogost, я это видел, но не думал, что это окажет такое влияние.... заремарил "дубли", обновился, на дубли больше не жалуется, но всё тоже самое  :(
Spoiler: ShowHide
root@isms2PS69:~# apt-get install  smbclient
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлена самая новая версия smbclient.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 6 пакетов не обновлено.
не установлено до конца или удалено 4 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить [Д/н]? y
Настраивается пакет winbind (2:3.6.6-6+deb7u4) …
[FAIL] Starting the Winbind daemon: winbind failed!
invoke-rc.d: initscript winbind, action "start" failed.
dpkg: ошибка при обработке параметра winbind (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет libnss-winbind:i386:
 libnss-winbind:i386 зависит от winbind (= 2:3.6.6-6+deb7u4), однако:
  Пакет winbind пока не настроен.


dpkg: ошибка при обработке параметра libnss-winbind:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libpam-winbind:i386:
 libpam-winbind:i386 зависит от winbind (= 2:3.6.6-6+deb7u4), однако:
  Пакет winbind пока не настроен.

dpkg: ошибка при обработке параметра libpam-winbind:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
Настраивается пакет samba (2:3.6.6-6+deb7u4) …
[FAIL] Starting Samba daemons: nmbd failed!
invoke-rc.d: initscript samba, action "start" failed.
dpkg: ошибка при обработке параметра samba (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 winbind
 libnss-winbind:i386
 libpam-winbind:i386
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)[/i]

используйте теги код или спойлер, ogost
« Последнее редактирование: 02 Февраля 2015, 08:54:03 от ogost »
 

Оффлайн endru

Re: Ошибки при установке Samba
« Ответ #9 : 02 Февраля 2015, 08:46:09 »
Александр_ru, давайте с самого начала:
1. приводим /etc/apt/sources.list к виду:
deb http://ftp.ru.debian.org/debian/ wheezy main contrib
deb http://security.debian.org/ wheezy/updates main contrib
deb http://ftp.ru.debian.org/debian/ wheezy-updates main contrib
2. Обновляем список пакетов:
apt-get update3. Пробуем еще раз установить пакеты:
apt-get -f install

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #10 : 02 Февраля 2015, 09:24:05 »
endru, всё сделал, как Вы сказали..... всё тоже самое....при установке вышеназванных пакетов произошли ошибки(выше) ...  :(
 

Оффлайн qupl

Re: Ошибки при установке Samba
« Ответ #11 : 02 Февраля 2015, 09:26:26 »
Александр_ru, тогда сначала удалите те пакеты, на которые ругается, потом заново установите.

Оффлайн Александр_ru

Re: Ошибки при установке Samba
« Ответ #12 : 02 Февраля 2015, 09:58:20 »
удалил эти 4 пакета dpkg --purge<имя пакета> , выполнил apt-get -f install , выполнил apt-get install smbclient , всё Ok. Дальше выполняю apt-get install samba,
[FAIL] Starting Samba daemons: nmbd failed!
invoke-rc.d: initscript samba, action "start" failed.
dpkg: ошибка при обработке параметра samba (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

прошу прощения  ::) , а как в спойлер разместить?  :(
 

Оффлайн qupl

Re: Ошибки при установке Samba
« Ответ #13 : 02 Февраля 2015, 10:11:51 »
а как в спойлер разместить? 
Над полем ввода текста есть кнопки, найти там кнопку "спойлер" (4-ая справа у меня).
 
Пользователи, которые поблагодарили этот пост: Александр_ru

Оффлайн endru

Re: Ошибки при установке Samba
« Ответ #14 : 02 Февраля 2015, 10:20:55 »
invoke-rc.d: initscript samba, action "start" failed.
dpkg: ошибка при обработке параметра samba (--configure):
давайте смотреть логи:
tail -n 50 /var/log/syslog

Теги:
     

    ошибки apt-get update

    Автор germes

    Ответов: 2
    Просмотров: 1940
    Последний ответ 24 Августа 2016, 13:07:17
    от germes
    Ошибки nginx

    Автор Паша-1

    Ответов: 1
    Просмотров: 1697
    Последний ответ 23 Октября 2018, 09:34:35
    от endru
    Перенесено: Ошибки в Devuan после обновления Firefox?

    Автор endru

    Ответов: 0
    Просмотров: 590
    Последний ответ 26 Декабря 2019, 03:46:57
    от endru
    "Иксы". Лог ошибки.

    Автор windolooser

    Ответов: 3
    Просмотров: 3223
    Последний ответ 13 Января 2012, 13:44:11
    от ihammers
    Ошибки зависимостей при каждом апдэйте

    Автор animegirl

    Ответов: 19
    Просмотров: 4171
    Последний ответ 17 Декабря 2012, 20:37:02
    от ihammers