Автор Тема: Ошибка (wxWidgets must be installed on your system.) -помогите разобраться.  (Прочитано 2544 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн temakonkin

Здорова всем, у меня 2 часа ночи), сижу расбираюсь с сборкой и установкой пакетов из сырцов.... скачал родимый Code::Blocks - сырцы, вроде то что нужно, пытаюсь собрать Makefile с помощью ./confugure - у меня в исходе такая вот ошибка..... что с ней делать ума не приложу.

Помогите разобраться пожалуйста.

checking for wx-config... no
configure: error:
                wxWidgets must be installed on your system.

                Please check that wx-config is in path, the directory
                where wxWidgets libraries are installed (returned by
                'wx-config --libs' or 'wx-config --static --libs' command)
                is in LD_LIBRARY_PATH or equivalent variable and
                wxWindows version is 2.8.0 or above.

В инете гуглил - но там всё на англ, я разобрать не могу, к сожалению не знаю языка....(

Заранее всем спасибо!

* используйте теги для оформления сообщения, ihammers.[color]
« Последнее редактирование: 21 Февраля 2015, 04:23:19 от ihammers »
 

Оффлайн ihammers

В ошибке написано, что ему нехватает пакета для сборки программы.
~$ apt-cache search wx-config
libwxgtk3.0-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
~$ sudo apt-get update
~$ sudo apt-get install libwxgtk3.0-dev

PS: возможно потребуется установить и другие пакеты, смотрите файлы readme или install.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Теги:
 

Ошибка при обновлении x86_64-linux-gnu/perl/5.28

Автор shlihta

Ответов: 33
Просмотров: 888
Последний ответ 29 Декабря 2020, 20:08:39
от qupl
Ошибка в /etc/apt/preferences

Автор CommanderG6

Ответов: 9
Просмотров: 2391
Последний ответ 13 Марта 2016, 23:56:31
от vic5710
Ошибка 404... с изюминкой

Автор Leo

Ответов: 11
Просмотров: 3009
Последний ответ 30 Июля 2012, 12:45:51
от rezedent12
Ошибка [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean

Автор qwers

Ответов: 1
Просмотров: 1507
Последний ответ 05 Августа 2016, 12:05:59
от ogost
Ошибка в репозиториях

Автор kex

Ответов: 2
Просмотров: 1376
Последний ответ 23 Декабря 2015, 01:00:44
от kex