Автор Тема: Проблема с регулировкой яркости дисплея  (Прочитано 3080 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн We-Love-Debian

Приветствую.
Помогите устранить проблему: не работает регулировка яркости. Не регулируется вообще никак, ни через хоткейс, ни через настройки. При этом, когда экран отключается, подсветка гаснет плавно.

Пробовал следующее:
xbacklight -  0 реакции со стороны подсветки. ключем set задавал разные значения, ось их принимала. При запросе этих значений данной утилитой отображалось, что они установлены нормально, т.е. ставлю set 20, спрашиваю сколько, мне выводит 20, а уровень подсветки остался прежним.

Далее на одном из блогов прочитал: "найдите файл xorg.conf, добавьте туда такую-то строку". Добавить надо в следующий текст то, что выделено красным:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Но у меня нету такого файла, и у меня не установлена доп. видео карта, только интеловская интегрированная графика.

Ноут бук Sony Vaio T13.
Debian 7.6 Wheezy, Gnome 3.

Подскажите где что искать, как устранять, а то у данного аппарата и так экран не ахти. В темноте так это вообще неудобно жуть.
 

Оффлайн qupl

We-Love-Debian, судя по ману у драйвера интел нет такой опции. Но попробовать можете. Имя драйвера только замените.

Оффлайн mrgoodvin

Проверите в /etc/default/grub следующие строки:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Если нет добавьте, и обновите grub: ~$ sudo update-grub
Перезагрузка.
 

Оффлайн We-Love-Debian

Если нет добавьте, и обновите grub: ~$ sudo update-grub
Перезагрузка.

Подстройка grub не даёт эффекта. также пробовал "acpi_osi=Linux". Тоже не работает. НО, когда выставляю "acpi_backlight=vendor", ползунок на экране не опускается ниже одного деления от самого яркого уровня, если я пытаюсь использовать функциональные кнопки.

Есть какие-нибуьд идеи ещё? За подсказку эту всё равно спасибо, попытка как говорится не пытка.
 

Оффлайн mrgoodvin

Можно посмотреть здесь: http://forum.ubuntu.ru/index.php?topic=216341.15
Можно создать конфигурационный файл в /etc/X11/xorg.conf.d/ например 60-intel.conf (как вы предлагали), с приведенным вами содержим, только изменить название драйвера на установленный в вашей системе.
Но с интегрированной intel не должно быть проблем. Что показывает ~$ glxinfo | grep -i opengl (нужен mesa-utils)?

Сообщение объединено: 06 Мая 2015, 00:17:12
Вместо glxinfo можно ~$ lspci -k | grep -E "VGA|3D"
« Последнее редактирование: 06 Мая 2015, 00:17:12 от mrgoodvin »
 

Оффлайн We-Love-Debian

Вывод glxinfo
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 3.0 Mesa 8.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Вывод lspci
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
 

Оффлайн mrgoodvin

Ну тогда можно попробовать в /etc/X11/xorg.conf.d/60-intel.conf:
Section "Device"
Identifier "card0"
Driver "intel"
Option "Backlight" "intel_backlight"
BusID "PCI:0:2:0"
EndSection

Параметры можно узнать по инструкции http://compizomania.blogspot.com/2014/06/ubuntu-1404linux-mint-17.html. По сути это будет:
~$ ls /sys/class/backlight/
~$ lspci | grep -i  VGA

~$ dpkg --list '*intel*' должен показать установленный xserver-xorg-video-intel
 

Оффлайн We-Love-Debian

Проблема была решена сама собой после перехода на Восьмую версию Дебиан. Видимо не хватало модуля в ядре, т.к. именно после оного обновления всё заработало.
 

Теги:
     

    [РЕШЕНО] Проблема после перехода с Gnome на Xfce

    Автор Упрямый

    Ответов: 4
    Просмотров: 6920
    Последний ответ 22 Сентября 2014, 11:21:10
    от Malaheenee
    Проблема ядра или канала full duplex

    Автор simonflex

    Ответов: 3
    Просмотров: 1469
    Последний ответ 24 Января 2019, 14:46:05
    от simonflex
    Проблема с www и закачкой файлов

    Автор kakawkin

    Ответов: 7
    Просмотров: 1856
    Последний ответ 29 Августа 2012, 15:15:56
    от kakawkin
    Проблема виснет ПК (debian) намертво.

    Автор ForsakeN1993

    Ответов: 17
    Просмотров: 3664
    Последний ответ 14 Марта 2016, 10:09:34
    от ForsakeN1993
    Debian 11 «Bullseye». Обновился c версии 10, но проблема с suspend/hibernate

    Автор arn

    Ответов: 15
    Просмотров: 729
    Последний ответ 04 Октября 2021, 18:17:26
    от dzhoser