Debian 8 Jessie и сетевая Realtek нет сети. [РЕШЕНО]

Автор Juriy, 08 мая 2015, 00:26:08

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Juriy

Решил поставить Debian 8 Jessie. А что бы не ставить не нужные пакеты которые идут с окружением рабочего стола решил ставить чистую и по мере необходимого устанавливать те пакеты которые потребуются. До этого ставил для проверки выбирал графическое окружение. Сеть работала. Когда определился с выбором. Начал устанавливать, пропала сеть. Хотя настройки указывал верные. Подключение к инету идет через роутер. Думал пусть поставиться без сети, а в консоли укажу в ручную. Не вышло хоть в network/interface и указываю верные параметры сеть запускаться отказывается.
lscpi | grep Ethernet02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
ifconfig
eth0      Link encap:Ethernet  HWaddr d0:27:88:6c:20:68 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:45 Base address:0xa000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1056 (1.0 KiB)  TX bytes:1056 (1.0 KiB)

пробовал прописывать для получения адреса по ДХЦП
/etc/network/interfaces
auto eth0
iface eth0 inet dhcp

и вручную
auto eth0
iface eth0 inet static
        address 192.168.1.2
        network 192.168.1.0
        netmask 255.255.255.0
        broadcast 192.168.1.255
        gateway 192.168.1.1


После установки пробовал ставить и пакет firmware-realtek_0.36+wheezy.1_all.deb. Пакет установился, но изменений не произошло. Так же в установочный дистрибутив добавлял в папку firmware модуль rtl8168d-2.fw на которую ругался дебиан при установке.

P.S. Пробовал также явно указывать ip через ifconfig eth0 inet 192.168.1.2/24
Адрес прописывается в /etc/network/interfaces но сеть не поднимается.
Пробовал подключать другую сетевую карту с тем же результатом.
Уже весь гугл перерыл, не ужели никто с таким не сталкивался.

ihammers

Почему версия пакета firmware-realtek_0.36+wheezy.1_all.deb, а не версия для Jessie (firmware-realtek_0.43_all.deb)?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Juriy

Цитата: ihammers от 08 мая 2015, 11:15:13Почему версия пакета firmware-realtek_0.36+wheezy.1_all.deb, а не версия для Jessie (firmware-realtek_0.43_all.deb)?

firmware-realtek_0.43_all.deb тоже ставил с при монтированной флешки, забыл указать. Также пробовал устанавливать версии отсюда https://debianforum.ru/go.php?url=http://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/, кстати firmware-realtek_0.43_all.deb от туда и брал.

mrgoodvin

#3
Опечатка в команде lspci.
Пробовали включить интерфейс# ip link set dev eth0 up?

Цитата: Juriy от 08 мая 2015, 00:26:08
... Когда определился с выбором. Начал устанавливать, пропала сеть.
Не совсем понятно.  Сеть пропала во время установки ОС? Вообще, не понятно как всё устанавливалось. Окружение рабочего стола установлено? Какое?
С чем связана настройка сети именно из консоли?

Цитата: Juriy от 08 мая 2015, 00:26:08
А что бы не ставить не нужные пакеты которые идут с окружением рабочего стола решил ставить чистую и по мере необходимого устанавливать те пакеты которые потребуются.
Но окружение же будет ставиться, пакеты потянутся в любом случае. И без DE, есть еще много чего ставить :). Пошаговая установка - ход мыслей верный.

А так, в общем, сеть должна работать, согласен.
Вот чтение этого https://wiki.archlinux.org/index.php/Networkconfiguration(Русский), надеюсь, поможет устранить проблему.

Juriy

Цитата: mrgoodvin от 08 мая 2015, 14:16:58Опечатка в команде lspci.
Да я в курсе команды не копировал набивал руками, на форуме с другого компьютера.
Цитата: mrgoodvin от 08 мая 2015, 14:16:58Не совсем понятно.  Сеть пропала во время установки ОС? Вообще, не понятно как всё устанавливалось. Окружение рабочего стола установлено? Какое?
Сеть во время установки вообще не поднималась. Сперва пытался поставить с двд образа 1 (Там в конце даётся выбор ставить окружение или нет и предлагают на выбор их +-4 штуки). Потом промучившись с поднятием сети подсовывал пакеты firmware-realtek, под конец пытался ставить версии от сюда http://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/. Окружение я не ставил сейчас голая консоль. До этого довольно долго стояла Ubuntu 10.04 так больше половины пакетов её мне не пригодились, а начинаешь удалять их тащили за собой не пойми что и в итоге приходилось восстанавливаться с бекапов. Поэтому и было принято решение ставить консоль и с неё уже нужное подтягивать если бы не траблы с сетью (Но злобный Realtek обломал весь благородный порыв). В Ubuntu сеть поднимать удавалось (Network-manager часто чудил), а вот в Debian и FreeBSD ни как на этом железе.
Цитата: mrgoodvin от 08 мая 2015, 14:16:58Но окружение же будет ставиться, пакеты потянутся в любом случае.
Нет, на двд есть возможность ставить без пакетов голое окружение.
ip link set dev eth0 up команда проходит по ifconfig видно что сетевая вроде поднята.
eth0      Link encap:Ethernet  HWaddr d0:27:88:6c:20:68
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

Но все равно когда пинг отправляю что на гугл, что на роутер пишит Network unreachable
Когда ip явно указываешь например ifconfig eth0 inet 192.168.1.2/24 up тот же результат только на выхлопе ifconfig ip прописан.
#ifdown eth0
ifdown: interface eth0 not configured

Хотя в /etc/network/interfaces все прописано как нужно, и /etc/init.d/networking restart делал после изменений и под конец систему перезагружал.

mrgoodvin

#5
Покажите все таки /etc/network/interfaces
#ifdown eth0
ifdown: interface eth0 not configured

Это предполагает, что в /etc/network/interfaces есть ошибка.


Сообщение объединено: 08 мая 2015, 17:38:40

Кстати, man interfaces о параметре network ничего не знает.

Juriy

#6
Цитата: mrgoodvin от 08 мая 2015, 17:15:50
Покажите все таки /etc/network/interfaces

сейчас ошибки нет, тк пробовал драйвер реалтековский поставить, так вообще сетевые интерфейсы потерялись. Ставил по новой. Network дописывает установщик Debiana (когда пробовал прописывать настройки для получения адреса по ДХЦП я их все #-комментировал). Пробовал шаманство от сюда https://wiki.archlinux.org/index.php/Network%20configuration не помогло.

mrgoodvin

#7
Возможно, проблема в драйверах тогда.
Вот была проблема с теми же драйверами: http://forum.ubuntu.ru/index.php?topic=203073.0

~$ lspci -knn | grep "Eth\|Net" -A2

Предлагается использовать r8168 вместо r8169. Но вот мой вывод:
Открыть содержимое (спойлер)

~$ lspci -knn | grep "Eth\|Net" -A2
02:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
Subsystem: Hewlett-Packard Company Device [103c:1453]
Kernel driver in use: rt2800pci
85:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: Hewlett-Packard Company Device [103c:1526]
Kernel driver in use: r8169
[свернуть]
У меня работает нормально сетевая на r8169, но система 7.8
Открыть содержимое (спойлер)
Цитировать~$ modinfo r8169
filename:       /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/realtek/r8169.ko
firmware:       rtl_nic/rtl8168f-2.fw
firmware:       rtl_nic/rtl8168f-1.fw
firmware:       rtl_nic/rtl8105e-1.fw
firmware:       rtl_nic/rtl8168e-3.fw
firmware:       rtl_nic/rtl8168e-2.fw
firmware:       rtl_nic/rtl8168e-1.fw
firmware:       rtl_nic/rtl8168d-2.fw
firmware:       rtl_nic/rtl8168d-1.fw
version:        2.3LK-NAPI
license:        GPL
description:    RealTek RTL-8169 Gigabit Ethernet driver
author:         Realtek and the Linux r8169 crew <netdev@vger.kernel.org>
srcversion:     70D3D4CA385646D8F58D8FC
alias:          pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias:          pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias:          pci:v000016ECd00000116sv*sd*bc*sc*i*
alias:          pci:v00001259d0000C107sv*sd*bc*sc*i*
alias:          pci:v00001186d00004302sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008167sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008129sv*sd*bc*sc*i*
depends:        mii
intree:         Y
vermagic:       3.2.0-4-amd64 SMP mod_unload modversions
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)
[свернуть]
Ну и конечно же, карточки разные.

ihammers

Открыть содержимое (спойлер)
mrgoodvin, исправте цитирование в вашем сообщении, так как не меня цитируете.
[свернуть]

Какой драйвер использует система:
~$ lspci -v | grep -i -A 9 ethernet
Установлен ли isc-dhcp-client? Что выдаёт следующая команда:
~# dhclient eth0
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Juriy

В /etc/network/interfaces выставлено на получение Ip от роутера.
dhclient eth0 ни чего не выдает.
Остальные команды на скрине.

Так сейчас выглядит /etc/network/interfaces

А так ifconfig -a

Цитата: mrgoodvin от 08 мая 2015, 19:07:19
Возможно, проблема в драйверах тогда.
Я тоже всё больше склоняюсь к этому мнению. Таких граблей с сетью не припомню. Вроде всегда спокойно данные ввёл, рестарт сети и поехали. А тут прям засада.

mrgoodvin

#10
allow-hotplug eth0 нужно разкомментировать. А что паказывает ~$ modinfo r8169

Сообщение объединено: 08 мая 2015, 22:36:06

И проверь установлен ли пакет isc-dhcp-client, так как ~# dhclient eth0 ничего не выдал.
dpkg --list 'isc-dhcp-client'


Juriy

Цитата: mrgoodvin от 08 мая 2015, 22:07:16
allow-hotplug eth0 нужно разкомментировать.
Странно может по запарке его закоментировал.
modinfo r8169 и dpkg --list 'isc-dhcp-client'
Script started on Сб 09 май 2015 02:24:04
root@my-pk:~# modinfo r8169
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/ethernet/realtek/r8169.ko
firmware:       rtl_nic/rtl8168g-3.fw
firmware:       rtl_nic/rtl8168g-2.fw
firmware:       rtl_nic/rtl8106e-2.fw
firmware:       rtl_nic/rtl8106e-1.fw
firmware:       rtl_nic/rtl8411-2.fw
firmware:       rtl_nic/rtl8411-1.fw
firmware:       rtl_nic/rtl8402-1.fw
firmware:       rtl_nic/rtl8168f-2.fw
firmware:       rtl_nic/rtl8168f-1.fw
firmware:       rtl_nic/rtl8105e-1.fw
firmware:       rtl_nic/rtl8168e-3.fw
firmware:       rtl_nic/rtl8168e-2.fw
firmware:       rtl_nic/rtl8168e-1.fw
firmware:       rtl_nic/rtl8168d-2.fw
firmware:       rtl_nic/rtl8168d-1.fw
version:        2.3LK-NAPI
license:        GPL
description:    RealTek RTL-8169 Gigabit Ethernet driver
author:         Realtek and the Linux r8169 crew <netdev@vger.kernel.org>
srcversion:     D0E1934D763B6927E0CB4A4
alias:          pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias:          pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias:          pci:v000016ECd00000116sv*sd*bc*sc*i*
alias:          pci:v00001259d0000C107sv*sd*bc*sc*i*
alias:          pci:v00001186d00004302sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008167sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008129sv*sd*bc*sc*i*
depends:        mii
intree:         Y
vermagic:       3.16.0-4-amd64 SMP mod_unload modversions
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)
root@my-pk:~# dpkg --list 'isc-dhcp-client'
Желаемый=неизвестно[u]/установить[i]/удалить[r]/вычистить[p]/зафиксировать[h]
| Состояние=не[n]/установлен[i]/настроен[c]/распакован[U]/частично настроен[F]/
            частично установлен[H]/trig-aWait/Trig-pend
|/ Ошибка?=(нет)/требуется переустановка[R] (верхний регистр
в полях состояния и ошибки указывает на ненормальную ситуацию)
||/ Имя            Версия       Архитектура  Описание
+++-==============-============-============-=================================
ii  isc-dhcp-clien 4.3.1-6      amd64        DHCP client for automatically obt
root@my-pk:~# exit
exit

Script done on Сб 09 май 2015 02:25:14
[свернуть]

mrgoodvin

Не знаю что-и думать,так как карточка работала в DE исходя из ваших сообщений. Как варианты, попробовать драйвера вот эти:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2,
или же установить DE.

ihammers

Проверьте не установился ли NW:
~$ dpkg -l \*network-manage\*

Если да, то его нужно отключить, или использовать только его для настройки сети.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

315th

#14
Цитата: Juriy от 08 мая 2015, 15:40:02видно что сетевая вроде поднята.
Но не работает. Нет RUNNING на интерфейсе.
Цитата: mrgoodvin от 09 мая 2015, 13:45:30Как варианты, попробовать драйвера вот эти:
Давно уже есть dkms-пакет c этими драйверами. Ничего руками собирать не надо.
Цитата: mrgoodvin от 09 мая 2015, 13:45:30или же установить DE.
И что измениться? Отвечу сразу, что НИЧЕГО.
Ссылко для тех кто не пользуется поиском http://ftp.de.debian.org/debian/pool/main/r/r8168/

Сообщение объединено: 09 мая 2015, 21:30:31

Цитата: ihammers от 09 мая 2015, 18:37:59Проверьте не установился ли NW:
А это тут вообще не при чём.
Debian GNU/Linux 7.11 (wheezy) - CLI
ICH7; D525MV; r8169; Linux 4.14.32-atomd525mv-imq-ja1 (i686); Intel Atom D525 1.8 GHz