Тачпад и клавиатура на этапе аутентификации

Автор 44HZD, 01 июля 2015, 14:32:00

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

44HZD

Приветствую сообщество. Проблема у меня бородатая. По гуглу аж с 2006 года месаги есть о похожих траблах. Нативная клавиатура и тачпад не работают при загрузке (asus 1225b) на этапе ввода логина/пароля. Кроме деба на машине были  убунта, минт, сьюс. На них наблюдалось то же самое. Возникает не при каждой загрузке, но примерно в 4 из 5.
Грешил и на acpi, и на само железо, но как оказалось, предложенные в гугле решения вроде использования hal'a или добавления в resume.d фикс скрипта
echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind

не помогают ни разу...
Может кто нибудь таки решил по тихому проблему и может поделиться решением?
Установлен 8.1

ihammers

С такой проблемой не сталкивался, но попытайтесь поставить и вывести вывод следующих команд:
~# apt-get install firmware-linux-free firmware-linux-nonfree
~# lspci
~# grep -i error /var/log/dmesg
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

ogost

сталкивался, в моём случае это был глючный контроллер usb на мамке, решалось заменой встроенного контроллера на pci-шный. замечу, что это может быть и не ваш случай (у вас то ноут).
есть ещё подозрения в сторону ДМ, или иксов, попробуйте загрузится в recovery mode несколько раз, посмотрите поведение, будет ли там работать.

44HZD

Цитата: ihammers от 02 июля 2015, 05:25:05
С такой проблемой не сталкивался, но попытайтесь поставить и вывести вывод следующих команд:
~# apt-get install firmware-linux-free firmware-linux-nonfree
~# lspci
~# grep -i error /var/log/dmesg

А как dmesg поможет? Он же очищается при новой загрузке. А раз нет доступа к клавиатуре в таких случаях, до него я тоже не доберусь. Я конечно грепнул на всякий случай, но ошибок там нет.

Цитата: ogost от 02 июля 2015, 07:23:12
сталкивался, в моём случае это был глючный контроллер usb на мамке, решалось заменой встроенного контроллера на pci-шный. замечу, что это может быть и не ваш случай (у вас то ноут).
есть ещё подозрения в сторону ДМ, или иксов, попробуйте загрузится в recovery mode несколько раз, посмотрите поведение, будет ли там работать.
В РМоде грузил еще когда первый раз столкнулся с проблемой, но, увы, там тоже отказывает. По поводу ДМ даже не знаю, куда там рыть, а с иксами все вроде нормально

ihammers

Цитата: 44HZD от 02 июля 2015, 23:15:00А как dmesg поможет? Он же очищается при новой загрузке. А раз нет доступа к клавиатуре в таких случаях, до него я тоже не доберусь. Я конечно грепнул на всякий случай, но ошибок там нет.
Эмм, а старые записи для этого на что? /var/log/dmesg.0 и /var/log/dmesg.X.gz (где X число от 1 и выше).
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

44HZD

Цитата: ihammers от 03 июля 2015, 05:10:04
Эмм, а старые записи для этого на что? /var/log/dmesg.0 и /var/log/dmesg.X.gz (где X число от 1 и выше).
Сказывается незнание системы :)


dmesg:[   11.636930] b43: probe of bcma0:0 failed with error -524
dmesg:[   14.046170] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.0:[   11.141035] b43: probe of bcma0:0 failed with error -524
dmesg.0:[   11.588945] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.1:[    8.173792] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.1:[    9.912807] b43: probe of bcma0:0 failed with error -524
dmesg.2:[   11.012230] b43: probe of bcma0:0 failed with error -524
dmesg.2:[   11.693206] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.3:[   12.722213] b43: probe of bcma0:0 failed with error -524
dmesg.3:[   13.423658] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.4:[   10.382155] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
dmesg.4:[   11.700622] b43: probe of bcma0:0 failed with error -524

Ошибка только с фирмой для вафли, но она работает правильно. В остальном чисто.

ihammers

Цитата: 44HZD от 03 июля 2015, 14:39:27Ошибка только с фирмой для вафли, но она работает правильно. В остальном чисто.
Печально, что в данном месте ничего нету. Такой вопрос в настройках биоса есть ли какие-нибудь пункты отвечающие за usb? Возможно какой-то из пунктов в настройках приводит к данному результату.

Есть подозрение, что данные устройства просто не инициализируются на этапе загрузки. Возможно стоит поискать информацию о задержки загрузки на момент инициализации.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

44HZD

#7
Цитата: ihammers от 04 июля 2015, 18:04:30
Цитата: 44HZD от 03 июля 2015, 14:39:27Ошибка только с фирмой для вафли, но она работает правильно. В остальном чисто.
Печально, что в данном месте ничего нету. Такой вопрос в настройках биоса есть ли какие-нибудь пункты отвечающие за usb? Возможно какой-то из пунктов в настройках приводит к данному результату.

Есть подозрение, что данные устройства просто не инициализируются на этапе загрузки. Возможно стоит поискать информацию о задержки загрузки на момент инициализации.
Биос я смотрел, там минимум настроек и ничего относящегося к устройствам ввода нет. Пока пытался решить как-то, тут целая история вышла. Вчера начисто пропал звук. При этом пульсаудио был давно выпилен. Я чекнул конечно конфиги альсы на предмет мута от рута, но ничего не нашел. Может быть поспешил, но тем не менее решил переустановить всю алсу. В итоге нет-менеджер тоже удалился (как???xD). Благо есть еще комп. Скачал пакеты со всеми зависимостями, поставил менеджера, подключил-все ок. Перезагрузил и... клава и тачпад с концами перестали работать. Даже в режиме рекавери. Работают только в биос/граб или на лайв сиди. Пришлось в общем все переустанавливать.