Автор Тема: Зависимости (apt-get)  (Прочитано 1407 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gen

Зависимости (apt-get)
« : 16 Августа 2015, 16:32:30 »
Стоит stretch/KDE5. После удаления dragonplayer(так как все равно не работает, и при вызове крашится постоянно), apt-get autoremove предлагает удалить чуть ли не все основные пакеты KDE5. Не хотелось бы однажды на автомате autoremove сделать, поэтому интересует как с этим бороться?
 

Онлайн endru

Re: Зависимости (apt-get)
« Ответ #1 : 17 Августа 2015, 06:16:20 »
может стоит показать вывод команды?

Оффлайн Андрей

Re: Зависимости (apt-get)
« Ответ #2 : 17 Августа 2015, 18:41:13 »
У меня похожая проблема.После sudo apt-get upgrade показывает что нужно снести много пакетов,что делать?

Cообщение объединено 17 Августа 2015, 19:03:03
Вот мой выхлоп:Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  alacarte argyll argyll-ref baobab bijiben bluez-obexd caribou caribou-antler
  cheese dleyna-renderer espeak-data file-roller fonts-cantarell gedit
  gedit-common gedit-plugins gir1.2-champlain-0.12 gir1.2-gdata-0.0
  gir1.2-geocodeglib-1.0 gir1.2-git2-glib-1.0 gir1.2-gmenu-3.0 gir1.2-goa-1.0
  gir1.2-grilo-0.2 gir1.2-gtkchamplain-0.12 gir1.2-gtop-2.0
  gir1.2-gucharmap-2.90 gir1.2-mediaart-1.0 gir1.2-rb-3.0 gir1.2-rest-0.7
  gir1.2-secret-1 gir1.2-tracker-1.0 gir1.2-vte-2.91 gir1.2-wnck-3.0
  gir1.2-zeitgeist-2.0 gir1.2-zpj-0.0 gnome-calculator gnome-clocks
  gnome-color-manager gnome-disk-utility gnome-documents gnome-font-viewer
  gnome-getting-started-docs gnome-media gnome-menus gnome-music gnome-nettool
  gnome-online-miners gnome-photos gnome-screenshot
  gnome-shell-extension-weather gnome-shell-extensions gnome-sound-recorder
  gnome-system-log gnome-system-monitor gnome-video-effects
  gnustep-base-common gnustep-base-runtime gnustep-common goobox
  gstreamer0.10-nice gstreamer0.10-plugins-bad gstreamer1.0-nice gtk2-engines
  gucharmap gvfs-fuse hyphen-en-us iputils-tracepath libapache2-mod-dnssd
  libatk-adaptor libavahi-ui-gtk3-0 libbrlapi0.6 libcaribou-gtk-module
  libcaribou-gtk3-module libcdaudio1 libcoverart0 libdirac-encoder0 libdiscid0
  libdotconf0 libespeak1 libfarstream-0.1-0 libfarstream-0.2-2 libgadu3
  libgail-common libgfbgraph-0.2-0 libgit2-21 libgit2-glib-1.0-0
  libgnome-menu-3-0 libgnustep-base1.24 libgstreamer-plugins-bad0.10-0
  libgtk-vnc-2.0-0 libgucharmap-2-90-7 libgupnp-igd-1.0-4 libgvnc-1.0-0
  libidl0 libjansson4 liblinear1 liblouis-data liblouis2 libmeanwhile1
  libminiupnpc10 libnatpmp1 libnice10 libobjc4 liborbit2 libprotobuf-c1
  librhythmbox-core8 libslv2-9 libsofia-sip-ua-glib3 libsofia-sip-ua0
  libsonic0 libspeechd2 libspice-client-glib-2.0-8 libspice-client-gtk-3.0-4
  libtelepathy-farstream3 libusbredirhost1 libusbredirparser1 libwnck-3-0
  libwnck-3-common libwnck-common libwnck22 libxres1 libzapojit-0.0-0
  libzephyr4 minissdpd nautilus-sendto ndiff nmap python-gconf python-gnome2
  python-pyatspi python-pyorbit python-wnck python3-brlapi python3-cairo
  python3-dbus python3-gi python3-gi-cairo python3-louis python3-mako
  python3-markupsafe python3-pyatspi python3-speechd python3-xdg qt-at-spi
  seahorse simple-scan speech-dispatcher speech-dispatcher-audio-plugins
  spice-client-glib-usb-acl-helper telepathy-gabble telepathy-idle
  telepathy-logger telepathy-rakia telepathy-salut transmission-common
  transmission-gtk unar unoconv vinagre vino xbrlapi xdg-user-dirs-gtk
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
« Последнее редактирование: 17 Августа 2015, 19:03:03 от Андрей »
 

Оффлайн ferum

Re: Зависимости (apt-get)
« Ответ #3 : 17 Августа 2015, 19:53:21 »
Покурить, на данный момент зависимости сломаны , рабочий момент так сказать.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн vovan--vovan

Re: Зависимости (apt-get)
« Ответ #4 : 17 Августа 2015, 20:00:56 »
Да-да вот однажды и я попал в этот рабочий момент, взял и сделал что было предложено системой и все, кирдык. Полная переустановка.
Не даст поколебаться Он ноге твоей, и не воздремлет хранящий тебя...
 

Оффлайн Андрей

Re: Зависимости (apt-get)
« Ответ #5 : 18 Августа 2015, 07:09:25 »
Поработал с aptitude,вроде всё исправил.Оставил реально не нужные пакеты,которые я потом удалил. :)
 

Оффлайн gen

Re: Зависимости (apt-get)
« Ответ #6 : 20 Августа 2015, 13:19:15 »
Проблема в итоге решилась осознанием, что dragonplayer входит в пакет kdemultimedia, также почему-то были притянуты зависимости от system-config-printer. Переустановка вручную данных пакетов помогла. Хотя так и не осознал связь между dragonplayer и system-config-printer, но да ладно - apt-get виднее.
 

Теги:
     

    [Решено] Зависимости, проблемы в aptitude

    Автор Vic

    Ответов: 4
    Просмотров: 2903
    Последний ответ 14 Февраля 2014, 00:00:35
    от Vic
    gbrainy: маленькая программка, большие зависимости

    Автор Листик

    Ответов: 3
    Просмотров: 837
    Последний ответ 28 Мая 2018, 10:43:49
    от endru
    Убрать зависимости X сервера

    Автор xbsd

    Ответов: 5
    Просмотров: 2206
    Последний ответ 16 Августа 2012, 16:40:36
    от Malaheenee
    нарушенные зависимости

    Автор doublemint

    Ответов: 14
    Просмотров: 2059
    Последний ответ 23 Апреля 2016, 22:23:28
    от doublemint
    Поломанные зависимости пакетов

    Автор Sergi

    Ответов: 8
    Просмотров: 1415
    Последний ответ 29 Августа 2019, 11:30:25
    от Sergi