Неверная информация о версии Хорга

Автор safocl, 14 сентября 2015, 06:37:10

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

safocl

Установил Хорг 1.17.2 , в терминале версию пишет нормально...
но в других приложениях в том числе в нвидиа хсервер сеттингс пишет, что 1.15, тоесть старая...
в логе хорга тоже указывает старую версию...

так и должно быть? или я что то не доустановил?

ihammers

Как производили установку? Вывод следующих команд под теги:
~$ dpkg -l xorg\* | grep ^ii
~$ dpkg -l xserver\* | grep ^ii
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

neon1ks

В голову пришла идея, как можно модифицировать команды:
dpkg -l xserver\* | grep ^ii | colrm 120
dpkg -l xorg\*    | grep ^ii | colrm 120

Чтобы строки вывода занимали по одной строчке в терминале, развернутого на весь экран.

safocl

#3
Цитата: ihammers от 15 сентября 2015, 06:06:15Как производили установку? Вывод следующих команд под теги:


~ $ dpkg -l xorg\*    | grep ^ii | colrm 120
ii  xorg                                                        1:7.7+1ubuntu8.1                                    amd
ii  xorg-dev                                                    1:7.7+1ubuntu8.1                                    all
ii  xorg-docs-core                                              1:1.7-1                                             all
ii  xorg-sgml-doctools                                          1:1.11-1                                            all



~ $ dpkg -l xserver\* | grep ^ii | colrm 120
ii  xserver-common                                              2:1.15.1-0ubuntu2.7                                 all
ii  xserver-xorg                                                1:7.7+1ubuntu8.1                                    amd
ii  xserver-xorg-core                                           2:1.15.1-0ubuntu2.7                                 amd
ii  xserver-xorg-dev                                            2:1.15.1-0ubuntu2.7                                 amd
ii  xserver-xorg-input-all                                      1:7.7+1ubuntu8.1                                    amd
ii  xserver-xorg-input-evdev                                    1:2.8.2-1ubuntu2                                    amd
ii  xserver-xorg-input-mouse                                    1:1.9.0-1build1                                     amd
ii  xserver-xorg-input-synaptics                                1.7.4-0ubuntu1                                      amd
ii  xserver-xorg-input-vmmouse                                  1:13.0.0-1build1                                    amd
ii  xserver-xorg-input-wacom                                    1:0.23.0-0ubuntu2                                   amd
ii  xserver-xorg-video-ati                                      1:7.3.0-1ubuntu3.1                                  amd
ii  xserver-xorg-video-cirrus                                   1:1.5.2-1build1                                     amd
ii  xserver-xorg-video-fbdev                                    1:0.4.4-1build1                                     amd
ii  xserver-xorg-video-glamoregl                                0.6.0-0ubuntu4                                      amd
ii  xserver-xorg-video-intel                                    2:2.99.910-0ubuntu1.6                               amd
ii  xserver-xorg-video-mach64                                   6.9.4-1build1                                       amd
ii  xserver-xorg-video-mga                                      1:1.6.3-1build1                                     amd
ii  xserver-xorg-video-modesetting                              0.8.1-1build1                                       amd
ii  xserver-xorg-video-neomagic                                 1:1.2.8-1build1                                     amd
ii  xserver-xorg-video-openchrome                               1:0.3.3-1build1                                     amd
ii  xserver-xorg-video-qxl                                      0.1.1-0ubuntu3                                      amd
ii  xserver-xorg-video-r128                                     6.9.2-1build1                                       amd
ii  xserver-xorg-video-radeon                                   1:7.3.0-1ubuntu3.1                                  amd
ii  xserver-xorg-video-s3                                       1:0.6.5-0ubuntu4                                    amd
ii  xserver-xorg-video-savage                                   1:2.3.7-2ubuntu2                                    amd
ii  xserver-xorg-video-siliconmotion                            1:1.7.7-2build1                                     amd
ii  xserver-xorg-video-sis                                      1:0.10.7-0ubuntu6                                   amd
ii  xserver-xorg-video-sisusb                                   1:0.9.6-2build1                                     amd
ii  xserver-xorg-video-tdfx                                     1:1.4.5-1build1                                     amd
ii  xserver-xorg-video-trident                                  1:1.3.6-0ubuntu5                                    amd
ii  xserver-xorg-video-vesa                                     1:2.3.3-1build1                                     amd
ii  xserver-xorg-video-vmware                                   1:13.0.2-2ubuntu1                                   amd


Cообщение объединено 15 сентября 2015, 17:16:30

устанавливаю из исходников с официального сайта http://www.x.org/

ihammers

Цитата: safocl от 15 сентября 2015, 17:13:42устанавливаю из исходников с официального сайта http://www.x.org/
Меня интересует как, то есть последовательность ваших действий, а не где был получин исходный код. Возможно вы пропустили какую-нибудь последовательность действий.

PS: Последовательность действий под спойлер.

И да, у нас всё-таки форум по Debian:
Цитата: safocl от 15 сентября 2015, 17:13:42ii  xserver-common                                              2:1.15.1-0ubuntu2.7                                 all
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

safocl

ну ёпрст, убунту основана на дебиан, ну и почти все одинаково, уж то про что я спрашиваю точно одинаково...


последовательность действий:
-скачал архив
-прочитал файл INSTALL
-выполнил  ./config
-выполнил make
-выполнил make install

P.S. долго не мог понять почему не компилились исходники... не  мог найти нужную библиотеку, но в итоге подсказали чо надо установить xorg-dev и к нему зависимости в виде x11proto-*-dev
П.П.С не нашел спойлер в кнопках редактора сообщений

neon1ks

#6
safocl,
Да, Ubuntu основана на Debian, но все равно есть различия. Так у Ubuntu (Mint) есть launchpad.net .


  • выполнение этих действий может привести к печальным последствиям
    Не проще было подключить репозиторий ppa:xorg-edgers/ppa и установить xorg оттуда ?
    [свернуть]
  • Так как Debain пакетный дистрибутив (как и Ubuntu, как и Mint), то установив программу командой make install , вы вызвали у себя в системе путаницу. Сейчас у вас одновременно стоят xorg 1.15 по пути /usr/bin и xorg 1.17 по пути /usr/local/bin (правда могу ошибаться...).
  • Продолжение 2 пункта: вместо команды make install , например, лучше выполнить - sudo checkinstall -D --install=yes .
  • И наконец, если вы хотите компилировать пакеты из исходников правильней будет освоить devscripts, dh-make и dpkg-buldpackage.

У спойлера значок радиации.

Malaheenee

Цитата: neon1ks от 16 сентября 2015, 11:37:54Не проще было подключить репозиторий ppa:xorg-edgers/ppa и установить xorg оттуда ?
За такую строку раньше банили. Сейчас предупреждения выносят.
Все мы где-то, когда-то и в чем-то были новичками.

safocl

#8
Открыть содержимое (спойлер)
Цитата: neon1ks от 16 сентября 2015, 11:37:54Да, Ubuntu основана на Debian, но все равно есть различия. Так у Ubuntu (Mint) есть launchpad.net .
Не проще было подключить репозиторий ppa:xorg-edgers/ppa и установить xorg оттуда ?
Так как Debain пакетный дистрибутив (как и Ubuntu, как и Mint), то установив программу командой make install , вы вызвали у себя в системе путаницу. Сейчас у вас одновременно стоят xorg 1.15 по пути /usr/bin и xorg 1.17 по пути /usr/local/bin (правда могу ошибаться...).
Продолжение 2 пункта: вместо команды make install , например, лучше выполнить - sudo checkinstall -D --install=yes .
И наконец, если вы хотите компилировать пакеты из исходников правильней будет освоить devscripts, dh-make и dpkg-buldpackage.
[свернуть]

да в обоих папках был установлен хорг... спс за подсказку, но "checkinstall -D --install=yes"  пишет неверная команда.
пробую установить куда следует в /usr/ такой ведь надо префикс указать?

Cообщение объединено 17 сентября 2015, 00:09:01

попробывал установить в нужную папку.... /usr/ а не /usr/locale, иксы слетели совсем...
видно из за того, что некоторые файлы не заменились на новые..
удалилсстарые родные иксы, поставил новые, но ни клава ни мышка не работают))))
установил xf86-input-mouse-1.3.0.tar.bz2 и xf86-input-keyboard-1.3.1.tar.bz2  из исходников, - эффект тот же

Cообщение объединено 17 сентября 2015, 00:30:31

а после установки снова стандартных иксов при вводе пароля снова перекидывает на ввод пароля


Cообщение объединено 17 сентября 2015, 02:00:26

о снова отвечу сам на свою проблему...
немного пошаманив, решил запустить иксы командой startx изс консоли....
в итоге выдало, что невозможно запустить циннамон.... установил циннамон и все заработало...
при этом до этого момента устанавливал другие окружения и никак... блин

Cообщение объединено 17 сентября 2015, 02:21:59

раз уж такая пьянка, подскажите как мне нормально поставить новый хорг?
в репозитории нету....
с исходников как?
что нужно для нормальной работы сразу сделать?
ниодной статьи не нашел, что бы расказано было что нужно для полноценного функционала собранного хорг