debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: нет звука  (Прочитано 593 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн серго

  • Topic Author
  • Сообщений: 10
нет звука
« : 16 Февраль 2017, 08:51:25 »
debian8 нет звука. как заставить петь intel ch6 iec958 playback ac97...
 

Оффлайн VKH

  • Сообщений: 137
Re: нет звука
« Ответ #1 : 16 Февраль 2017, 11:25:08 »
lspci | grep audio или lspci | grep Audio ?
 

Оффлайн yoric

  • Сообщений: 559
  • gentoo
  • Jabber: yoric@jabber.ru
Re: нет звука
« Ответ #2 : 16 Февраль 2017, 11:52:42 »
lspci | grep -i audio :)
 

Оффлайн серго

  • Topic Author
  • Сообщений: 10
Re: нет звука
« Ответ #3 : 16 Февраль 2017, 13:35:31 »
sergo@sergo:~$ lspci | grep audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
sergo@sergo:~$ lspci | grep -i audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
sergo@sergo:~$
 

Оффлайн yoric

  • Сообщений: 559
  • gentoo
  • Jabber: yoric@jabber.ru
Re: нет звука
« Ответ #4 : 16 Февраль 2017, 13:46:09 »
Теперь lsmod|grep sndА вообще попробуйте запустить alsamixer и подвигать ползунки (помощь там по F1).
 

Оффлайн серго

  • Topic Author
  • Сообщений: 10
Re: нет звука
« Ответ #5 : 16 Февраль 2017, 16:02:04 »
а ещё варианты есть? звука нет.
 

Оффлайн VKH

  • Сообщений: 137
Re: нет звука
« Ответ #6 : 16 Февраль 2017, 16:17:19 »
pulseaudioустановить пакеты firmware-linux-free и firmware-linux-nonfree, если не установлены.
« Последнее редактирование: 16 Февраль 2017, 16:25:09 от VKH »
 

Оффлайн amd_amd

  • Сообщений: 270
  • jessie jwm & stretch jwm
Re: нет звука
« Ответ #7 : 16 Февраль 2017, 16:50:56 »
если установили алсу - надо ее инициировать # alsactl init - без этого звука от алсы недождешься и уже после этого двигать ползунки в  alsamixer
 

Оффлайн ogost

  • Сообщений: 2731
  • Linux Registered User #547151
Re: нет звука
« Ответ #8 : 16 Февраль 2017, 17:19:19 »
Пользуемся тегами!

Оффлайн yoric

  • Сообщений: 559
  • gentoo
  • Jabber: yoric@jabber.ru
Re: нет звука
« Ответ #9 : 16 Февраль 2017, 19:32:26 »
а ещё варианты есть? звука нет.
Вариантов куча, сначала предложенные освойте.

ее инициировать # alsactl init - без этого звука от алсы недождешься
У меня как-то всегда без этого заводилась.
 

Оффлайн amd_amd

  • Сообщений: 270
  • jessie jwm & stretch jwm
Re: нет звука
« Ответ #10 : 16 Февраль 2017, 19:40:33 »
У меня как-то всегда без этого заводилась
потому что вы пользуетесь готовыми решениями из коробки где все запилено, попробуйте собрать систему сами из репозиториев  и тогда после установки алсы (alsa-base alsa-tools alsa-utils) без инициализации alsactl init не обойтись... не использую готовых решений - всегда собираю сам, использую только алсу - еще не было такого железа где бы она не завелась
 

Оффлайн серго

  • Topic Author
  • Сообщений: 10
Re: нет звука
« Ответ #11 : 16 Февраль 2017, 20:26:23 »
если установили алсу - надо ее инициировать # alsactl init - без этого звука от алсы недождешься и уже после этого двигать ползунки в  alsamixer
вот сделал... root@sergo:/home/sergo# alsactl init
No protocol specified
xcb_connection_has_error() returned true
Found hardware: "ICH4" "Realtek ALC250 rev 2" "AC97a:414c4752" "0x1179" "0xff00"
Hardware is initialized using a generic method

только перед этим поставил audacious и указал ему куда отправлять звук. Он поёт. В браузере, например, звука нет

Cообщение объединено 16 Февраль 2017, 20:31:41
потому что вы пользуетесь готовыми решениями из коробки где все запилено, попробуйте собрать систему сами из репозиториев  и тогда после установки алсы (alsa-base alsa-tools alsa-utils) без инициализации alsactl init не обойтись... не использую готовых решений - всегда собираю сам
Согласен!!! Вот я и хочу научиться
« Последнее редактирование: 16 Февраль 2017, 20:31:41 от серго »
 

Оффлайн amd_amd

  • Сообщений: 270
  • jessie jwm & stretch jwm
Re: нет звука
« Ответ #12 : 16 Февраль 2017, 21:15:30 »
В браузере, например, звука нет
в браузере и не должно его быть, звук в flashplugin или каком стороннем прикрученном проигрывателе, подвигайте ползунки - врубите все до красного, какой у вас браузер? в флеш играх звук есть? alsa-base alsa-tools alsa-utils установлено?
Вот я и хочу научиться
пример: https://sites.google.com/site/amdamdsoft/Home/debian-jwm-full  https://sites.google.com/site/amdamdsoft/Home/dedian-jwm
« Последнее редактирование: 16 Февраль 2017, 21:17:17 от amd_amd »
 

Оффлайн серго

  • Topic Author
  • Сообщений: 10
Re: нет звука
« Ответ #13 : 16 Февраль 2017, 23:19:40 »
какие полезные ссылки!!!!!!!!!!! работает всё!!!! (стыдно быть балбесом...)
спасибо большое!!!
 

Теги: