debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Установка свежих версий Libreoffice и Mozilla из репозитория  (Прочитано 44070 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nik.ilim

  • Пользователь
  • *
  • Сообщений: 33
aptitude install -t wheezy-backports libreoffice


Спасибо. Всё нормально установилось
« Последнее редактирование: 02 Январь 2014, 16:54:26 от nik.ilim »
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
Подскажите кто как борется когда libreoffice искажает документы созданные в   MS Office, при наличии всяких колонок и форматирований , отрывая такой документ в либре полная каша ?  пример документа из сбербанка http://yadi.sk/d/8e7SA0rKGRaLw

видео  https://www.youtube.com/watch?feature=player_detailpage&v=zo16E-YvuiU
« Последнее редактирование: 21 Январь 2014, 10:43:26 от leomuz »
 

Оффлайн SeHELLioN

  • Старожил
  • ****
  • Сообщений: 910
виртуалку с офисом обычно для таких целей использую
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
На видео как раз этот процесс и запечатлен, может уже как то побороли это, а то порой так и хочется взять компутре и выкинуть в окно.

Сообщение объединено: 21 Январь 2014, 13:47:47
aptitude install -t wheezy-backports libreoffice
что то у меня вообще все пропало, и старая версия  >:( как поставить то поновее офис?
« Последнее редактирование: 21 Январь 2014, 13:47:47 от leomuz »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
1. Вводим
# aptitude versions libreofficeи смотрим на вывод касательно метапакета libreoffice:
Цитировать
Пакет libreoffice:
p   1:3.5.4+dfsg2-0+deb7u2                                           stable                                       500
i   1:4.1.4-2~bpo70+1                                                wheezy-backports                             100
2. Как понятно из вывода, в wheezy-backports на данный момент лежит версия 1:4.1.4-2~bpo70+1. Её и ставим:
# aptitude install libreoffice=1:4.1.4-2~bpo70+1
PS: можно использовать # aptitude show -v вместо aptitude versions. Вывод будет таков:
Spoiler: ShowHide
Цитировать
aptitude show -v libreoffice
Пакет: libreoffice                               
Состояние: установлен
Автоматически установлен: нет
Версия: 1:4.1.4-2~bpo70+1
Приоритет: необязательный
Раздел: metapackages
Сопровождающий: Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>
Архитектура: i386
Размер в распакованном виде: 121 k
Размер в сжатом виде: 63,6 k
Имя файла: pool/main/libr/libreoffice/libreoffice_4.1.4-2~bpo70+1_i386.deb
MD5sum: e7cca6f9b28218a19090a816d4436a48
Архив: wheezy-backports, now
Зависимости: fonts-sil-gentium-basic, libreoffice-base, libreoffice-calc, libreoffice-core (= 1:4.1.4-2~bpo70+1),
                        libreoffice-draw, libreoffice-impress, libreoffice-math, libreoffice-report-builder-bin,
                        libreoffice-writer, ttf-dejavu, libreoffice-java-common (>= 1:4.1.4~), python-uno
Рекомендуются: fonts-liberation | ttf-mscorefonts-installer, libpaper-utils
Предлагаются: cups-bsd, hunspell-dictionary, hyphen-hyphenation-patterns, iceweasel | firefox | icedove | thunderbird
                          | iceape-browser | mozilla-browser, imagemagick | graphicsmagick-imagemagick-compat, libgl1,
                          libreoffice-gnome | libreoffice-kde, libreoffice-grammarcheck, libreoffice-help-4.1,
                          libreoffice-l10n-4.1, libsane, libxrender1, myspell-dictionary, mythes-thesaurus,
                          openclipart-libreoffice, pstoedit, unixodbc, gstreamer0.10-plugins-base,
                          gstreamer0.10-plugins-good, gstreamer0.10-plugins-ugly, gstreamer0.10-plugins-bad,
                          gstreamer0.10-ffmpeg, default-jre | gcj-jre | openjdk-7-jre | openjdk-6-jre | sun-java5-jre
                          | sun-java6-jre | java5-runtime | jre, libreoffice-officebean
Описание: office productivity suite (metapackage)
 LibreOffice is a full-featured office productivity suite that provides a near drop-in replacement for Microsoft(R)
 Office.
 
 This metapackage installs all components of libreoffice:
 * libreoffice-writer: Word processor
 * libreoffice-calc: Spreadsheet
 * libreoffice-impress: Presentation
 * libreoffice-draw: Drawing
 * libreoffice-base: Database
 * libreoffice-math: Equation editor
   
 You can extend the functionality of LibreOffice by installing these packages:
 * hunspell-*/myspell-*: Hunspell/Myspell dictionaries for use with LibreOffice
 * libreoffice-l10n-*: UI interface translation
 * libreoffice-help-*: User help
 * mythes-*: Thesauri for the use with LibreOffice
 * hyphen-*: Hyphenation patterns for LibreOffice
 * libreoffice-gtk: Gtk UI Plugin, GNOME File Picker support, QuickStarter for GNOMEs notification are
 * libreoffice-gnome: GIO, GConf backend
 * libreoffice-kde: KDE UI Plugin and KDE File Picker support
 * unixodbc: ODBC database support
 * cups-bsd: Allows LibreOffice to detect your CUPS printer queues automatically
 * libsane: Use your sane-supported scanner with LibreOffice
 * libxrender1: Speed up display by using Xrender library
 * libgl1: OpenGL support
 * openclipart-libreoffice: Open Clip Art Gallery with LibreOffice index files
 * iceweasel | firefox | icedove | thunderbird | iceape-browser | mozilla-browser: Mozilla profile with Certificates
   needed for XML Security...
 * openjdk-6-jre | gcj-jre | java5-runtime: Java Runtime Environment for use with LibreOffice
 * pstoedit / imagemagick: helper tools for EPS thumbnails
 * gstreamer0.10-plugins-*: GStreamer plugins for use with LibreOffices media backend
 * libpaper-utils: papersize detection support via paperconf
 * bluez: Bluetooth support for Impress (slideshow remote control
Сайт: http://www.libreoffice.org

Пакет: libreoffice
Состояние: не установлен
Автоматически установлен: нет
Версия: 1:3.5.4+dfsg2-0+deb7u2
Приоритет: необязательный
Раздел: editors
Сопровождающий: Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>
Архитектура: i386
Размер в распакованном виде: 158 k
Размер в сжатом виде: 50,5 k
Имя файла: pool/main/libr/libreoffice/libreoffice_3.5.4+dfsg2-0+deb7u2_i386.deb
MD5sum: 3b03e42f3eb6fb0cfd3e6cefdb5bfb81
Архив: stable
Зависимости: libreoffice-core (= 1:3.5.4+dfsg2-0+deb7u2), libreoffice-writer, libreoffice-calc, libreoffice-impress,
                        libreoffice-draw, libreoffice-math, libreoffice-base, libreoffice-report-builder-bin,
                        ttf-dejavu, ttf-sil-gentium-basic, libreoffice-filter-mobiledev, liblucene2-java (>= 2.3.2),
                        libreoffice-java-common (>= 1:3.5.4+dfsg2~)
Рекомендуются: ttf-liberation | ttf-mscorefonts-installer, libpaper-utils
Предлагаются: hunspell-dictionary, myspell-dictionary, libreoffice-help-3.5, libreoffice-l10n-3.5, unixodbc, cups-bsd,
                          libsane, hyphen-hyphenation-patterns, mythes-thesaurus, libreoffice-grammarcheck,
                          libxrender1, libgl1, libreoffice-gnome | libreoffice-kde, iceweasel | firefox | icedove |
                          thunderbird | iceape-browser | mozilla-browser, default-jre | gcj-jre | java-gcj-compat |
                          openjdk-6-jre | openjdk-7-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre,
                          openclipart-libreoffice, pstoedit, imagemagick | graphicsmagick-imagemagick-compat,
                          gstreamer0.10-plugins-base, gstreamer0.10-plugins-good, gstreamer0.10-plugins-ugly,
                          gstreamer0.10-plugins-bad, gstreamer0.10-ffmpeg, libldap-2.4-2,
                          libreoffice-filter-binfilter, libreoffice-officebean
Описание: office productivity suite
 LibreOffice is a full-featured office productivity suite that provides a near drop-in replacement for Microsoft(R)
 Office.
 
 This metapackage installs all components of libreoffice:
 * libreoffice-writer: Word processor
 * libreoffice-calc: Spreadsheet
 * libreoffice-impress: Presentation
 * libreoffice-draw: Drawing
 * libreoffice-base: Database
 * libreoffice-math: Equation editor
 * libreoffice-filter-mobiledev: Mobile Devices filters
   
 You can extend the functionality of LibreOffice by installing these packages:
 * hunspell-*/myspell-*: Hunspell/Myspell dictionaries for use with LibreOffice
 * libreoffice-l10n-*: UI interface translation
 * libreoffice-help-*: User help
 * mythes-*: Thesauri for the use with LibreOffice
 * hyphen-*: Hyphenation patterns for LibreOffice
 * libreoffice-gtk: Gtk UI Plugin, GNOME File Picker support, QuickStarter for GNOMEs notification are
 * libreoffice-gnome: GIO, GConf backend
 * libreoffice-kde: KDE UI Plugin and KDE File Picker support
 * unixodbc: ODBC database support
 * cups-bsd: Allows LibreOffice to detect your CUPS printer queues automatically
 * libsane: Use your sane-supported scanner with LibreOffice
 * libxrender1: Speed up display by using Xrender library
 * libgl1: OpenGL support
 * openclipart-libreoffice: Open Clip Art Gallery with LibreOffice index files
 * iceweasel | firefox | icedove | thunderbird | iceape-browser | mozilla-browser: Mozilla profile with Certificates
   needed for XML Security...
 * openjdk-6-jre | gcj-jre | java5-runtime: Java Runtime Environment for use with LibreOffice
 * pstoedit / imagemagick: helper tools for EPS thumbnails
 * gstreamer0.10-plugins-*: GStreamer plugins for use with LibreOffices media backend
 * libpaper-utils: papersize detection support via paperconf
 * libldap-2.4-2: LDAP client library; needed for LibreOffice getting its profiles from LDAP
 * libreoffice-filter-binfilter: legacy filters (e.g. StarOffice 5.2)
Сайт: http://www.libreoffice.org
« Последнее редактирование: 21 Январь 2014, 14:05:37 от Brainey »
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
Что то совсем крыша едет Brainey помогите разобраться  :)


Spoiler: ShowHide
aptitude install libreoffice=1:4.1.4-2~bpo70+1
Не удаётся найти версию «1:4.1.4-2~bpo70+1» пакета «libreoffice»
Не удаётся найти версию «1:4.1.4-2~bpo70+1» пакета «libreoffice»
Следующие НОВЫЕ пакеты будут установлены:
  libreoffice libreoffice-base{a} libreoffice-base-core{a} libreoffice-calc{a} libreoffice-core{a}
  libreoffice-draw{a} libreoffice-filter-mobiledev{a} libreoffice-impress{a} libreoffice-math{a}
  libreoffice-report-builder-bin{a} libreoffice-writer{a} python3.3-uno{a}
0 пакетов обновлено, 12 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 155 kB/49,8 MB архивов. После распаковки 190 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libreoffice-common : Конфликтует: libreoffice-filter-mobiledev но устанавливается 1:4.0.3-3.
                      Ломает: libreoffice-core (< 1:4.1~) но устанавливается 1:4.0.3-3.
 ure : Ломает: libreoffice-core (< 1:4.1.2~) но устанавливается 1:4.0.3-3.
Следующие действия разрешат зависимости:

      Сохранить для следующих пакетов их текущие версии:
1)      libreoffice [Не установлен]                     
2)      libreoffice-base [Не установлен]               
3)      libreoffice-base-core [Не установлен]           
4)      libreoffice-calc [Не установлен]               
5)      libreoffice-core [Не установлен]               
6)      libreoffice-draw [Не установлен]               
7)      libreoffice-filter-mobiledev [Не установлен]   
8)      libreoffice-impress [Не установлен]             
9)      libreoffice-math [Не установлен]               
10)     libreoffice-report-builder-bin [Не установлен] 
11)     libreoffice-writer [Не установлен]             
12)     python3.3-uno [Не установлен]                   

      Оставить следующие зависимости неразрешёнными:   
13)     libreoffice-writer рекомендует libreoffice-math


Принять данное решение? [Y/n/q/?]
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Что в sources.list?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
Прошу прощения не у компьютера, у меня не чистый debian  а LMDE  :-[



Spoiler: ShowHide
deb http://debian.lth.se/linuxmint/ debian main upstream import
deb http://debian.lth.se/lmde/latest testing main contrib non-free
deb http://debian.lth.se/lmde/latest/security testing/updates main contrib non-free
deb http://debian.lth.se/lmde/latest/multimedia testing main non-free

# Debian Backports

# deb http://packages.linuxmint.com/ debian backport


был еще вот
# Debian Backports
deb http://backports.debian.org/debian-backports wheezy-backports main contrib non-free   ------ может это не правильный ?

вот к стати попробовал добавил вновь то что выше такой результат
.............
Spoiler: ShowHide
94% [Обработка]W: Не удалось получить http://backports.debian.org/debian-backports/dists/wheezy-backports/main/binary-i386/Packages: 404  Not Found [IP: 130.89.148.14 80]
W: Не удалось получить http://backports.debian.org/debian-backports/dists/wheezy-backports/contrib/binary-i386/Packages: 404  Not Found [IP: 130.89.148.14 80]
W: Не удалось получить http://backports.debian.org/debian-backports/dists/wheezy-backports/non-free/binary-i386/Packages: 404  Not Found [IP: 130.89.148.14 80]
E: Не удалось скачать некоторые индексные файлы. Они были проигнорированы, или вместо них использовались старые.
E: Не удалось перестроить кэш пакетов


подскажите правильный репозиторий
« Последнее редактирование: 21 Январь 2014, 16:46:11 от leomuz »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
подскажите правильный репозиторий
Читайте предыдущую страницу.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
Что то не могу допетрить, еле еле вернул старую версию, пробую устанавливать пишет

aptitude install -t wheezy-backports libreoffice
Spoiler: ShowHide
Следующие пакеты будут УДАЛЕНЫ:                 
  libreoffice-filter-mobiledev{u}
Следующие пакеты будут обновлены:
  libreoffice libreoffice-common libreoffice-core{b} uno-libs3 ure
5 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 48 пакетов не обновлено.
Необходимо получить 29,6 MB/60,7 MB архивов. После распаковки 15,7 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libreoffice-impress : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-math : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-calc : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 python-uno : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-base : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-draw : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-base-core : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
 libreoffice-core : Зависит: libexttextcat0 (>= 2.2-8) но его невозможно установить.
                    Ломает: libreoffice-base (< 1:4.1.4-2~bpo70+1) но установлен 1:4.0.3-3 и удерживается.
                    Ломает: libreoffice-calc (< 1:4.1.4-2~bpo70+1) но установлен 1:4.0.3-3 и удерживается.
                    Ломает: libreoffice-draw (< 1:4.1.4-2~bpo70+1) но установлен 1:4.0.3-3 и удерживается.
                    Ломает: libreoffice-impress (< 1:4.1.4-2~bpo70+1) но установлен 1:4.0.3-3 и удерживается.
                    Ломает: libreoffice-writer (< 1:4.1.4-2~bpo70+1) но установлен 1:4.0.3-3 и удерживается.
 libreoffice-writer : Зависит: libreoffice-core (= 1:4.0.3-3) но устанавливается 1:4.1.4-2~bpo70+1.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                                       
1)      libreoffice                                                                                   
2)      libreoffice-base                                                                               
3)      libreoffice-base-core                                                                         
4)      libreoffice-calc                                                                               
5)      libreoffice-core                                                                               
6)      libreoffice-draw                                                                               
7)      libreoffice-impress                                                                           
8)      libreoffice-math                                                                               
9)      libreoffice-report-builder-bin                                                                 
10)     libreoffice-writer                                                                             
11)     python-uno                                                                                     

      Оставить следующие зависимости неразрешёнными:                                                   
12)     libreoffice-l10n-ru рекомендует libreoffice-core (> 1:4.0.3) | language-support-translations-ru
13)     libreoffice-writer рекомендует libreoffice-math                                               
14)     libreoffice-common рекомендует python-uno                                                     


Принять данное решение? [Y/n/q/?]


что тут делать?
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4539
  • memento mori
  • Jabber: qupl@jabber.ru
deb http://backports.debian.org/debian-backports wheezy-backports main contrib non-free   ------ может это не правильный ?
Этот однозначно неправильный, потому что там только для oldstable бэкпорты.


Сообщение объединено: 21 Январь 2014, 21:16:52
deb http://ftp.ru.debian.org/debian/ wheezy-backports main contrib non-free
« Последнее редактирование: 21 Январь 2014, 21:16:52 от qupl »
 

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
deb http://cdn.debian.net/debian/ wheezy-backports main contrib non-free  сменил уже на этот горе с пополам вернул старую какую то покромсаную версию,  может у меня в этом проблема
cat  /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500 ?


ps: да уж такого дерьма я даже в gentoo не встречал, ни фига не врубаюсь что делать.
pss: поставил пока напрямую из deb пакетов  :-[
« Последнее редактирование: 21 Январь 2014, 23:30:37 от leomuz »
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4539
  • memento mori
  • Jabber: qupl@jabber.ru
ps: да уж такого дерьма я даже в gentoo не встречал, ни фига не врубаюсь что делать.
Наверное не использовать мешанины из сборки форка Дебиан и Дебиан?

Оффлайн leomuz

  • Пользователь
  • *
  • Сообщений: 20
[ot]qupl вам хорошо рассуждать это ваша работа я так думаю вы и по жизни связаны с ПО, я лишь продвинутый пользователь, улавливаете разницу, ну некогда мне заниматься настройками, было время gentoo использовал пару лет, появился "форк" calculate перешел на него года 3 потом пришлось снова WS использовать в связи с рабочей необходимостью, в один прекрасный момент все упало , пришлось опять поставить debian посмотрел ну непричесаный он а самому мне некогда было доводить надо срочно работать, попался тут lmde он меня полностью устроил т.к. на сборки пакетов из сырцов в калькуляторе времени не было, бинарные я по религии не ставил никогда , да и надоел он мне, вот как то так  :)[/ot]
« Последнее редактирование: 22 Январь 2014, 21:40:16 от Malaheenee »
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4539
  • memento mori
  • Jabber: qupl@jabber.ru
leomuz, тут два пути: 1) поставить сборку и не трогать ее раз всё работает; 2) собрать из чистой системы и нужных программ конструктор.
С виду первый вариант проще и быстрее, но как только вы начинаете что-то навешивать/обновлять сразу же вылазят проблемы.
В Вашем случае , если бы это был Debian, я бы посоветовал отключить лишние репозитории и переустановить офис. А когда источников 3 и более, не берусь предположить что получится.

Русскоязычное сообщество Debian GNU/Linux



Теги:
 

[РЕШЕНО] Установка пакетов из списка

Автор SuperGeek256

Ответов: 2
Просмотров: 964
Последний ответ 14 Июль 2014, 15:37:58
от SuperGeek256
Установка debian. Модули ядра не найдены.

Автор valikst

Ответов: 3
Просмотров: 2132
Последний ответ 20 Март 2013, 09:06:06
от fry
Установка ограниченных прав на нового пользователя

Автор madwayz1337

Ответов: 3
Просмотров: 608
Последний ответ 18 Сентябрь 2016, 18:08:19
от alsoijw
Установка пакетов из testing

Автор Salder

Ответов: 6
Просмотров: 1823
Последний ответ 23 Январь 2017, 04:13:29
от ogost
Установка MySQL Workbench

Автор Fire

Ответов: 1
Просмотров: 1887
Последний ответ 23 Март 2011, 00:13:17
от Ghostdmn