debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [РЕШЕНО] Установка плееров  (Прочитано 2306 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Alecks-ei

  • Гость
[РЕШЕНО] Установка плееров
« : 10 Апрель 2011, 15:19:42 »
Как установить проигрыватели VLC и Deadbeef? На бубунту много статей про них, на дебиан не могу найти(
 

IngwarE

  • Гость
Re: Английский Cromium
« Ответ #1 : 10 Апрель 2011, 15:21:52 »
гм...
vlc есть в репозитории
про Мертвый кусок мяса не в курсе - не пользуюсь
 

Оффлайн BULATUS

  • Сообщений: 1924
Re: Английский Cromium
« Ответ #2 : 10 Апрель 2011, 15:26:25 »
оффтоп. С этого места viewtopic.php?p=4992#p4992 вырезать в другую тему...
aptitude install vlc
и все  :)
Deadbeef в репах кажется нет... но не уверен.
Если нужен аудио плейер то посмотри в сторону exaile

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Английский Cromium
« Ответ #3 : 10 Апрель 2011, 15:32:55 »
Мясо здесь есть
« Последнее редактирование: 29 Сентябрь 2011, 15:00:47 от Brainey »
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн zen1tfan

  • Сообщений: 14
Re: [РЕШЕНО] Установка плееров
« Ответ #4 : 28 Сентябрь 2011, 15:40:33 »
При попытке установить любой плеер, к примеру vlc, получается вот что:

sudo aptitude install vlc

Следующие НОВЫЕ пакеты будут установлены:       
  liba52-0.7.4{a} libass4{a} libavcodec53{ab} libavformat53{ab} libavutil51{ab} libcddb2{a} libdc1394-22{a} libdca0{a} libdirectfb-1.2-9{a} libdvdnav4{a} libdvdread4{a}
  libenca0{a} libfaac0{ab} libiso9660-7{a} libkate1{a} liblircclient0{a} libmp3lame0{ab} libmpeg2-4{a} librtmp0{a} libsdl-image1.2{a} libsdl1.2debian{a}
  libsdl1.2debian-alsa{a} libsvga1{a} libswscale2{ab} libsysfs2{a} libts-0.0-0{a} libupnp3{a} libvcdinfo0{a} libvlc5{a} libvlccore4{a} libx264-116{ab} libx86-1{a}
  libxcb-randr0{a} libxcb-shm0{a} libxcb-xv0{a} libxvidcore4{ab} tsconf{a} vlc{b} vlc-data{a} vlc-nox{ab} vlc-plugin-notify{ab} vlc-plugin-pulse{ab}
Следующие пакеты будут обновлены:
  libpostproc51{b}
1 пакетов обновлено, 42 установлено новых, 0 пакетов отмечено для удаления, и 36 пакетов не обновлено.
Необходимо получить 10,7 MB/19,8 MB архивов. После распаковки 57,1 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libswscale2: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavutil51: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libx264-116: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavcodec53: Зависит: libva1 (> 1.0.12~) но его установка не запланирована.
                Зависит: libvo-aacenc0 (>= 0.1.0~rc1) который является виртуальным пакетом.
                Зависит: libvo-amrwbenc0 который является виртуальным пакетом.
                ПредЗависит: multiarch-support который является виртуальным пакетом.
  libmp3lame0: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc-nox: Зависит: libasound2 (> 1.0.24.1) но установлен 1.0.23-2.1
           Зависит: libdvbpsi7 (>= 0.2.0) который является виртуальным пакетом.
           Зависит: libebml3 который является виртуальным пакетом.
           Зависит: libgnutls26 (>= 2.12.6.1-0) но установлен 2.8.6-1
           Зависит: libgpg-error0 (>= 1.10) но установлен 1.6-1
           Зависит: libmatroska4 который является виртуальным пакетом.
           Зависит: libmtp9 (>= 1.1.0) который является виртуальным пакетом.
           Зависит: libstdc++6 (>= 4.6) но установлен 4.4.5-8
           Зависит: libtag1c2a (>= 1.7) но установлен 1.6.3-1
  vlc-plugin-notify: Зависит: libgdk-pixbuf2.0-0 (>= 2.22.0) который является виртуальным пакетом.
                     Зависит: libnotify4 (>= 0.7.0) который является виртуальным пакетом.
  libpostproc51: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavformat53: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc: Зависит: libqtcore4 (>= 4:4.7.0~beta1) но установлен 4:4.6.3-4+squeeze1
       Зависит: libstdc++6 (>= 4.6) но установлен 4.4.5-8
       Зависит: libtar0 который является виртуальным пакетом.
       Зависит: libva-x11-1 (> 1.0.12~) но его установка не запланирована.
       Зависит: libva1 (> 1.0.12~) но его установка не запланирована.
       Зависит: libxcb-keysyms1 (>= 0.3.8) но его установка не запланирована.
  libxvidcore4: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc-plugin-pulse: Зависит: libpulse0 (>= 0.9.23) но установлен 0.9.21-3+squeeze1
  libfaac0: ПредЗависит: multiarch-support который является виртуальным пакетом.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                         
1)      libpostproc51                                   

      Сохранить для следующих пакетов их текущие версии:
2)      libavcodec53 [Не установлен]                   
3)      libavformat53 [Не установлен]                   
4)      libavutil51 [Не установлен]                     
5)      libfaac0 [Не установлен]                       
6)      libmp3lame0 [Не установлен]                     
7)      libswscale2 [Не установлен]                     
8)      libx264-116 [Не установлен]                     
9)      libxvidcore4 [Не установлен]                   
10)     vlc [Не установлен]                             
11)     vlc-nox [Не установлен]                         
12)     vlc-plugin-notify [Не установлен]               
13)     vlc-plugin-pulse [Не установлен]               



Принять данное решение? [Y/n/q/?]

И дальше ничего... Как исправить  проблему?
 

Оффлайн Metrix

  • Сообщений: 486
  • Jabber: metrix-ds@jabber.ru
Re: [РЕШЕНО] Установка плееров
« Ответ #5 : 28 Сентябрь 2011, 15:46:54 »
При попытке установить любой плеер, к примеру vlc, получается вот что:

sudo aptitude install vlc

[spoiler]Следующие НОВЫЕ пакеты будут установлены:       
  liba52-0.7.4{a} libass4{a} libavcodec53{ab} libavformat53{ab} libavutil51{ab} libcddb2{a} libdc1394-22{a} libdca0{a} libdirectfb-1.2-9{a} libdvdnav4{a} libdvdread4{a}
  libenca0{a} libfaac0{ab} libiso9660-7{a} libkate1{a} liblircclient0{a} libmp3lame0{ab} libmpeg2-4{a} librtmp0{a} libsdl-image1.2{a} libsdl1.2debian{a}
  libsdl1.2debian-alsa{a} libsvga1{a} libswscale2{ab} libsysfs2{a} libts-0.0-0{a} libupnp3{a} libvcdinfo0{a} libvlc5{a} libvlccore4{a} libx264-116{ab} libx86-1{a}
  libxcb-randr0{a} libxcb-shm0{a} libxcb-xv0{a} libxvidcore4{ab} tsconf{a} vlc{b} vlc-data{a} vlc-nox{ab} vlc-plugin-notify{ab} vlc-plugin-pulse{ab}
Следующие пакеты будут обновлены:
  libpostproc51{b}
1 пакетов обновлено, 42 установлено новых, 0 пакетов отмечено для удаления, и 36 пакетов не обновлено.
Необходимо получить 10,7 MB/19,8 MB архивов. После распаковки 57,1 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libswscale2: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavutil51: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libx264-116: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavcodec53: Зависит: libva1 (> 1.0.12~) но его установка не запланирована.
                Зависит: libvo-aacenc0 (>= 0.1.0~rc1) который является виртуальным пакетом.
                Зависит: libvo-amrwbenc0 который является виртуальным пакетом.
                ПредЗависит: multiarch-support который является виртуальным пакетом.
  libmp3lame0: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc-nox: Зависит: libasound2 (> 1.0.24.1) но установлен 1.0.23-2.1
           Зависит: libdvbpsi7 (>= 0.2.0) который является виртуальным пакетом.
           Зависит: libebml3 который является виртуальным пакетом.
           Зависит: libgnutls26 (>= 2.12.6.1-0) но установлен 2.8.6-1
           Зависит: libgpg-error0 (>= 1.10) но установлен 1.6-1
           Зависит: libmatroska4 который является виртуальным пакетом.
           Зависит: libmtp9 (>= 1.1.0) который является виртуальным пакетом.
           Зависит: libstdc++6 (>= 4.6) но установлен 4.4.5-8
           Зависит: libtag1c2a (>= 1.7) но установлен 1.6.3-1
  vlc-plugin-notify: Зависит: libgdk-pixbuf2.0-0 (>= 2.22.0) который является виртуальным пакетом.
                     Зависит: libnotify4 (>= 0.7.0) который является виртуальным пакетом.
  libpostproc51: ПредЗависит: multiarch-support который является виртуальным пакетом.
  libavformat53: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc: Зависит: libqtcore4 (>= 4:4.7.0~beta1) но установлен 4:4.6.3-4+squeeze1
       Зависит: libstdc++6 (>= 4.6) но установлен 4.4.5-8
       Зависит: libtar0 который является виртуальным пакетом.
       Зависит: libva-x11-1 (> 1.0.12~) но его установка не запланирована.
       Зависит: libva1 (> 1.0.12~) но его установка не запланирована.
       Зависит: libxcb-keysyms1 (>= 0.3.8) но его установка не запланирована.
  libxvidcore4: ПредЗависит: multiarch-support который является виртуальным пакетом.
  vlc-plugin-pulse: Зависит: libpulse0 (>= 0.9.23) но установлен 0.9.21-3+squeeze1
  libfaac0: ПредЗависит: multiarch-support который является виртуальным пакетом.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                         
1)      libpostproc51                                   

      Сохранить для следующих пакетов их текущие версии:
2)      libavcodec53 [Не установлен]                   
3)      libavformat53 [Не установлен]                   
4)      libavutil51 [Не установлен]                     
5)      libfaac0 [Не установлен]                       
6)      libmp3lame0 [Не установлен]                     
7)      libswscale2 [Не установлен]                     
8)      libx264-116 [Не установлен]                     
9)      libxvidcore4 [Не установлен]                   
10)     vlc [Не установлен]                             
11)     vlc-nox [Не установлен]                         
12)     vlc-plugin-notify [Не установлен]               
13)     vlc-plugin-pulse [Не установлен]               



Принять данное решение? [Y/n/q/?]

И дальше ничего... Как исправить  проблему?

Какой дистрбутив? И выложи /etc/apt/sources.list
« Последнее редактирование: 28 Сентябрь 2011, 15:51:01 от Metrix »
Юзербар в отпуске
 

Оффлайн zen1tfan

  • Сообщений: 14
Re: [РЕШЕНО] Установка плееров
« Ответ #6 : 28 Сентябрь 2011, 16:00:48 »
Debian Squeeze

/etc/apt/sources.list

#

# deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64 CD Binary-1 20110626-16:33]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64 CD Binary-1 20110626-16:33]/ squeeze main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ squeeze/updates main contrib
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ squeeze/updates main contrib

# Line commented out by installer because it failed to verify:
#deb ://volatile.debian.org squeeze-updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src ://volatile.debian.org squeeze-updates main contrib

# Main repo's
deb http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ squeeze main
deb http://volatile.debian.org/debian-volatile squeeze/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile squeeze/volatile main contrib

# Multimedia
deb http://www.debian-multimedia.org stable main
deb ftp://ftp.debian-multimedia.org stable main
deb http://www.debian-multimedia.org testing main
deb ftp://ftp.debian-multimedia.org testing main

# Yandex
deb http://mirror.yandex.ru/debian squeeze main contrib non-free
deb http://mirror.yandex.ru/debian-multimedia/ squeeze main
deb http://ftp.debian.org/debian/ squeeze main

# Google
deb http://dl.google.com/linux/deb/ stable non-free

# Skype
deb http://download.skype.com/linux/repos/debian/ stable non-free

# Qutim
deb http://qutim.org/debian/unstable unstable main

# VLC
deb http://download.videolan.org/pub/videolan/debian sid main
deb-src http://download.videolan.org/pub/videolan/debian sid main
 

Оффлайн Metrix

  • Сообщений: 486
  • Jabber: metrix-ds@jabber.ru
Re: [РЕШЕНО] Установка плееров
« Ответ #7 : 28 Сентябрь 2011, 16:17:31 »
Понятно, закоментируй репозитории с testing, unstable, sid. У тя стабильная версия конфликтует разными ветками дебиана.
И почему у тя в sources.list-e присутствуют репозитории от тестинг, анстейбл и сид ???? Удали их вообще
После
# aptitude update
# aptitude install vlc

Сообщение объединено: 28 Сентябрь 2011, 16:20:33
Еще если ты хочешь поставить пакеты из других веток, надо для каждой программы приоритет задавать. Но думаю проблемы будут с зависимостями
« Последнее редактирование: 28 Сентябрь 2011, 16:20:33 от Metrix »
Юзербар в отпуске
 

Оффлайн zen1tfan

  • Сообщений: 14
Re: [РЕШЕНО] Установка плееров
« Ответ #8 : 28 Сентябрь 2011, 16:28:11 »
Спасибо, все заработало!
 

Теги: