Lenovo v310-15isk - не запустилось ядро из бэкпорта, 4,9.0 amd64

Автор rkanav, 01 марта 2017, 22:30:42

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

rkanav

Здравствуйте, помогите пожалуйста советом начинающему. Система: https://wiki.debian.org/InstallingDebianOn/Lenovo/IdeaPad%20300-15ISK
1) После установки не заработал wifi. Как вариант решения проблема нашел установку ядра из бэкпорта 4.6.0-amd64.
Открыть содержимое (спойлер)
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
[свернуть]
Такого в репозитории бэкпортов не было. Установил 4.9.0. Был потерян драйвер сетевой карты. При запуске системы с новым ядром зависает на инициации сетевой карты.
2) Также есть проблема с запуском gedit из под root.
3) При запуске стандартного ядра выводится сообщение вроде "platform creation failed ms:0101"
Проблемы расположены по степени значимости.
  •  

Aalexeey

https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  
    Users thanked this post: rkanav


Aalexeey

#3
Цитата: rkanav от 01 марта 2017, 23:30:41в чем может быть проблема при загрузке
Для начала установите firmware, я бы установил все какие есть чтоб наверняка отсечь проблемы с драйверами. Хорошо что вы оставили старое ядро, многие по неопытности его сразу удаляют, я так понял что с ним у вас система как то но грузится?
Сейчас посмотрел у меня в ядре 4.4 драйвер realtek r8169 есть, если бы у вас с 4.4 заработало, то на нём бы и остановился, оно LTS и при этом очень удачное.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

rkanav

Цитата: Aalexeey от 01 марта 2017, 23:36:54
Цитата: rkanav от 01 марта 2017, 23:30:41в чем может быть проблема при загрузке
Для начала установите firmware, я бы установил все какие есть чтоб наверняка отсечь проблемы с драйверами. Хорошо что вы оставили старое ядро, многие по неопытности его сразу удаляют, я так понял что с ним у вас система как то но грузится?
Да, с ним корректно грузится. Firmware не ставится - possible missing (если ставить пакет firmware-non-free)
  •  

Aalexeey

Вот такие у меня firmware:
firmware-amd-graphics                 
firmware-atheros               
firmware-bnx2                 
firmware-bnx2x                 
firmware-brcm80211                   
firmware-cavium                 
firmware-intel-sound                                     
firmware-intelwimax                 
firmware-ipw2x00               
firmware-ivtv                 
firmware-iwlwifi                   
firmware-libertas                 
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree                   
firmware-misc-nonfree                   
firmware-myricom                   
firmware-netxen                   
firmware-qlogic                   
firmware-realtek                   
firmware-samsung                   
firmware-siano                   
firmware-ti-connectivity

Места они много не занимают зато если будете добавлять или менять оборудование то избежите танцев с ....
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

rkanav

Цитата: Aalexeey от 01 марта 2017, 23:50:37
Вот такие у меня firmware:
firmware-amd-graphics                 
firmware-atheros               
firmware-bnx2                 
firmware-bnx2x                 
firmware-brcm80211                   
firmware-cavium                 
firmware-intel-sound                                     
firmware-intelwimax                 
firmware-ipw2x00               
firmware-ivtv                 
firmware-iwlwifi                   
firmware-libertas                 
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree                   
firmware-misc-nonfree                   
firmware-myricom                   
firmware-netxen                   
firmware-qlogic                   
firmware-realtek                   
firmware-samsung                   
firmware-siano                   
firmware-ti-connectivity

Места они много не занимают зато если будете добавлять или менять оборудование то избежите танцев с ....
Теперь не запускается и со старым ядром. Останавливается после инициализации bluetooth
  •  

Aalexeey

А с новым ядром грузится? Вы все firmware поставили.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

rkanav

#8
Цитата: Aalexeey от 01 марта 2017, 23:57:46
А с новым ядром грузится? Вы все firmware поставили.
Поставить не успел - выключил на период, пока искал зарядник. С новым - тоже не грузится.

Cообщение объединено 02 марта 2017, 00:09:08

с новым - моргает индикатор ввода, но реагирует только на ctrl+alt+del
  •  

Aalexeey

#9
Вам надо загрузится в безопасный режим (recovery mode) и в консоли ввести от root:
apt-get update && apt-get install firmware-linux-nonfree
если firmware-linux-nonfree у вас не установлен. Можно так-же повторить со всеми firmware, если продолжит не запускаться.
firmware-amd-graphics
firmware-intel-sound
firmware-iwlwifi
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree
firmware-realtek

Думаю это для вашего нотбука минимальный набор.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

rkanav

Цитата: Aalexeey от 02 марта 2017, 00:15:17
Вам надо загрузится в безопасный режим (recovery mode) и в консоли ввести от root:
apt-get update && apt-get install firmware-linux-nonfree
если firmware-linux-nonfree у вас не установлен. Можно так-же повторить со всеми firmware, если продолжит не запускаться.
firmware-amd-graphics
firmware-intel-sound
firmware-iwlwifi
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree
firmware-realtek

Думаю это для вашего нотбука минимальный набор.
- Рекавери запускает только новое ядро. Первый пакет не ставится. В командной строке вместо комментариев система оставляет квадраты
  •  

Aalexeey

Попробуйте установить/переустановить xserver-xorg-video-fbdev говорят это поможет читать кирилицу в ответах консоли, ещё переустановите/установите xserver-xorg-video-vesa
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

rkanav

#12
Цитата: Aalexeey от 02 марта 2017, 01:16:26
Попробуйте установить/переустановить xserver-xorg-video-fbdev говорят это поможет читать кирилицу в ответах консоли, ещё переустановите/установите xserver-xorg-video-vesa
судя по-всему не пашет сеть (проводное подключение)
  •  

Aalexeey

#13
Возможно. Все профи по консолям спят уже давно. При установке для Debian'а лучше сразу готовить на флэшке firmwar'ы оборудования на борту (из одного источника, например все из родного репа либо все из бэкпортов), т.к. они есть не во всех образах либо устарели. Во время установки там меню предлагает добавить такие заготовленные пакеты.
Вот здесь: https://debianforum.ru/index.php?topic=6879 почитайте как можно создавать образ системы, это вам сейчас не поможет но могло бы помочь быстро вернуть всё на момент свежеустановленной системы, если бы вы создали тогда образ (аналогично с Акронисом). Если возникнут вопросы по той теме там задавайте с удовольствием расскажу как.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
  •  

qupl

Автор, пройдите по ссылке в моей подписи "Как искать и как спрашивать."  Нет информации о том, что у вас установлено, списке источников,железе ит.д.