Автор Тема: Lenovo v310-15isk - не запустилось ядро из бэкпорта, 4,9.0 amd64  (Прочитано 7223 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rkanav

Здравствуйте, помогите пожалуйста советом начинающему. Система: https://wiki.debian.org/InstallingDebianOn/Lenovo/IdeaPad%20300-15ISK
 1) После установки не заработал wifi. Как вариант решения проблема нашел установку ядра из бэкпорта 4.6.0-amd64.
Spoiler: ShowHide
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
Такого в репозитории бэкпортов не было. Установил 4.9.0. Был потерян драйвер сетевой карты. При запуске системы с новым ядром зависает на инициации сетевой карты.
2) Также есть проблема с запуском gedit из под root.
3) При запуске стандартного ядра выводится сообщение вроде "platform creation failed ms:0101"
Проблемы расположены по степени значимости.
« Последнее редактирование: 01 Марта 2017, 23:17:27 от rkanav »
 

Оффлайн Aalexeey

« Последнее редактирование: 01 Марта 2017, 23:24:44 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 
Пользователи, которые поблагодарили этот пост: rkanav


Оффлайн Aalexeey

в чем может быть проблема при загрузке
Для начала установите firmware, я бы установил все какие есть чтоб наверняка отсечь проблемы с драйверами. Хорошо что вы оставили старое ядро, многие по неопытности его сразу удаляют, я так понял что с ним у вас система как то но грузится?
Сейчас посмотрел у меня в ядре 4.4 драйвер realtek r8169 есть, если бы у вас с 4.4 заработало, то на нём бы и остановился, оно LTS и при этом очень удачное.
« Последнее редактирование: 01 Марта 2017, 23:52:47 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн rkanav

в чем может быть проблема при загрузке
Для начала установите firmware, я бы установил все какие есть чтоб наверняка отсечь проблемы с драйверами. Хорошо что вы оставили старое ядро, многие по неопытности его сразу удаляют, я так понял что с ним у вас система как то но грузится?
Да, с ним корректно грузится. Firmware не ставится - possible missing (если ставить пакет firmware-non-free)
 

Оффлайн Aalexeey

Вот такие у меня firmware:
firmware-amd-graphics                 
firmware-atheros               
firmware-bnx2                 
firmware-bnx2x                 
firmware-brcm80211                   
firmware-cavium                 
firmware-intel-sound                                     
firmware-intelwimax                 
firmware-ipw2x00               
firmware-ivtv                 
firmware-iwlwifi                   
firmware-libertas                 
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree                   
firmware-misc-nonfree                   
firmware-myricom                   
firmware-netxen                   
firmware-qlogic                   
firmware-realtek                   
firmware-samsung                   
firmware-siano                   
firmware-ti-connectivity
Места они много не занимают зато если будете добавлять или менять оборудование то избежите танцев с ....
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн rkanav

Вот такие у меня firmware:
firmware-amd-graphics                 
firmware-atheros               
firmware-bnx2                 
firmware-bnx2x                 
firmware-brcm80211                   
firmware-cavium                 
firmware-intel-sound                                     
firmware-intelwimax                 
firmware-ipw2x00               
firmware-ivtv                 
firmware-iwlwifi                   
firmware-libertas                 
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree                   
firmware-misc-nonfree                   
firmware-myricom                   
firmware-netxen                   
firmware-qlogic                   
firmware-realtek                   
firmware-samsung                   
firmware-siano                   
firmware-ti-connectivity
Места они много не занимают зато если будете добавлять или менять оборудование то избежите танцев с ....
Теперь не запускается и со старым ядром. Останавливается после инициализации bluetooth
 

Оффлайн Aalexeey

А с новым ядром грузится? Вы все firmware поставили.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн rkanav

А с новым ядром грузится? Вы все firmware поставили.
Поставить не успел - выключил на период, пока искал зарядник. С новым - тоже не грузится.

Cообщение объединено 02 Марта 2017, 00:09:08
с новым - моргает индикатор ввода, но реагирует только на ctrl+alt+del
« Последнее редактирование: 02 Марта 2017, 00:09:08 от rkanav »
 

Оффлайн Aalexeey

Вам надо загрузится в безопасный режим (recovery mode) и в консоли ввести от root:
apt-get update && apt-get install firmware-linux-nonfreeесли firmware-linux-nonfree у вас не установлен. Можно так-же повторить со всеми firmware, если продолжит не запускаться.
firmware-amd-graphics
firmware-intel-sound
firmware-iwlwifi
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree
firmware-realtek
Думаю это для вашего нотбука минимальный набор.
« Последнее редактирование: 02 Марта 2017, 00:44:44 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн rkanav

Вам надо загрузится в безопасный режим (recovery mode) и в консоли ввести от root:
apt-get update && apt-get install firmware-linux-nonfreeесли firmware-linux-nonfree у вас не установлен. Можно так-же повторить со всеми firmware, если продолжит не запускаться.
firmware-amd-graphics
firmware-intel-sound
firmware-iwlwifi
firmware-linux                 
firmware-linux-free                       
firmware-linux-nonfree
firmware-realtek
Думаю это для вашего нотбука минимальный набор.
- Рекавери запускает только новое ядро. Первый пакет не ставится. В командной строке вместо комментариев система оставляет квадраты
 

Оффлайн Aalexeey

Попробуйте установить/переустановить xserver-xorg-video-fbdev говорят это поможет читать кирилицу в ответах консоли, ещё переустановите/установите xserver-xorg-video-vesa
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн rkanav

Попробуйте установить/переустановить xserver-xorg-video-fbdev говорят это поможет читать кирилицу в ответах консоли, ещё переустановите/установите xserver-xorg-video-vesa
судя по-всему не пашет сеть (проводное подключение)
« Последнее редактирование: 02 Марта 2017, 01:24:57 от rkanav »
 

Оффлайн Aalexeey

Возможно. Все профи по консолям спят уже давно. При установке для Debian'а лучше сразу готовить на флэшке firmwar'ы оборудования на борту (из одного источника, например все из родного репа либо все из бэкпортов), т.к. они есть не во всех образах либо устарели. Во время установки там меню предлагает добавить такие заготовленные пакеты.
Вот здесь: https://debianforum.ru/index.php?topic=6879 почитайте как можно создавать образ системы, это вам сейчас не поможет но могло бы помочь быстро вернуть всё на момент свежеустановленной системы, если бы вы создали тогда образ (аналогично с Акронисом). Если возникнут вопросы по той теме там задавайте с удовольствием расскажу как.
« Последнее редактирование: 02 Марта 2017, 01:42:57 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн qupl

Автор, пройдите по ссылке в моей подписи "Как искать и как спрашивать."  Нет информации о том, что у вас установлено, списке источников,железе ит.д.

Теги:
     

    [Решено] Установка Debian 8.1 на Lenovo B590

    Автор sagekrite

    Ответов: 6
    Просмотров: 3915
    Последний ответ 10 Июля 2015, 10:03:57
    от sagekrite
    [РЕШЕНО] debian 8.1 на lenovo e555 загружается как хочет

    Автор torm84

    Ответов: 8
    Просмотров: 2453
    Последний ответ 23 Августа 2015, 10:57:51
    от torm84
    Невозможно регулировать яркость дисплея на Lenovo Y540 с картой Nvidia

    Автор user0k

    Ответов: 8
    Просмотров: 334
    Последний ответ 04 Сентября 2021, 09:51:36
    от user0k