Автор Тема: Не загружается система.Сообщение "Fixing recursive fault but reboot is needed!"  (Прочитано 4513 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zenoxx

Здравствуйте! Имеется ноутбук с двумя HDD.На первом установлена Win 7, на втором Debian 9 xfce. HDD на котором установлена Win 7 разбит на два логических раздела.В BIOS первичной загрузкой выставлен HDD c Win 7. Загрузчик Linux установлен в основной раздел первого HDD. При включении ноутбука Debian не загружается и появляется сообщение "Fixing recursive fault but reboot is needed!". Чтобы загрузить Debian приходится несколько раз выключать и включать ноут. Может кто-нибудь сталкивался с подобной проблемой?
20171203_150435.jpg
 

Оффлайн ecc83

На первом установлена Win 7, на втором Debian 9 xfce. Загрузчик Linux установлен в основной раздел первого HDD.

У вас груб биосу или биос грубу кружат "мозги" и они путаются.

Что по вашему означает "основной раздел"? Загрузчик Grub должен устанавливаться не на раздел, а на диск.

Мне не понятно, зачем вам устанавливать загрузчик на диск с Windows, если Debian на другом физическом диске?
Предлагаю переустановить Grub на диск где установлен Debian, а потом выставить его в BIOS первым в загрузке.
С него же потом можно будет загружать Windows 7.

При установке указывается устройство, а не раздел например:

sudo grub-install /dev/sdb
sudo update-grub


 

Оффлайн Zenoxx

Спасибо за совет! Действительно,проблема была в конфликте между GRUBом и BIOSом. Переустановил GRUB на диск с Linux - проблема решилась.
 

Оффлайн Zenoxx

К сожалению проблема вернулась.Пару дней работал нормально,затем всё по новой.Судя по всему он при загрузке не может обнаружить разделы.С чем это связано ума не приложу.Загрузчик установлен на диск с Линуксом ???
Ошибка.jpg
 

Оффлайн ferum

В теме https://debianforum.ru/index.php?topic=13401.0 человек заявлял что подобные проблемы решаются через граб кастомайзер Пакет для него я собрал https://yadi.sk/d/l7CCa5QJ3Q6dnk Он скачан трижды с яндекса но ни кто не хорошо не плохо не отписался.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ecc83

Судя по всему он при загрузке не может обнаружить разделы.

для начала выполни команду:

sudo blkid -c /dev/null
Сохрани результат, открой fstab и внимательно проверь все UUID всех дисков на соответствие.

Вообще то есть подозрение на аппаратную проблему. Может разъём подключения диска барахлит...


Он скачан трижды с яндекса но ни кто не хорошо не плохо не отписался.

Я тоже скачал. Пробовал, работает ;)
 

Оффлайн Zenoxx

Проблема решена путем изменения параметра строки GRUB_CMDLINE_LINUX_DEFAULT  в /etc/default/grub на "quiet splash acpi=off". Всем спасибо!
 

Теги:
     

    Не загружается

    Автор Angus123

    Ответов: 11
    Просмотров: 3117
    Последний ответ 23 Мая 2014, 06:34:52
    от ihammers
    Не загружается машина

    Автор Missme

    Ответов: 0
    Просмотров: 901
    Последний ответ 15 Апреля 2018, 15:36:31
    от Missme
    Не загружается GUI XFCE

    Автор VL_Light

    Ответов: 2
    Просмотров: 732
    Последний ответ 21 Июня 2020, 15:21:35
    от VL_Light
    [Решено] LMDE не загружается после обновления.

    Автор uRodETs

    Ответов: 12
    Просмотров: 4615
    Последний ответ 21 Октября 2012, 04:45:27
    от vladimir_ar
    [РЕШЕНО] debian 8.1 на lenovo e555 загружается как хочет

    Автор torm84

    Ответов: 8
    Просмотров: 2609
    Последний ответ 23 Августа 2015, 10:57:51
    от torm84