Автор Тема: Debian устанавливается но не запускается.  (Прочитано 1600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Anty666

  • Новичок форума
  • Сообщений: 4
Всем привет. :)
Собственно вопрос: как это заставить работать?
_________________________________
Ставлю вот это: debian-10.7.0-i386-netinst. Ставлю на img-образ находящийся в телефоне и примонтированный в качестве съёмного накопителя. Windows10x64Pro читает съёмный накопитель корректно. Ровно как и все её компоненты. В BiOS устройство хранения так же определяется как надо. Для сравнения. LiveCD с установочником Windows10x64\x32 запускается без вопросов. Со Slax так же без проблем. То есть, как я полагаю, примонтированно всё как надо и работает корректно. К слову, безопасная загрузка и быстрая загрузка в BiOS отключены.
_________________________________
Пробовал ставить и на прямую с установочного носителя в BiOS и через VirtualBOX. Результат всегда один. Независимо от способа установки Система грузится в виртуальной машине и не грузится на ПК.
Пробовал в GRUB нажимать "E" подбирать носитель и нажимать "F10". Всё одно.
_________________________________
В качестве примера буду использовать установку через виртуальную машину, поскольку разницы замечено не было.
Устройство:: ShowHide

* 2_Flash.png (Filesize: 4.19 КБ, Dimensions: 1603x68)

Настройки виртуальной машины:: ShowHide
 

* 1_Настройки_VirtualBox.png (Filesize: 25.33 КБ, Dimensions: 541x747)

Установка проходит в обычном режиме без каких либо ошибок. Пробовал устанавливать и из графического режима и из устаревшего. Всё одинаково. В качестве файловой системы выбираю Ext2. Так же пробовал использовать и Ext4, и Btrfs. Опять же, разницы не было. Пробовал на файловых системах отключать журналирование, и без отключения. Всю систему ставлю в один раздел. Вынос /home на отдельный раздел, а так же использование раздела подкачки проблему не решает. Пробовал ставить систему и на логический раздел и на первичный. Пробовал выставлять разделу метку: Загрузочный. Безрезультатно.
В итоге система установлена...
Загрузка системы в виртуальной машины:: ShowHide
 

* 5_VirtualBox_Loading.png (Filesize: 46.64 КБ, Dimensions: 1208x727)

...и загружается
Система в виртуальной машине: ShowHide
 

* 6_Virtual_Machine.png (Filesize: 34.71 КБ, Dimensions: 800x675)


... продолжу во втором сообщении из-за ограничений на вложения.
« Последнее редактирование: 22 Января 2021, 03:25:48 от Anty666 »
 

Оффлайн Anty666_2

  • Новичок форума
  • Сообщений: 1
Re: Debian устанавливается но не запускается.
« Ответ #1 : 22 Января 2021, 03:06:51 »
Off-Topic: ShowHide
склеивает мои сообщения и не даёт возможность добавить новые вложения... как отменить склейку не нашёл. так что зарегал ещё одну страницу.

и так...
Пробую перезагрузить ПК и загрузиться в только что установленный Debian
Выбор устройства:: ShowHide
 

* 7_Выбор-устройства.jpg (Filesize: 13.91 КБ, Dimensions: 500x375)

Загружается GRUB
Выбор системы:: ShowHide
 

* 8_Выбор_системы.jpg (Filesize: 6.58 КБ, Dimensions: 500x375)

В итоге всё падает с такими вот ошибками. Без перезагрузки и реакции на команды с клавиатуры.
EROR:: ShowHide
 

* 9_Загрузка_системы.jpg (Filesize: 91.42 КБ, Dimensions: 777x680)
 

* 10_Загрузка_системы.jpg (Filesize: 72.08 КБ, Dimensions: 960x720)
 

* 11_Загрузка_системы.jpg (Filesize: 80.28 КБ, Dimensions: 960x720)

В итоге приходится перезагружать ПК непосредственно кнопкой.

...
« Последнее редактирование: 22 Января 2021, 03:29:10 от Anty666_2 »
 

Оффлайн Anty666

  • Новичок форума
  • Сообщений: 4
Re: Debian устанавливается но не запускается.
« Ответ #2 : 22 Января 2021, 03:13:51 »
...
В загрузчике GRUB следующие параметры:: ShowHide
 

* 13_Свойства_Grub.jpg (Filesize: 36.18 КБ, Dimensions: 960x720)
 

* 14_Свойства_Grub.jpg (Filesize: 18.54 КБ, Dimensions: 960x720)


Так что как-то так. Не знаю, что делать. Прошу помощи.
« Последнее редактирование: 22 Января 2021, 03:31:50 от Anty666 »
 

Оффлайн qupl

Re: Debian устанавливается но не запускается.
« Ответ #3 : 22 Января 2021, 05:33:13 »
Что за раздел /dev/sdc1 ?  Ошибки файловой системы, проверьте диск на ошибки.

Оффлайн Anty666

  • Новичок форума
  • Сообщений: 4
Re: Debian устанавливается но не запускается.
« Ответ #4 : 22 Января 2021, 16:00:03 »
Что за раздел /dev/sdc1 ?
Собственно раздел на который установлена система.
Ошибки файловой системы, проверьте диск на ошибки.
Почему тогда при загрузке в виртуальной машине нет этих ошибок?
Наверное я чего-то не понимаю. Но, система у меня лежит на Ext2. А ошибки говорят о Ext4. Предположу, что каким-то макаром загрузчик пытается прочитать файловую систему которой нет. Возможно нужно поправить какие-то записи в нём?
« Последнее редактирование: 22 Января 2021, 16:04:43 от Anty666 »
 

Оффлайн dzhoser

Re: Debian устанавливается но не запускается.
« Ответ #5 : 22 Января 2021, 16:24:25 »
  При загрузке grub нужно выбрать дополнительные параметры и в свойствах grub (13 скриншот)
После параметра "ro quet splash" через пробел дописать init=/bin/bash и нажать F10.
После загрузки командной строки выполнить команду blkid в ее выводе определить раздел на который установлен debian
Выполнить команду fsck.ext4 /dev/sdc1 -f
sdc1 тут для примера следует использовать данные из предыдущей команды.
Для перезагрузи выполнить команду reboot и попробовать загрузится
Помогаю за спасибо!
 

Оффлайн Anty666

  • Новичок форума
  • Сообщений: 4
Re: Debian устанавливается но не запускается.
« Ответ #6 : 23 Января 2021, 01:30:45 »
попробовать загрузится
Спасибо большое. В ближайшее время попробую и отпишусь о результате.
 

Оффлайн ZulC_Silence

Re: Debian устанавливается но не запускается.
« Ответ #7 : 24 Января 2021, 12:03:11 »
Буду краток.
По сообщениям об ошибках при загрузке ОС,написано что происходит ошибка ввода/вывода (I/O error), последующий процесс инициализации системы прерывается из-за наличия битых кластеров на диске (logical block on sdc1 № xxxxxx),далее система запинается на месте загрузки файловой системы Ext4  на устройстве sdc1.

Если в своём диске вы уверены,что он 100%-но рабочий.То советую искать решение в grub.
А именно запуститься без графической оболочки ,чисто в текстовом режиме и посмотреть какие ошибки выдаст при загрузке.
 

Оффлайн Дима Скоков

Re: Debian устанавливается но не запускается.
« Ответ #8 : 10 Февраля 2021, 18:09:43 »
Не определяется накопитель, похоже,
Возможно, что при установке происходит инициализация накопителей по другому чем в BIOS.
После перезагрузки накопитель по этому месту не доступен.
Возможно BIOS включает эмуляцию HDD или CD-ROM.
У меня похожая проблема:
https://debianforum.ru/index.php/topic,16397.0.html
 

 

[Решено] nvidia GT240 и debian

Автор orthodox

Ответов: 17
Просмотров: 8650
Последний ответ 11 Июня 2013, 13:21:45
от Brainey
Debian + xfce на 32Gb eMMC

Автор LionDeb

Ответов: 7
Просмотров: 3011
Последний ответ 14 Сентября 2015, 15:32:14
от LionDeb
загрузочный usb-flash для установки debian-9

Автор neodebian

Ответов: 8
Просмотров: 5676
Последний ответ 29 Сентября 2017, 12:46:50
от user89
Как обновиться до Debian 10?

Автор lionet

Ответов: 7
Просмотров: 1901
Последний ответ 05 Января 2020, 14:34:17
от PbI6A
Чем черевата установка Debian 32bit на AMD64?

Автор Leo

Ответов: 41
Просмотров: 10972
Последний ответ 20 Октября 2015, 01:41:49
от maslakovvi