Автор Тема: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev  (Прочитано 7737 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Здравтсвуйте. Как использовать по умолчанию xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev? Пробовал удалить fbdev - иксы не стартуют.
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #1 : 27 Января 2014, 19:40:06 »
Прописать /etc/X11/xorg.conf.d/ ?
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #2 : 27 Января 2014, 19:44:10 »
Прописать /etc/X11/xorg.conf.d/ ?
ls /etc/X11/xorg.conf.d/
ls: cannot access /etc/X11/xorg.conf.d/: No such file or directory

Создать папку и где именно прописывать и что?
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #3 : 27 Января 2014, 20:20:15 »
Создавайте. В новых версиях ее вроде нет.
Код: (/etc/X11/xorg.conf.d/20-modesetting.conf) [Выделить]
Section "Device"
Identifier  "Device0"
Driver      "modesetting"
EndSection
Как-то так. Если не секрет - зачем оно Вам?
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #4 : 27 Января 2014, 20:21:33 »

Как-то так. Если не секрет - зачем оно Вам?
GMA3600

Сообщение объединено: 27 Января 2014, 20:26:18
При создании файла в /etc/X11/xorg.conf.d появляется проблема, привожу xorg.0.log:
[  4802.346]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[  4802.355] X Protocol Version 11, Revision 0
[  4802.359] Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
[  4802.362] Current Operating System: Linux crunchbang 3.2.0-4-486 #1 Debian 3.2.51-1 i686
[  4802.362] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-486 root=UUID=d8dea59f-47b5-4dbf-91ae-bf7961fdff79 ro quiet
[  4802.369] Build Date: 17 December 2013  08:37:13PM
[  4802.373] xorg-server 2:1.12.4-6+deb7u2 (Julien Cristau <jcristau@debian.org>)
[  4802.376] Current version of pixman: 0.26.0
[  4802.384] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[  4802.384] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4802.400] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 27 20:23:17 2014
[  4802.405] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  4802.409] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4802.409] (==) No Layout section.  Using the first Screen section.
[  4802.409] (==) No screen section available. Using defaults.
[  4802.409] (**) |-->Screen "Default Screen Section" (0)
[  4802.409] (**) |   |-->Monitor "<default monitor>"
[  4802.410] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[  4802.410] (**) |   |-->Device "Device0"
[  4802.410] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[  4802.410] (==) Automatically adding devices
[  4802.410] (==) Automatically enabling devices
[  4802.410] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  4802.410] Entry deleted from font path.
[  4802.410] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[  4802.410] Entry deleted from font path.
[  4802.410] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[  4802.410] (==) ModulePath set to "/usr/lib/xorg/modules"
[  4802.410] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4802.411] (II) Loader magic: 0xb77805a0
[  4802.411] (II) Module ABI versions:
[  4802.411] X.Org ANSI C Emulation: 0.4
[  4802.411] X.Org Video Driver: 12.1
[  4802.411] X.Org XInput driver : 16.0
[  4802.411] X.Org Server Extension : 6.0
[  4802.412] (--) PCI:*(0:0:2:0) 8086:0be1:144d:c614 rev 9, Mem @ 0xdfc00000/1048576, I/O @ 0x0000f100/8
[  4802.412] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  4802.412] (II) LoadModule: "extmod"
[  4802.414] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  4802.414] (II) Module extmod: vendor="X.Org Foundation"
[  4802.414] compiled for 1.12.4, module version = 1.0.0
[  4802.414] Module class: X.Org Server Extension
[  4802.414] ABI class: X.Org Server Extension, version 6.0
[  4802.414] (II) Loading extension SELinux
[  4802.414] (II) Loading extension MIT-SCREEN-SAVER
[  4802.415] (II) Loading extension XFree86-VidModeExtension
[  4802.415] (II) Loading extension XFree86-DGA
[  4802.415] (II) Loading extension DPMS
[  4802.415] (II) Loading extension XVideo
[  4802.415] (II) Loading extension XVideo-MotionCompensation
[  4802.415] (II) Loading extension X-Resource
[  4802.415] (II) LoadModule: "dbe"
[  4802.415] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  4802.416] (II) Module dbe: vendor="X.Org Foundation"
[  4802.416] compiled for 1.12.4, module version = 1.0.0
[  4802.416] Module class: X.Org Server Extension
[  4802.416] ABI class: X.Org Server Extension, version 6.0
[  4802.416] (II) Loading extension DOUBLE-BUFFER
[  4802.416] (II) LoadModule: "glx"
[  4802.417] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  4802.417] (II) Module glx: vendor="X.Org Foundation"
[  4802.417] compiled for 1.12.4, module version = 1.0.0
[  4802.417] ABI class: X.Org Server Extension, version 6.0
[  4802.417] (==) AIGLX enabled
[  4802.417] (II) Loading extension GLX
[  4802.417] (II) LoadModule: "record"
[  4802.418] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  4802.418] (II) Module record: vendor="X.Org Foundation"
[  4802.418] compiled for 1.12.4, module version = 1.13.0
[  4802.418] Module class: X.Org Server Extension
[  4802.418] ABI class: X.Org Server Extension, version 6.0
[  4802.418] (II) Loading extension RECORD
[  4802.418] (II) LoadModule: "dri"
[  4802.419] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  4802.420] (II) Module dri: vendor="X.Org Foundation"
[  4802.420] compiled for 1.12.4, module version = 1.0.0
[  4802.420] ABI class: X.Org Server Extension, version 6.0
[  4802.420] (II) Loading extension XFree86-DRI
[  4802.420] (II) LoadModule: "dri2"
[  4802.421] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  4802.421] (II) Module dri2: vendor="X.Org Foundation"
[  4802.421] compiled for 1.12.4, module version = 1.2.0
[  4802.421] ABI class: X.Org Server Extension, version 6.0
[  4802.421] (II) Loading extension DRI2
[  4802.421] (II) LoadModule: "modesetting"
[  4802.421] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  4802.422] (II) Module modesetting: vendor="X.Org Foundation"
[  4802.422] compiled for 1.12.1.902, module version = 0.3.0
[  4802.422] Module class: X.Org Video Driver
[  4802.422] ABI class: X.Org Video Driver, version 12.0
[  4802.422] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  4802.422] (--) using VT number 7

[  4802.433] (WW) Falling back to old probe method for modesetting
[  4802.433] (II) UnloadModule: "modesetting"
[  4802.433] (EE) Screen(s) found, but none have a usable configuration.
[  4802.433]
Fatal server error:
[  4802.433] no screens found
[  4802.433]
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[  4802.433] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4802.433]
[  4802.469] Server terminated with error (1). Closing log file.
« Последнее редактирование: 27 Января 2014, 20:26:18 от Nedis »
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #5 : 27 Января 2014, 20:29:36 »
М-да. Согласно этой статье на дочернем дистрибутиве было бы легче. Но можно просто получить исходники пакетов и бэкпортировать для себя. Самый кошерный вариант. Долгий, трудный - но зато будете много знать о системе.

Сообщение объединено: 27 Января 2014, 20:31:00
В принципе, логично - драйвер элементарно не поддерживает карточку.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #6 : 27 Января 2014, 20:33:29 »
М-да. Согласно этой статье на дочернем дистрибутиве было бы легче. Но можно просто получить исходники пакетов и бэкпортировать для себя. Самый кошерный вариант. Долгий, трудный - но зато будете много знать о системе.
Я уже пробовал. Собрать ядро по инструкции японца-индуса из интела не получилось, выскакивала какая-то ошибка, не помню какая. И походу не получилось ни у кого из дебианщиков, т.к. успешных историй не слышал - только нытьё.

В слаке у меня на 3.10.х работало все нормально (не марцал курсор и подключался внешний монитор), но там по дефолту использовался modesetting. Сейчас попробую установить 3.10.х из бекпортов и попробовать запустить егос modesetting.
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #7 : 27 Января 2014, 20:34:17 »
Вот тут почитайте.
Измените созданный файл вот так:
Section "Device"
    Identifier "Intel GMA3600"
    Driver     "modesetting"
    Option     "Monitor-LVDS-0" "Monitor"
EndSection

Section "Monitor"
    Identifier "Monitor"
    Option     "Enable"
EndSection
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #8 : 27 Января 2014, 21:05:52 »
Xorg.0.log:
[   417.327]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[   417.337] X Protocol Version 11, Revision 0
[   417.340] Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
[   417.343] Current Operating System: Linux crunchbang 3.10-0.bpo.3-486 #1 Debian 3.10.11-1~bpo70+1 (2013-09-24) i686
[   417.343] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10-0.bpo.3-486 root=UUID=d8dea59f-47b5-4dbf-91ae-bf7961fdff79 ro quiet
[   417.351] Build Date: 17 December 2013  08:37:13PM
[   417.354] xorg-server 2:1.12.4-6+deb7u2 (Julien Cristau <jcristau@debian.org>)
[   417.358] Current version of pixman: 0.26.0
[   417.365] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[   417.365] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   417.382] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 27 21:02:41 2014
[   417.386] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   417.389] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   417.390] (==) No Layout section.  Using the first Screen section.
[   417.390] (==) No screen section available. Using defaults.
[   417.390] (**) |-->Screen "Default Screen Section" (0)
[   417.390] (**) |   |-->Monitor "<default monitor>"
[   417.391] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[   417.391] (**) |   |-->Device "Intel GMA3600"
[   417.391] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[   417.391] (==) Automatically adding devices
[   417.391] (==) Automatically enabling devices
[   417.391] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   417.391] Entry deleted from font path.
[   417.391] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   417.391] Entry deleted from font path.
[   417.391] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[   417.391] (==) ModulePath set to "/usr/lib/xorg/modules"
[   417.391] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[   417.391] (II) Loader magic: 0xb77f05a0
[   417.391] (II) Module ABI versions:
[   417.391] X.Org ANSI C Emulation: 0.4
[   417.392] X.Org Video Driver: 12.1
[   417.392] X.Org XInput driver : 16.0
[   417.392] X.Org Server Extension : 6.0
[   417.393] (--) PCI:*(0:0:2:0) 8086:0be1:144d:c614 rev 9, Mem @ 0xdfc00000/1048576, I/O @ 0x0000f100/8
[   417.393] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   417.393] (II) LoadModule: "extmod"
[   417.394] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   417.395] (II) Module extmod: vendor="X.Org Foundation"
[   417.395] compiled for 1.12.4, module version = 1.0.0
[   417.395] Module class: X.Org Server Extension
[   417.395] ABI class: X.Org Server Extension, version 6.0
[   417.395] (II) Loading extension SELinux
[   417.395] (II) Loading extension MIT-SCREEN-SAVER
[   417.395] (II) Loading extension XFree86-VidModeExtension
[   417.396] (II) Loading extension XFree86-DGA
[   417.396] (II) Loading extension DPMS
[   417.396] (II) Loading extension XVideo
[   417.396] (II) Loading extension XVideo-MotionCompensation
[   417.396] (II) Loading extension X-Resource
[   417.396] (II) LoadModule: "dbe"
[   417.396] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   417.397] (II) Module dbe: vendor="X.Org Foundation"
[   417.397] compiled for 1.12.4, module version = 1.0.0
[   417.397] Module class: X.Org Server Extension
[   417.397] ABI class: X.Org Server Extension, version 6.0
[   417.397] (II) Loading extension DOUBLE-BUFFER
[   417.397] (II) LoadModule: "glx"
[   417.398] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   417.398] (II) Module glx: vendor="X.Org Foundation"
[   417.398] compiled for 1.12.4, module version = 1.0.0
[   417.398] ABI class: X.Org Server Extension, version 6.0
[   417.398] (==) AIGLX enabled
[   417.398] (II) Loading extension GLX
[   417.398] (II) LoadModule: "record"
[   417.399] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   417.399] (II) Module record: vendor="X.Org Foundation"
[   417.399] compiled for 1.12.4, module version = 1.13.0
[   417.399] Module class: X.Org Server Extension
[   417.399] ABI class: X.Org Server Extension, version 6.0
[   417.399] (II) Loading extension RECORD
[   417.399] (II) LoadModule: "dri"
[   417.400] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   417.401] (II) Module dri: vendor="X.Org Foundation"
[   417.401] compiled for 1.12.4, module version = 1.0.0
[   417.401] ABI class: X.Org Server Extension, version 6.0
[   417.401] (II) Loading extension XFree86-DRI
[   417.401] (II) LoadModule: "dri2"
[   417.402] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   417.402] (II) Module dri2: vendor="X.Org Foundation"
[   417.402] compiled for 1.12.4, module version = 1.2.0
[   417.402] ABI class: X.Org Server Extension, version 6.0
[   417.402] (II) Loading extension DRI2
[   417.402] (II) LoadModule: "modesetting"
[   417.402] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   417.403] (II) Module modesetting: vendor="X.Org Foundation"
[   417.403] compiled for 1.12.1.902, module version = 0.3.0
[   417.403] Module class: X.Org Video Driver
[   417.403] ABI class: X.Org Video Driver, version 12.0
[   417.403] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   417.403] (--) using VT number 7

[   417.502] (WW) Falling back to old probe method for modesetting
[   417.503] (II) UnloadModule: "modesetting"
[   417.503] (EE) Screen(s) found, but none have a usable configuration.
[   417.503]
Fatal server error:
[   417.503] no screens found
[   417.503]
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[   417.503] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   417.503]
[   417.606] Server terminated with error (1). Closing log file.

Сделал так, как показали Вы, пробовал сохранять в 20-gpudriver.conf - результат аналогичен.

[offtop-mode]Надо будет отписаться в Intel и PowerVR в таком же стиле, что и Линус обращался к NVidia[/offtop-mode]
« Последнее редактирование: 27 Января 2014, 21:15:48 от Nedis »
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #9 : 27 Января 2014, 21:58:21 »
[ot]
[offtop-mode]Надо будет отписаться в Intel и PowerVR в таком же стиле, что и Линус обращался к NVidia[/offtop-mode]
Есть кнопочка offtop  в форме быстрого ответа  ;)[/ot]

Из бэкпортов иксы и ядро ставили?

[   417.390] (**) |-->Screen "Default Screen Section" (0)
[   417.390] (**) |   |-->Monitor "<default monitor>"

Судя по этим строчкам, монитор не подхватился.

Сообщение объединено: [time]28 Январь 2014, 00:00:45[/time]
Поиграйте с названием монитора. В нашем случае он называется просто LVDS, без нуля.

Сообщение объединено: 27 Января 2014, 22:03:45
До кучи, можно прибить монитор гвоздиками, как в старину:
Section "Screen"
  Identifier "Default Screen"
  Monitor "Monitor"
  Device "Intel GMA3600"
EndSection
« Последнее редактирование: 27 Января 2014, 22:03:45 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #10 : 27 Января 2014, 22:37:31 »
Нет, не помогает. Просто перейду на Windows, деваться некуда. Нет, серьезно, некуда, я перепробовал уже все что возможно.

Ubuntu - не использую принципиально.
В Debian ничего не работает.
В Слаке просто ужасное полусектантское комьюнити.
Arch - не люблю я роллинг.
Fedora - слишком нестабильна, да и третьегном, ради которого её можно поставить на этой "видео"-карте не работает.
openSUSE - я не люблю кеды, да и в основном репозитории мало ПО, да и работает достаточно нестабильно.
Gentoo - без комментариев, использовать её на нетбуке - чистой воды мазохизм.

Остается только Windows :(. Ну или как на десктопе накатить LFS, но тут тоже проблемы - см.  Gentoo.
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #11 : 27 Января 2014, 22:53:43 »
Nedis, попробуйте все же бэкпортировать пакеты из Ubuntu.

Сообщение объединено: 27 Января 2014, 22:58:53
Лежит он в репах precise-updates, секция multiverse. Версия старая, но работать должна.
« Последнее редактирование: 27 Января 2014, 22:58:53 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн ferum

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #12 : 27 Января 2014, 23:05:07 »
, попробуйте все же бэкпортировать пакеты из Ubuntu.
Я бы наверное залез в репозиторий kanotix http://www.kanotix.com/Article255.html Зря что ли они там что то модифицируют?
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Nedis

  • Пользователь
  • *
  • Сообщений: 17
Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #13 : 28 Января 2014, 14:43:57 »
Nedis, попробуйте все же бэкпортировать пакеты из Ubuntu.

Сообщение объединено: [time]27 Январь 2014, 22:58:53[/time]
Лежит он в репах precise-updates, секция multiverse. Версия старая, но работать должна.
Для дебиановского ядра это не работает. А при установке убунтовского ядра, убунтовских иксов и т.д., система наполовину превращается в убунту, а это, как понимаете, подрывает работу систему - не обновиться ни оттуда, ни отсюда.
 

Оффлайн Malaheenee

Re: xserver-xorg-video-modesetting вместо xserver-xorg-video-fbdev
« Ответ #14 : 28 Января 2014, 16:05:38 »
Nedis, бэкпорт - это пересобирание пакета из чужой системы для своей. Ссылку же дали, как делать.
Все мы где-то, когда-то и в чем-то были новичками.
 

Теги: